UVI Falcon - hybrid instrument - version 2.5 released - rumors, ads, praise and off-topic inside!

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
dakkra
KVRian
1331 posts since 4 Oct, 2012 from Utah

Post Sat Jan 09, 2021 6:16 pm

EvilDragon wrote:
Sat Jan 09, 2021 4:47 am
maximoog wrote:
Sat Jan 09, 2021 4:09 am
Finally VST3, VST2 is no longer supported on the new Apple devices.
Incorrect. VST2 can work just fine on M1 (ask FabFilter).
Speaking as a plugin dev, VST2 is a simple recompile on M1. 0 compatibility issues if your framework is generic enough.

3lu5iv3
KVRist
368 posts since 24 Sep, 2016

Post Tue Jan 12, 2021 12:04 am

Now it is possible to run standalone Falcon in Ubuntu Budgie 20.04 via Wine 6.0 RC6
i need to do more testing but everything seems to be working. :D
VSTi version also works if you use LinVST 3.5.

https://imgur.com/6pc9xHB
SoundCloud
"I believe every music producer inherently has something unique about the way they make music. They just have to identify what makes them different, and develop it" - Max Martin

User avatar
Sampleconstruct
KVRAF

Topic Starter

15723 posts since 12 Oct, 2008 from Here and there

Post Fri Jan 15, 2021 10:11 am

Using a field recording of water-drops (recorded in my garden) in UVI Falcon's granular engine, then processing the signal with feedback machine with a frequency shifter inserted in Chain 1

https://youtu.be/EPydQ5Gbgus

Kypresso
KVRist
335 posts since 26 Mar, 2014

Post Sun Jan 17, 2021 11:36 am

Any body at uvi want to give any hint as too using their products with apple m1's and big sur?

I searched the uvi website and couldn't find any info about big sur nevermind apple silicon.
Win 10, Mac Mini M1, Bitwig 4.0.1, too many plugins, Novation Circuit Mono Station and now a lovely Waldorf Blofeld.

User avatar
WatchTheGuitar
KVRAF
9350 posts since 30 Apr, 2019

Post Sun Jan 17, 2021 12:12 pm

Kypresso wrote:
Sun Jan 17, 2021 11:36 am
Any body at uvi want to give any hint as too using their products with apple m1's and big sur?

I searched the uvi website and couldn't find any info about big sur nevermind apple silicon.
I’m not at UVI, but everything suggests they’re working on it, but that they currently only support up to Catalina e.g.

https://support.uvi.net/hc/en-us/articl ... ns-Falcon-

numerouno
KVRist
108 posts since 17 Jan, 2021

Post Sun Jan 17, 2021 12:32 pm

Sampleconstruct wrote:
Fri Jan 15, 2021 10:11 am
Using a field recording of water-drops (recorded in my garden) in UVI Falcon's granular engine, then processing the signal with feedback machine with a frequency shifter inserted in Chain 1

https://youtu.be/EPydQ5Gbgus
Awesome! :clap:

otristan
KVRAF
2221 posts since 28 Mar, 2005

Post Mon Jan 18, 2021 12:23 am

Kypresso wrote:
Sun Jan 17, 2021 11:36 am
Any body at uvi want to give any hint as too using their products with apple m1's and big sur?

I searched the uvi website and couldn't find any info about big sur nevermind apple silicon.
Working on it.
I've tested it on my M1 MBP as Standalone using rosetta and it works fine.
For official ARM version, you will need to wait a bit longer as we have some dependency which are not yet working on ARM. The UVI own codebase already compile on ARM though.
Olivier Tristan
Developer - UVI Team
http://www.uvi.net

User avatar
WatchTheGuitar
KVRAF
9350 posts since 30 Apr, 2019

Post Sat Jan 23, 2021 6:12 am

(FIXED: UVI Portal had installed the latest plugin files in C:\Program Files\Steinberg\Vstplugins rather than where I normally have my plugins installed)

I seem to have an issue with the PX Memories library in Falcon. I'm on latest build of Win10Prox64 FWIW.
UVI Portal reports I have latest version of everything installed, but I'm seeing this "script was created with a more recent version of UVIScript" error dialog box on every preset I try to use
Untitled.png
To add to the fun, also bought UVI Relayer and although it went through the process of install, iLok activation etc fine it isn't showing up as an available plugin in any of my DAWs, didn't seem to write any dll anywhere.

Edit: Update. Also installed UVI Workstation for the first time in ages and it also shows the same dialog box. I guess I need to hit up UVI directly.

Update #2: Hmmm something in the support reporting process gave me pause, I never use standalone so had forgotten it exists. PX Memories is opening OK in standalone, but I get the script error on Reaper, Ableton Live, Bitwig and Studio One. So I've raised a case on the UVI support portal and see what transpires.
You do not have the required permissions to view the files attached to this post.
Last edited by WatchTheGuitar on Sat Jan 23, 2021 9:40 am, edited 1 time in total.

User avatar
EvilDragon
KVRAF
22080 posts since 7 Jan, 2009 from Croatia

Post Sat Jan 23, 2021 6:42 am

Looks like the plugin files might not have been properly updated to the latest version?

User avatar
WatchTheGuitar
KVRAF
9350 posts since 30 Apr, 2019

Post Sat Jan 23, 2021 7:28 am

EvilDragon wrote:
Sat Jan 23, 2021 6:42 am
Looks like the plugin files might not have been properly updated to the latest version?
Yes, that’s what it looks like. As I said I’ve registered both issues with support. At least I can play with the library standalone until they fix it.
Should do that more often, no DAW distractions helps focus on doing stuff within Falcon itself rather than ancillary ‘helper’ plugins. It’s much more like using a hardware synth.

trusampler
KVRian
1403 posts since 2 Jul, 2007

Post Sat Jan 23, 2021 8:31 am

Did this get updated yet?
Cpu:Win10/Intel Core i9-10900K Console:Tascam Model 24
Interface:Slate VMS/Antelope Audio Discrete 8 Synergy Core
Synths: Sequential Prophet 10|OB-6/Roland Fantom 7/Deepmind 12/Virus TI2 61//Hologram Electronics Microcosm/Akai MPC X

srcodling
KVRist
179 posts since 25 Mar, 2004 from Strasbourg, Saskatchewan, Canada

Post Sat Jan 23, 2021 8:40 am

I had the same problem. Falcon and Workstation DLL files were autoinstalled to the wrong location by uvi. Just had to move them to my proper vst folder location and all was fine.

User avatar
WatchTheGuitar
KVRAF
9350 posts since 30 Apr, 2019

Post Sat Jan 23, 2021 9:06 am

srcodling wrote:
Sat Jan 23, 2021 8:40 am
I had the same problem. Falcon and Workstation DLL files were autoinstalled to the wrong location by uvi. Just had to move them to my proper vst folder location and all was fine.
Where did it install them to in your setup? I'm searching my PC, but it's about 8 TB so takes forever.
Nice one, they'd been stuck into C:\Program Files\Steinberg\Vstplugins for some bloody reason.

That stone has killed both birds nicely as I also found my missing Relayer plugin in there! Cheers :tu:

btw anyone who has the PX Memories library, if a patch sounds tame, try the LAMM Unison option. It seems rather radical. :party:

Particularly like the sweeping patches
https://soundcloud.com/watch_the_guitar/pxmastersweep

LOL I got some feedback to my hastily assembled demo
Bro this song crazy good. To receive more exposure, send it to my website.(link to my website is in my bio and background picture)
I am quitting my job immediately and signing up with MegamusicCorp Inc.

estevancarlos
KVRer
9 posts since 27 Mar, 2008

Post Wed Feb 03, 2021 11:40 am

Not sure if this is too off topic but is there a way to assign an ADSR envelope to a delay parameter? It sounds SO reasonable. Takes two seconds to pull off in Arturia's Pigments. I can not do it in Falcon because:

1) The delay FX are not available at the keygroup level
2) The ADSRs are not functional outside the keygroup level

Am I missing something?

blowfly
KVRer
15 posts since 6 Jan, 2010

Post Wed Feb 03, 2021 2:54 pm

No, you're correct.
But there's a trick to have Delays on KG level though: use FX Racks.
But it only works with OSCs with in-built VCAs: FM Osc and Drum Osc.

Return to “Instruments”