Live 11 : Pitch Bend Bug ?

Plug-in hosts and other software applications discussion
KVRian
581 posts since 25 Jan, 2014

Post Thu Feb 25, 2021 4:25 pm

I noticed that when I automate the pitch bend wheel in Serum even if I bring back the automation point to 0.50 in Ableton it doesn't necessarily bring the pitch bend wheel to 0.00 but rather like 0.11.

And if I slightly move up and down the automation point even if it stay to 0.50, the value of the pitch bend change like 0,12, 0.11, 0.08...

I knew that visually, 2 dot at like 0.50 were not necessarily at the same height but never notice it was really affecting the parameter. But now I see that the pitch isn't correct.

As if the automation dot values were not precise enough.

Has it always been like this or it's new to Live 11 ?

KVRian
542 posts since 4 Feb, 2017

Post Fri Feb 26, 2021 1:08 am

This has to do with the fact the pitch bend range in Live goes from 0 to 1. In Serum it goes from -1 to 1 (or whatever setting you choose). So the neutral position 0 in Serum has a value of 0.5 in Live.

KVRian

Topic Starter

581 posts since 25 Jan, 2014

Post Fri Feb 26, 2021 7:33 am

Here is a gif to show what I mean. On the gif I drag up and down the automation point while pressing shift to get more precision. As you can see the value 0.50 stay the same even though the red line is moving AND the value of the pitch bend is changing in the bottom serum square. And it's the same with filter cutoff parameter ...and the same with Sylenth1.

But with stock Live's plugin it's ok. As soon as you move the red line the value changes. I just verify and it's the same with Live 10.

Image

User avatar
KVRAF
7944 posts since 4 Jan, 2017 from Warsaw, Poland

Post Fri Feb 26, 2021 8:07 am

Jolaff wrote:
Fri Feb 26, 2021 7:33 am
...the value 0.50 stay the same even though the red line is moving AND the value of the pitch bend is changing in the bottom serum square
Right-click on that automation point and there's option up top to enter exact breakpoint value (of 0.5). Probably Live is only displaying 2 decimal points, but there's lots more after it?

See if that helps.
Music tech enthusiast.
DAW, VST & hardware hoarder.
My "music": https://soundcloud.com/antic604

KVRian

Topic Starter

581 posts since 25 Jan, 2014

Post Fri Feb 26, 2021 8:28 am

antic604 wrote:
Fri Feb 26, 2021 8:07 am
Jolaff wrote:
Fri Feb 26, 2021 7:33 am
...the value 0.50 stay the same even though the red line is moving AND the value of the pitch bend is changing in the bottom serum square
Right-click on that automation point and there's option up top to enter exact breakpoint value (of 0.5). Probably Live is only displaying 2 decimal points, but there's lots more after it?

See if that helps.
Thanx I didn't knew about that "edit value".

Yes it looks like the value displayed are not precise enough since it doesn't follow the movement of the red line... it would take something like 0.5000

KVRian
542 posts since 4 Feb, 2017

Post Fri Feb 26, 2021 8:37 am

Osc A Detune is even weirder. Not a matter of rounding.

Return to “Hosts & Applications (Sequencers, DAWs, Audio Editors, etc.)”