Plugins compatible with Windows XP 32 + Cubase SX 2

VST, AU, etc. plug-in Virtual Effects discussion
criscross123
KVRer
5 posts since 14 Oct, 2021

Post Thu Oct 14, 2021 1:23 am

Hi everybody,
I am still working with Windows XP + Cubase SX 2
Are they any version of the pluging that are compatible with these old stuff and that I could get ?
Regards.

chk071
KVRAF
30020 posts since 11 Apr, 2010 from Germany

Post Thu Oct 14, 2021 1:25 am

Anything which still comes as a 32-bit version should be compatible.

I won't ask now why you're still on such an ancient OS, and such an ancient DAW.
Plugins and a DAW. On an operating system. Which runs on a computer.

criscross123
KVRer

Topic Starter

5 posts since 14 Oct, 2021

Post Thu Oct 14, 2021 1:31 am

chk071
Thanks for your answer. But, unfortunatelly, a 32-bit version is not assurance that it works under Windows XP !
Anyway, I'll try that. Who knows ?
And why do I still use that ancient OS is because my hardware is fine to me, working fine and not totally compatible with recent OS.... so, why should I have to bye new stuff as mine is ok ? :)
Regards.

chk071
KVRAF
30020 posts since 11 Apr, 2010 from Germany

Post Thu Oct 14, 2021 2:11 am

Because most of not all software isn't tested and supported on that OS anymore. And, because there is more and more software which doesn't even come in 32-bit anymore. And, because the OS itself isn't supported and doesn't get updated anymore. And so on.

Your choice of course. Just saying why I wouldn't use it anymore.
Plugins and a DAW. On an operating system. Which runs on a computer.

criscross123
KVRer

Topic Starter

5 posts since 14 Oct, 2021

Post Thu Oct 14, 2021 3:12 am

Yes I do understand your point of view.
I'am working in IT so I know one or two things about OS. The probleme with knew OS :
Vista and Windows 8 are craps.
Win7 is ok but not supported anymore and Win10 got to be connected to the web. Or my music PC is NOT connected so it allows me to set it in a very light way and then it works very fine and efficiently ! With very few amount of money ! And very good and stable hardware. Ok, I admit I have to miss some very interresting tools.... But I don't mind a lot.

chk071
KVRAF
30020 posts since 11 Apr, 2010 from Germany

Post Thu Oct 14, 2021 3:14 am

criscross123 wrote:
Thu Oct 14, 2021 3:12 am
Win10 got to be connected to the web.
No, it doesn't.
Plugins and a DAW. On an operating system. Which runs on a computer.

Passing Bye
KVRAF
3001 posts since 5 Nov, 2014

Post Thu Oct 14, 2021 3:19 am

Windows 8.1 is not crap, far away from it, it’s obvious you never used it and can say such an nonsense!

criscross123
KVRer

Topic Starter

5 posts since 14 Oct, 2021

Post Thu Oct 14, 2021 4:08 am

Ok guys ! I didn't mean to hurt you ! If yuo like Windows 8.1 it's your right ! And, yes Win10 could be used without being connected but what is the interest ? Anyway, it remains that my hardware isn't compatible with these OS and I don't see the interest for me to get new one as it works very fine ! I have the occasion to test recent Cubase version with focusrite audio interface and I didn't see anything - I precise : FOR ME - that give me more than I have got. Well, I was just asking if there is still some version of the KVR plugins still avaiable compatible with Windows XP. I allready tried the 10.x version and it doesn't work. Well, if there isn't : too bad for me ! That's all folks !

Scotty
KVRAF
2366 posts since 23 Dec, 2002

Post Thu Oct 14, 2021 4:10 am

There are a lot of people still running old systems for a variety of reasons. This thread is huge but it concentrates on freeware 32bit plugins from the past. I'd chug through this thread and you'll find some great stuff.

viewtopic.php?f=1&t=177407

criscross123
KVRer

Topic Starter

5 posts since 14 Oct, 2021

Post Thu Oct 14, 2021 4:42 am

Hello Scotty,
Thanks a lot ! I'll go and have a look.

Passing Bye
KVRAF
3001 posts since 5 Nov, 2014

Post Fri Oct 15, 2021 2:44 am

criscross123 wrote:
Thu Oct 14, 2021 4:08 am
Ok guys ! I didn't mean to hurt you ! If yuo like Windows 8.1 it's your right !
What an logic, so if you never used Windows 8 you have every right to follow accepted blew out of the proportion internet nonsense, how can you let yourself, as IT expert, to even repeat that nonsense is beyond me, one legitimate thing is that one OS works the best for you, failed thing is to use that kind of argument, I'm not hurt, far away from it, it's just an OS, I'm in disbelief that someone who can call him IT expert can repeat nonsense like that.

fese
KVRAF
1796 posts since 14 Sep, 2004 from $HOME

Post Fri Oct 15, 2021 9:50 am

Passing Bye wrote:
Fri Oct 15, 2021 2:44 am
… I'm in disbelief that someone who can call him IT expert can repeat nonsense like that.
Well, to stay with the facts, he never claimed to be an IT expert, just that he worked in IT. Big difference.

Anyhoo, my guess is that any plugin that was released before and maybe a bit after when WinXP became really obsolete (2014) should be fine.
What I actually don’t know whether Cubase SX2 will work with plugins written for a newer VST specifications, like 2.4, which was release in 2006.

User avatar
WOK
KVRAF
2116 posts since 24 Feb, 2004 from Germany

Post Fri Oct 15, 2021 10:19 am

All of my plugins  (link:)
ImageImage

Dunbar
KVRian
569 posts since 28 Apr, 2004 from location: location

Post Fri Oct 15, 2021 10:54 am

criscross123 wrote:
Thu Oct 14, 2021 1:31 am
so, why should I have to bye new stuff as mine is ok ? :)
Absolutely.

Two of my machines still have Windows 98 SE installed (one is a duplicate system, in case the other conks out). The system works flawlessly, there's no reason to change.
eh?

v1o
KVRAF
3052 posts since 2 Oct, 2004

Post Fri Oct 15, 2021 11:27 am

Why Win XP instead of Win95 and Cubase VST32 5.3?
Orion Platinum, Muzys 2

Return to “Effects”