Novation SL MK3 - Question about VST's in Ableton

Plug-in hosts and other software applications discussion
KVRer
6 posts since 18 Oct, 2021

Post Mon Oct 18, 2021 5:26 am

Hello,

I am having some difficulties with setting this up the way I want.

I want to be able to let a sequence going on channel 1 without it stopping when I switch to channel 2.
It's going silent when I switch because channel 2 is getting armed within Ableton and that midi channel is 2 instead of 1. It has a different midi channel because I want to use different VST sounds.

This whole midi thing is new to me and I'm afraid I don't see the meadows because of all the trees.

Check this short video I made:
https://youtu.be/8_FZv-kvr54

And
https://youtu.be/WTbzKIFT48k
Last edited by Rorion on Mon Oct 18, 2021 10:23 am, edited 1 time in total.

User avatar
KVRAF
10753 posts since 4 Jan, 2017 from Warsaw, Poland

Post Mon Oct 18, 2021 5:47 am

Rorion wrote:
Mon Oct 18, 2021 5:26 am
I am having some difficulties with setting this up the way I want.
I believe setting monitoring to "In" in Ableton should do the trick (it's "Auto" on both tracks).
Music tech enthusiast
DAW, VST & hardware hoarder
My "music": https://soundcloud.com/antic604

KVRer

Topic Starter

6 posts since 18 Oct, 2021

Post Mon Oct 18, 2021 6:35 am

I would be able to set it to "In" but then I hear all sounds from every instrument. I can't seem to figure how to get the midi channel in Ableton on 2 and in my novation on 2.

User avatar
KVRAF
31167 posts since 27 Jul, 2005 from the wilds of wanny

Post Mon Oct 18, 2021 6:44 am

https://help.ableton.com/hc/en-us/artic ... l-Surfaces

Have you tried turning off "auto-arm" in preferences?

User avatar
KVRAF
10753 posts since 4 Jan, 2017 from Warsaw, Poland

Post Mon Oct 18, 2021 6:50 am

Rorion wrote:
Mon Oct 18, 2021 6:35 am
I would be able to set it to "In" but then I hear all sounds from every instrument. I can't seem to figure how to get the midi channel in Ableton on 2 and in my novation on 2.
I think Ableton is set up correctly (except for monitoring "In" ), i.e. track #1 is set to receive MIDI Channel #1, track #2 to MIDI Channel #2 and so on.

Are you sure that when you switch to channel 2 on Novation SL it actually sends the corresponding notes on MIDI Channel #2? In your video there was never any activity on either the sequencer of Novation SL or in Live's track #2.
Music tech enthusiast
DAW, VST & hardware hoarder
My "music": https://soundcloud.com/antic604

KVRer

Topic Starter

6 posts since 18 Oct, 2021

Post Mon Oct 18, 2021 6:58 am

antic604 wrote:
Mon Oct 18, 2021 6:50 am
Rorion wrote:
Mon Oct 18, 2021 6:35 am
I would be able to set it to "In" but then I hear all sounds from every instrument. I can't seem to figure how to get the midi channel in Ableton on 2 and in my novation on 2.
I think Ableton is set up correctly (except for monitoring "In" ), i.e. track #1 is set to receive MIDI Channel #1, track #2 to MIDI Channel #2 and so on.

Are you sure that when you switch to channel 2 on Novation SL it actually sends the corresponding notes on MIDI Channel #2? In your video there was never any activity on either the sequencer of Novation SL or in Live's track #2.
When I switch to channel 2 on my novation, it sends out midi info over channel 1. But I can't seem to figure how to change it to channel 2 on my novation. Already tried at the templates thing.. probably missing something small, aaaaarrrrgh..

User avatar
KVRAF
31167 posts since 27 Jul, 2005 from the wilds of wanny

Post Mon Oct 18, 2021 7:09 am

There's a setting in the Edit menu on my ReMote SL mk1 to select midi transmit channel. I usually set my tracks in Live to receive midi on All Channels.

User avatar
KVRAF
10753 posts since 4 Jan, 2017 from Warsaw, Poland

Post Mon Oct 18, 2021 7:17 am

Rorion wrote:
Mon Oct 18, 2021 6:58 am
When I switch to channel 2 on my novation, it sends out midi info over channel 1. But I can't seem to figure how to change it to channel 2 on my novation. Already tried at the templates thing.. probably missing something small, aaaaarrrrgh..
I thought that was the point, i.e. you wanted MIDI Channel #1 to continue playing the pattern from SL through the plugin on Ableton's track #1, while having MIDI Channel #2 on SL to play something else on track #2? Or am I not understanding what you're looking for?

I don't see you playing any notes or the SL sequencer playing anything when you switch to track #2 in SL.
Music tech enthusiast
DAW, VST & hardware hoarder
My "music": https://soundcloud.com/antic604

KVRer

Topic Starter

6 posts since 18 Oct, 2021

Post Mon Oct 18, 2021 7:34 am

antic604 wrote:
Mon Oct 18, 2021 7:17 am
Rorion wrote:
Mon Oct 18, 2021 6:58 am
When I switch to channel 2 on my novation, it sends out midi info over channel 1. But I can't seem to figure how to change it to channel 2 on my novation. Already tried at the templates thing.. probably missing something small, aaaaarrrrgh..
I thought that was the point, i.e. you wanted MIDI Channel #1 to continue playing the pattern from SL through the plugin on Ableton's track #1, while having MIDI Channel #2 on SL to play something else on track #2? Or am I not understanding what you're looking for?
Yes that's correct. But when I switch to channel 2. The whole sequence of midi notes get send through that channel. I made a small video of 1 min maybe that can help you understand more what my problem is.

https://youtu.be/tS7QvdJlgzE

User avatar
KVRAF
10753 posts since 4 Jan, 2017 from Warsaw, Poland

Post Mon Oct 18, 2021 7:41 am

Thanks, but you really need to help us help you :)
a) use some distinct sounds, i.e. I can't tell if 2nd instrument plays the pattern that 1st instument was playing;
b) show us what's happening in Live when you've switched to channel #2 in SL - is monitoring set to "in"? is there any activity on track #2?
c) I've no idea what "inControl" mode does, but you weren't using it in 1st video, so that's confusing too;
Music tech enthusiast
DAW, VST & hardware hoarder
My "music": https://soundcloud.com/antic604

KVRer

Topic Starter

6 posts since 18 Oct, 2021

Post Mon Oct 18, 2021 10:21 am

antic604 wrote:
Mon Oct 18, 2021 7:41 am
Thanks, but you really need to help us help you :)
a) use some distinct sounds, i.e. I can't tell if 2nd instrument plays the pattern that 1st instument was playing;
b) show us what's happening in Live when you've switched to channel #2 in SL - is monitoring set to "in"? is there any activity on track #2?
c) I've no idea what "inControl" mode does, but you weren't using it in 1st video, so that's confusing too;
Alright, tried my best to explain a couple of things.
I can't put the channel 2 Inout monitoring on (In) because the. I'd hear it also playing when I'm playing on channel 1.

https://youtu.be/WTbzKIFT48k

User avatar
KVRAF
10753 posts since 4 Jan, 2017 from Warsaw, Poland

Post Mon Oct 18, 2021 11:11 am

Rorion wrote:
Mon Oct 18, 2021 10:21 am
Alright, tried my best to explain a couple of things.
Ok, I think the problem is you want to use the Sequencer (page #5 of User Guide) in InControl mode (page #26). The former turns SL Mk3 into a MIDI sequencer that can sequence up to 16 devices with different MIDI patters, whereas the latter is meant for controlling the DAW - playing notes, launching clips, tweaking mixer and devices.

Going off of cursory reading of the User Guide, you can't mix the two.
Music tech enthusiast
DAW, VST & hardware hoarder
My "music": https://soundcloud.com/antic604

KVRer

Topic Starter

6 posts since 18 Oct, 2021

Post Tue Oct 19, 2021 8:37 pm

antic604 wrote:
Mon Oct 18, 2021 11:11 am
Rorion wrote:
Mon Oct 18, 2021 10:21 am
Alright, tried my best to explain a couple of things.
Ok, I think the problem is you want to use the Sequencer (page #5 of User Guide) in InControl mode (page #26). The former turns SL Mk3 into a MIDI sequencer that can sequence up to 16 devices with different MIDI patters, whereas the latter is meant for controlling the DAW - playing notes, launching clips, tweaking mixer and devices.

Going off of cursory reading of the User Guide, you can't mix the two.
You are right I suppose. Had a feeling somewhere that maybe this isn't something I can fix. Guess have to work my way around it.

Thanks for all your help!

Return to “Hosts & Applications (Sequencers, DAWs, Audio Editors, etc.)”