Akai MPK261 and Studio One 5

Plug-in hosts and other software applications discussion
User avatar
KVRAF
16438 posts since 16 Sep, 2001 from Las Vegas,USA

Post Thu Oct 21, 2021 1:39 pm

Anyone own an Akai MPK261 and use Studio One 5 ?

I've set up the MPK but can either get the knobs or transport controls working not both. Anyone successfully have both working ? Keys and Pads work fine either way. :)
Last edited by Teksonik on Sun Oct 24, 2021 7:52 am, edited 1 time in total.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
KVRAF

Topic Starter

16438 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sat Oct 23, 2021 10:42 am

What the heck I'll bump it once. Probably not a common combination.

I did mange to create two device entries,with one the transport works and the other the knobs work but I have to manually re-assign the input each time.

Should be a way to make it work but even with the MPK261 template in Studio One the knobs don't work. Creating a "New Keyboard" allows the knobs to work but not the transport buttons. :?
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRAF
30020 posts since 11 Apr, 2010 from Germany

Post Sat Oct 23, 2021 10:57 am

Are you sure that the knobs and faders sent normal MIDI CC messages? Not sure about the transport controls. According to the manual, they can only be configured to send "CC, Note, Program Change (PrgChange), Program Bank (PrgBank), and Keystroke". Normally, those also can be configured for MCU.

Also, how did you set up the keyboard in Studio One? Is there an official template for that keyboard? Otherwise, you have to set it up as a generic MIDI controller ("New Keyboard" option). See here: https://s1manual.presonus.com/#Setup_To ... 257C_____4
Plugins and a DAW. On an operating system. Which runs on a computer.

User avatar
KVRAF

Topic Starter

16438 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sat Oct 23, 2021 1:54 pm

I've already explained most of that but I'll go over it again....
Teksonik wrote:
Sat Oct 23, 2021 10:42 am
even with the MPK261 template in Studio One the knobs don't work. Creating a "New Keyboard" allows the knobs to work but not the transport buttons.
The knobs work fine when setting up a "New Keyboard" device but not the Transport buttons which are set to send MMC commands.

Using the MPK61 Template:

MPK.png

Even when using a Generic preset on the MPK as suggested in the image the transport buttons work but not the knobs.

Of course I have read both manuals and have followed the instructions. I have owned my MPK261 for years but just recently got Studio One Artist.

I was hoping someone who actually owns both got it working and would share the secret..... :wink:
You do not have the required permissions to view the files attached to this post.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRAF
30020 posts since 11 Apr, 2010 from Germany

Post Sat Oct 23, 2021 2:07 pm

Check this out for setting up the transport controls: https://support.presonus.com/hc/en-us/a ... MIDI-Learn
4. Next you will need to enable the MMC device. Click "ADD" again to add a new device and on the left go to the Presonus folder and choose MMC from the list. Click where it says "Receive From" and select the name of the midi port your controller is connected to. It may be the name of the midi driver your device uses or the name of the actual midi port you have connected midi cables to.

If you get a message that the port is already assigned, disregard it and proceed.
And, it doesn't surprise me that the MPK61 preset isn't working, because it's the MPK261, not the MPK61.
Plugins and a DAW. On an operating system. Which runs on a computer.

User avatar
KVRAF

Topic Starter

16438 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sat Oct 23, 2021 2:22 pm

"The MPK2 series controllers are backward compatible with the original MPK series controllers when using PreSonus Studio One, with the following additional features:

Pad Bank A is mapped to Impact2
Use the DAW CONTROL Up and Down buttons to move up and down between different tracks"

https://www.noterepeat.com/products/aka ... ware_setup

From your link:

"4. Next you will need to enable the MMC device. Click "ADD" again to add a new device and on the left go to the Presonus folder and choose MMC from the list".

Presonus 102321-1.png

There is no MMC in the list. Again the transport buttons work fine when using the MPK preset.

Do you own Studio One or an MPK261 ?
You do not have the required permissions to view the files attached to this post.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRAF
30020 posts since 11 Apr, 2010 from Germany

Post Sat Oct 23, 2021 2:55 pm

No, I don't own either, that's why I'm so eager to try to help you.

If you would have given me the information that the MPK261 is backwards compatible with the MPK61 before, then I wouldn't have suspected that it's not working. Things change with newer hardware revisions, you know?

Anyway, get some other idiot to help you. I'm done here, because all I get is snarky comments from you, as usual.

The MMC template is present here, in my version of Studio One 4 Pro, BTW, so, it must have been recently removed from version 5. Either that, or your Artist version doesn't have it. Yes, I really own Studio One. Idiot.
Plugins and a DAW. On an operating system. Which runs on a computer.

User avatar
KVRAF

Topic Starter

16438 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun Oct 24, 2021 7:12 am

Look I appreciate your attempt to help but let me tell you how I saw it...

I said "my car doesn't start, I put the key in and turned the ignition".

You responded:

"Did you put the key in and turn the ignition?"

All that did was insult me and embarrass you.

That's why I asked for anyone who owns both the MPK261 and Studio One. I wouldn't have had to tell an MPK owner that the 2 is backwards compatible in the template.

I did not ask for generic "RTFM" advice but again I appreciate your attempt to help. As for snarky comments at no point did I call you an idiot.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRAF
30020 posts since 11 Apr, 2010 from Germany

Post Sun Oct 24, 2021 7:36 am

If something doesn't work, the first thing you do is to check if the power connector is plugged in. Unless you want to be the idiot who tries everything, and THEN in the end finds out that the power connector isn't plugged in.

Apart from that, it's always the best to gather all possible information, otherwise you will likely go completely in the wrong direction.

You probably suspected that I would take you for a fool because of our history here. Well, I didn't, but, hey...
Plugins and a DAW. On an operating system. Which runs on a computer.

User avatar
KVRAF

Topic Starter

16438 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun Oct 24, 2021 7:47 am

I don't know what "history" we have. If you don't like me that's fine I could not possibly care less but when I post....
Teksonik wrote:
Sat Oct 23, 2021 10:42 am
Creating a "New Keyboard" allows the knobs to work but not the transport buttons.
and you respond....
chk071 wrote:
Sat Oct 23, 2021 10:57 am
you have to set it up as a generic MIDI controller ("New Keyboard" option)
or when I post.....
Teksonik wrote:
Sat Oct 23, 2021 10:42 am
Creating a "New Keyboard" allows the knobs to work but not the transport buttons.
and you respond....
chk071 wrote:
Sat Oct 23, 2021 10:57 am
Are you sure that the knobs and faders sent normal MIDI CC messages?
I have to think of course they are set correctly can't you read "the knobs work" ? :dog:

Even though I was forced to question your reading comprehension skills I did not call you an idiot....out loud.

Look if you think we've got such a "history" then why respond at all? Just looking to start another argument or find something else to complain about?

If I upset you that much just ignore me and we'll both be better off. :tu:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
KVRAF

Topic Starter

16438 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun Oct 24, 2021 7:51 am

Anyway after working with Studio One Artist further I discovered that most of the Midi FX are missing and an upgrade will cost about $300...not going to happen or I can pay $15 a month to rent the full version...not going to happen so I'm pretty much done faffing about with S1.

I only paid $20 for the license in the marketplace here so no big deal. At least S1 will add another DAW that I can use for beta testing plugins so it is worth it for that alone.

So I'll lock this thread and we can all go on to enjoy our Sunday.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

Return to “Hosts & Applications (Sequencers, DAWs, Audio Editors, etc.)”