Big Sur & Monterey M1 Mac - question

Configure and optimize you computer for Audio.
Fraggle
KVRist
83 posts since 29 May, 2013 from Durham

Post Sun Dec 05, 2021 10:27 pm

I know Big Sur involved significant changes , and that changes in Monterey are not as major. I am tempted to assume that if the plugin manufacturer has made their stuff M1 and big sur compatible , it should work in Monterey on an M1 Mac. However, before doing anything I thought I would ask here for some more advice.
___________________________________________________________________________
Ableton website is very clear that their DAW is compatible with Monterey

But for the following I am asking if anyone on K v R knows any more than I could find :-
___________________________________________________________________________
Serum -
the latest update does not mention Monterey compatibility, therefore I assume Serum is still only Big Sur , and will therefore crash Ableton in Monterey
___________________________________________________________________________
Zebra 2/HZ
On U/he website their is only mention of big sur compatibility, so again I must assume these synths will crash in Monterey
___________________________________________________________________________
Valhalla DSP
As Above - only mentions Bug Sur compatibility
___________________________________________________________________________
Fabfilter
On individual plug ins it says compatible with ‘Mac OS 10.12 or higher’- which implies their plugins should work with Monterey as that is OS 12
___________________________________________________________________________
Pigments -Arturia
On the website it just says 10.13+ - which I assume means the same as fabfilter - it should work on Monterey
___________________________________________________________________________
Kilohearts
On their FAQ page they say operating requirements are Mac OS 10.10 or higher , but I know their stuff isn’t yet M1 compatible , so all their gear will be buggy on an M1 Mac running monterey
___________________________________________________________________________

Thanks for any help anyone can give
Zen

PeterP_swe
KVRist
121 posts since 13 Aug, 2017 from Gothenburg

Post Mon Dec 06, 2021 12:40 am

I can confirm that FabFilter and Pigments works fine on M1 and Monterey.

I don't have Zebra, but Diva and Repro works fine so I assume it works fine as well.

Fraggle
KVRist

Topic Starter

83 posts since 29 May, 2013 from Durham

Post Mon Dec 06, 2021 12:44 am

Thanks - that is very good to hear
Zen

User avatar
pdxindy
KVRAF
20854 posts since 3 Feb, 2005 from in the wilds

Post Mon Dec 06, 2021 6:06 am

I have had no issues with any of the u-he synths and fx on my M1-Pro MBP which came with Monterey. That includes Zebra, but not Uhbik which is not yet M1 native.

Fabfilter and Valhalla are both working without any obvious issue as well.

hangars liquides
KVRist
53 posts since 8 Dec, 2008

Post Mon Dec 06, 2021 6:17 am

Tested everything there you mentioned but Fabfilter, and all plugs work flawlessly

Stokely
KVRist
227 posts since 11 May, 2010

Post Mon Dec 06, 2021 4:58 pm

Zebra works fine on my machine, as do Repro and Diva. Same with my Valhalla plugins.

I had a few older plugins that I wasn't using not pass validation, nothing from your list.

Exponential Audio's R4 and Excaliber do not work. Same with Kazrog's True Iron on stereo tracks; on mono it works. And when I say these "don't work", I mean Logic Pro completely crashes with no indication of the issue. I had several recent sessions refuse to load because I had R4 on them. I started searching forums (like this one!) and saw others having the issue, deleted the components and the sessions opened. I have hopes True Iron will get fixed (or the mac issue fighting it will get fixed); I don't have such hopes for Expontial's stuff because Izotope seems content to let those die. So I bought a reverb plugin this holiday sale season :) As an aside, Phoenixverb still works, I use that even more than R4, but I figure I'd better start moving on from it.

ON BEATS
KVRer
8 posts since 12 Dec, 2021 from Nürburgring Germany

Post Sun Dec 12, 2021 2:46 am

If it worked on Big Sur it should almost definitely work with Monterey.

I keep my laptop 100% up to date and haven't ever had an issue (MBP 13" M1 bought in August 2021)
MacBook Pro M1 13" 💻 , Waveform 11.5.18 👨🏽‍🍳, Hensive VST 🪗, Akai LPK25 Wireless Keyboard 🎹 , JBL Tune 660NC Wireless Headphones 🎧 = 🥰

https://linktr.ee/Nicholas_Lawrence

Goony
KVRist
86 posts since 1 Feb, 2015

Post Sun Dec 12, 2021 3:48 am

One of the weirdest ones for me is Gforce Oddity2, doesnt work on Big Sur but works fine in Monterey.
Ableton Live 11, NI KK S61 mk2, Deepmind 12D, Hydrasynth, Modal Cobalt8M, Microfreak, Nord Drum 3p

Bombadil
KVRAF
7281 posts since 31 Aug, 2013 from Down the Withywindle

Post Sun Dec 12, 2021 8:44 am

I've seen reports of stuff working ok with Big Sur, but not Monterey. ADD and ADK, for example, have been reported to open only a black GUI. I don't know if that's been sorted yet, but I've held off upgrading.
“Always after a defeat and a respite," says Gandalf, "the Shadow takes another shape and grows again."
J.R.R. Tolkien

sQeetz
KVRian
671 posts since 8 Jan, 2005

Post Tue Dec 14, 2021 10:12 pm

Bombadil wrote:
Sun Dec 12, 2021 8:44 am
I've seen reports of stuff working ok with Big Sur, but not Monterey. ADD and ADK, for example, have been reported to open only a black GUI. I don't know if that's been sorted yet, but I've held off upgrading.
They've been both working for a while now. XLN was pretty quick to update them.
Afar from that, everything I had on Big Sur works on Monterey.
MacBook Pro M1 . 16GB . 1TB . . Logic Pro……Renoise……Reason

sQeetz
KVRian
671 posts since 8 Jan, 2005

Post Tue Dec 14, 2021 10:17 pm

Stokely wrote:
Mon Dec 06, 2021 4:58 pm
Same with Kazrog's True Iron on stereo tracks; on mono it works. And when I say these "don't work", I mean Logic Pro completely crashes with no indication of the issue.[...] I have hopes True Iron will get fixed (or the mac issue fighting it will get fixed)
True Iron works here on stereo tracks. :shrug:
MacBook Pro M1 . 16GB . 1TB . . Logic Pro……Renoise……Reason

User avatar
DrGonzo
KVRAF
2735 posts since 24 Oct, 2000 from A Swede Living in Budapest

Post Tue Dec 14, 2021 11:35 pm

Slightly OT - but just a quickie - to ensure minimal effups I'm always about two generations of OSes late. Is it safe to go Big Sur yet? Anything significant that haven't been updated for it yet? No M1 - just plain Intel.
Plughugger Sound Design
CELLOS OF DARKNESS - Cinematic Cellos for Omnisphere
HARDWARE SAMPLER FANATIC - Akai S1100/S950/Z8 - Casio FZ20m - Emu Emax I - Ensoniq ASR10/EPS

Bombadil
KVRAF
7281 posts since 31 Aug, 2013 from Down the Withywindle

Post Wed Dec 15, 2021 7:28 am

sQeetz wrote:
Tue Dec 14, 2021 10:12 pm
Bombadil wrote:
Sun Dec 12, 2021 8:44 am
I've seen reports of stuff working ok with Big Sur, but not Monterey. ADD and ADK, for example, have been reported to open only a black GUI. I don't know if that's been sorted yet, but I've held off upgrading.
They've been both working for a while now. XLN was pretty quick to update them.
Afar from that, everything I had on Big Sur works on Monterey.
Good to know, thanks. I'm still going to hold off until sometime in the New Year.
“Always after a defeat and a respite," says Gandalf, "the Shadow takes another shape and grows again."
J.R.R. Tolkien

Return to “Computer Setup and System Configuration”