UVI Falcon - hybrid instrument - version 2.5 released - rumors, ads, praise, mud wrestling and off-topic inside!

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
RELATED
PRODUCTS
Falcon
User avatar
EvilDragon
KVRAF
22424 posts since 7 Jan, 2009 from Croatia

Post Tue Dec 07, 2021 2:37 pm

And hog EVEN MORE CPU? :D

soops32
KVRer
6 posts since 8 Dec, 2021

Post Wed Dec 08, 2021 12:11 am

been looking at this for a while, might have to cop now

User avatar
newuser2014
KVRist
64 posts since 14 Jan, 2014

Post Wed Dec 08, 2021 6:54 am

  • · a falcon poem
    ·· to express my gratitude
    ··· thank you and god bless

User avatar
Biome_Digital
KVRAF
1997 posts since 9 Jan, 2014 from Worldwide

Post Thu Dec 23, 2021 1:50 pm

I can use a patch using the analog stack engine and the CPU meter reads 60% to 70% with no playback problems or audio problems. But if I use the IRCAM stretch engine at just 30% CPU, I get loads of crackling and playback problems.

Does anyone else get this? The granular engines give me no problem either, just stretch.

andrewbrewer
KVRist
115 posts since 5 Dec, 2009

Post Thu Dec 23, 2021 6:24 pm

Biome_Digital wrote: Thu Dec 23, 2021 1:50 pm I can use a patch using the analog stack engine and the CPU meter reads 60% to 70% with no playback problems or audio problems. But if I use the IRCAM stretch engine at just 30% CPU, I get loads of crackling and playback problems.

Does anyone else get this? The granular engines give me no problem either, just stretch.
I also get problems with the IRCAM engines

User avatar
Biome_Digital
KVRAF
1997 posts since 9 Jan, 2014 from Worldwide

Post Fri Dec 24, 2021 4:16 am

andrewbrewer wrote: Thu Dec 23, 2021 6:24 pm
Biome_Digital wrote: Thu Dec 23, 2021 1:50 pm I can use a patch using the analog stack engine and the CPU meter reads 60% to 70% with no playback problems or audio problems. But if I use the IRCAM stretch engine at just 30% CPU, I get loads of crackling and playback problems.

Does anyone else get this? The granular engines give me no problem either, just stretch.
I also get problems with the IRCAM engines
Do you think it's just CPU though, or something more?

otristan
KVRAF
2262 posts since 28 Mar, 2005

Post Sun Dec 26, 2021 11:53 pm

IRCAM oscillator do not have a constant load as opposed to other oscillator.
The first buffer and when a new window is processed are more heavy leading to CPU spike. That could explain your issue.
You can try to increase your buffer size to help having enough CPU headroom for those.
HTH
Olivier Tristan
Developer - UVI Team
http://www.uvi.net

User avatar
c_voltage
KVRAF
2079 posts since 16 May, 2004 from Soviet Union

Post Sat Jan 08, 2022 7:50 pm

Sometimes when i going back to Falcon i every time impress how sounds his unisson\spread system (for example in WT), damn this is really beautiful, without any phasey dullness. True hardwarish feeling lol. Seriously, very good algo.

Neon Breath
KVRAF
4099 posts since 15 Sep, 2010

Post Sat Jan 08, 2022 9:30 pm

c_voltage wrote: Sat Jan 08, 2022 7:50 pm Sometimes when i going back to Falcon i every time impress how sounds his unisson\spread system (for example in WT), damn this is really beautiful, without any phasey dullness. True hardwarish feeling lol. Seriously, very good algo.
+1.96

chagzuki
KVRAF
2588 posts since 26 Mar, 2002 from london

Post Mon Jan 10, 2022 10:16 am

Is it possible to alternative between two programs on successive notes? I'm accustomed to using layer rules to control round robins etc., but would like to do it at the multi level between programs, but am thinking that scripts probably operate only within the confines of the containing program?
Every day takes figuring out all over again how to f#ckin’ live.

otristan
KVRAF
2262 posts since 28 Mar, 2005

Post Mon Jan 10, 2022 11:13 am

You can do it using script.
Check out how the "Utilities/Program Change Switcher" script is done.
Olivier Tristan
Developer - UVI Team
http://www.uvi.net

ekwipt
KVRist
121 posts since 14 Feb, 2006

Post Mon Jan 17, 2022 7:01 pm

Is there a way to move sound banks off of Macbook drive and off on to an external drive without downloading them all again (I tried copying them over but it didn't recognise them)

edit: actually delete that I got it to work

Hanz Meyzer
KVRAF
1913 posts since 20 Oct, 2014

Post Tue Jan 18, 2022 12:48 am

@otristan The GUI speed behaviour actually differs a lot on my M1pro/macOS 12.1 machine: It does not work fluently, if OpenGL is enabled. It works most of the time fluently with OpenGL disabled:

Resizing of the GUI then works with smooth 60fps, but somehow the knob- and slider-animations and scrollbar-scrolling are not so smooth anymore. I assume that you capped then the framerate at 30fps or so?

I think for M1/macOS 12.1 you should remove the openGL option and also remove any framerate capping. Would be nice, if it was running as smooth as on my Intel machine :)

otristan
KVRAF
2262 posts since 28 Mar, 2005

Post Tue Jan 18, 2022 2:26 am

This behavior is currently investigated by the Juce team.
https://forum.juce.com/t/poor-performan ... ines/48725

They have made some progress regarding this but it's not perfect yet. Stay tuned.
Olivier Tristan
Developer - UVI Team
http://www.uvi.net

maximoog
KVRist
197 posts since 22 Jan, 2007

Post Wed Jan 19, 2022 9:41 am

Steinberg will finally discontinue VST2 within the next 24 months. From then on, Cubase will no longer support VST2.

https://forums.steinberg.net/t/vst-2-di ... ued/761383

Return to “Instruments”