Bitwigs - Strong Laptop - Lagging Like Hell

Configure and optimize you computer for Audio.
RELATED
PRODUCTS

Post

Hello everyone,
does anybody has any tips how to configure a windows 11 laptop so that i can work properly under bitwigs?

My hw setup is a thinkpad laptop with
Amd ryzen pro 7
64gb ram
Ssd
No extra graphics card
Windows 11
I bought it a few months ago. And hoped it helps. But no.

My projects are sometimes quite complex, like let me say 15 tracks with effects and synths.

When i have finished something i try to bounce it and deactivate all the processings of it. i played around with process lasso, did tons of configs i found in the internet. What ever i do my projects always end up in crackles and lagging so that it is nearly impossible to work.

Does anybody has and tips? Is my laptop still too bad?

Plugins i use often times:
-everything from soundtoys. On each track let me say 1 of it.
-serum
-massiv
-XO
-LFO tool
-TDR compressors
-… do not know… many things. Sometimes quite huge processings. I love huge processings
-No mastering plugins! This is do seperatly.

I have maybe a quite direct question: Can you help me with a good setup for process lasso? Arranging cores, I/O, Ram and so on.

Thank you very much :)

Greetings

Post


Post

What is your soundcard is the first question, I am getting a feeling you are trying to run DAW on the internal sound chip?
Soft Knees - Live 12, Diva, Omnisphere, Slate Digital VSX, TDR, Kush Audio, U-He, PA, Valhalla, Fuse, Pulsar, NI, OekSound etc. on Win11Pro R7950X & RME AiO Pro
https://www.youtube.com/@softknees/videos Music & Demoscene

Post

Sorry, forgot to mention: a focusrite scarlet 2i2 4th gen.

I did a few things from the links above, still no help.

It is strange: Process Lasso showing only round about 40% usage of CPU and RAM but 100% DSP peaks im Bitwig. And sometimes suddenly 1h all runs well... and then unworkable spikes suddenly.


But i will go more in detail through all these links. Thanks :)

Post

Sounds like either power management is not on full or something is making DPC peaks.
Soft Knees - Live 12, Diva, Omnisphere, Slate Digital VSX, TDR, Kush Audio, U-He, PA, Valhalla, Fuse, Pulsar, NI, OekSound etc. on Win11Pro R7950X & RME AiO Pro
https://www.youtube.com/@softknees/videos Music & Demoscene

Post

legendCNCD wrote: Fri May 31, 2024 12:16 am Sounds like either power management is not on full or something is making DPC peaks.
Yeah, I remember a laptop like that, constant crackle - turn off the bluetooth and wifi and it worked perfectly. Try DPC latency checker - you can usually work out what is causing an DPC peaks that way and then disable it
I believe every thread should devolve into character attacks and witch-burning. It really helps the discussion.

Post

Yep, download latencyMon and check that first.

The other thing to understand is chip speeds aren't really getting faster anymore (and haven't for a while) and your project will be bottlenecked by the most cpu hungry channel + sends + master before you run out of parallel processing power. So your overall CPU utilisation being 40% isn't necessarily a surprise.

Post

Is your laptop plugged in? I see much higher CPU usage in Bitwig when on battery purely because it's not running a full tilt.
Another anecdote I have is my work laptop, a 13th gen i7 Thinkpad run like shit, and a couple of other colleagues have the same issues as me, taking 5-10mis to start from sleep etc. I eventually reinstalled windows fresh and it has been fine ever since - it seems the factory install was crap from the start.

Return to “Computer Setup and System Configuration”