How can I remove the generic low latency asio driver?

Configure and optimize you computer for Audio.
RELATED
PRODUCTS
hibrasil
KVRian
Topic Starter
862 posts since 24 Jun, 2002 from Berlin

Post Sun Oct 13, 2013 1:24 am

For some reason the Steinberg generic low latency asio driver seems to slow down loading of asio enabled apps on my Windows 7 Home x64 system. Does anyone know how I can totally remove it from the system?

cheers

User avatar
nix808
KVRAF
4709 posts since 22 Jul, 2006 from Tasmania, Australia

Post Sun Oct 13, 2013 1:44 am

Have you tried
My Computer->
Uninstall or change a program

hibrasil
KVRian
Topic Starter
862 posts since 24 Jun, 2002 from Berlin

Post Sun Oct 13, 2013 1:49 am

of course i've tried that :-) the generic low latency asio isn't listed there.

User avatar
nix808
KVRAF
4709 posts since 22 Jul, 2006 from Tasmania, Australia

Post Sun Oct 13, 2013 1:56 am

Did you try running the installer?

Spiritos
KVRian
724 posts since 24 Mar, 2013 from Amsterdam

Post Sun Oct 13, 2013 2:12 am

I think you should go to 'device manager', choose your audio device, details, check driver then uninstall.
Win8.1 64x/Live 9/Steinberg UR44/Roland HP 235/Edirol PCR-800/Eastman AC222/Washburn D12/Ch. Les Paul/Behringer BCF2000 & BCR2000/Korg Nanopad 2/Focusrite VRM Box/AT 2020/2xB5/E825s/Beyerdynamic DT990 Pro 250/Tannoy 502

hibrasil
KVRian
Topic Starter
862 posts since 24 Jun, 2002 from Berlin

Post Sun Oct 13, 2013 2:48 am

it's comes with steinberg products - i don't think the uninstaller will remove it.

ASIO drivers aren't listed in device manager so i can't uninstall it there. It needs to be removed from the registry i think

Spiritos
KVRian
724 posts since 24 Mar, 2013 from Amsterdam

Post Sun Oct 13, 2013 2:59 am

hibrasil wrote:it's comes with steinberg products - i don't think the uninstaller will remove it.

ASIO drivers aren't listed in device manager so i can't uninstall it there. It needs to be removed from the registry i think
Strange. I though that in device manager you could see the driver (when active) on your audio device.

For what it's worth, you could try 3rd party tools like 'Your Uninstaller' or 'Driver Genius'/'Driver Sweeper' for a more thorough scan.
Win8.1 64x/Live 9/Steinberg UR44/Roland HP 235/Edirol PCR-800/Eastman AC222/Washburn D12/Ch. Les Paul/Behringer BCF2000 & BCR2000/Korg Nanopad 2/Focusrite VRM Box/AT 2020/2xB5/E825s/Beyerdynamic DT990 Pro 250/Tannoy 502

User avatar
pljones
KVRAF
6920 posts since 8 Feb, 2003 from London, UK

Post Sun Oct 13, 2013 3:51 am

The registry key should be under HKLM\Software\ASIO if you want to start messing.

rasscass
KVRist
78 posts since 3 Dec, 2004

Post Sun Oct 13, 2013 4:15 am

Rename or remove "asioglld.dll" located in Program Files/Steinberg/Asio. Back it up to be safe.

UltraJv
KVRAF
6324 posts since 30 Dec, 2004 from London uk

Post Sun Oct 13, 2013 10:33 am

I seriously doubt that the generic ASIO driver is doing what you think. No one has ever said this before. Id be careful about trying to remove it. If you succeed, you may cause other problems. Id look elsewhere for the cause. You don't mention what soundcard youre using.

hibrasil
KVRian
Topic Starter
862 posts since 24 Jun, 2002 from Berlin

Post Sun Oct 13, 2013 1:28 pm

I got rid of it (thanks pljones). I removed the steinberg asio driver entries from

HKEY_LOCAL_MACHINE\Software\ASIO
HKEY_LOCAL_MACHINE \Software\Wow6432Node\ASIO

now the apps in question load much faster, like they should with an SSD. Previously I could actually see a progress bar window flash during the loading process that said "Generic Low latency ASIO driver" so that's how i knew it was the culprit. Still I've never seen it on other systems so I understand your disbelief.

diegohrc
KVRer
15 posts since 21 Jul, 2009

Post Thu Jan 16, 2014 2:59 pm

Thank you very much. I did this procedure on regedit. My programs are runing faster.

anglenasalt
KVRer
1 posts since 29 Jan, 2014

Post Tue Jan 28, 2014 9:31 pm

Did you try running the installer?




*sofiazoe*

Return to “Computer Setup and System Configuration”