aax plugin broken inno setup

DSP, Plug-in and Host development discussion.
RELATED
PRODUCTS
LePou
KVRist
Topic Starter
42 posts since 12 Mar, 2009

Post Sat Aug 05, 2017 8:41 am

I'm working on a windows installer for my plugins using Inno setup. Everything works fine for the vst and vst3 but the aax vesrion gets broken when installed. I have tried different flags and attributs (nocompression, noencryption, readonly, etc.) without succes.

Any help would appreciate.
Thanks

User avatar
FabienTDR
KVRian
1129 posts since 24 Feb, 2012

Post Sat Aug 05, 2017 9:14 am

Yes, you have to be careful when "recreating" the AAX. It's all about flags. Definitely works.

We do this:

[Dirs]
Name: "{code:GetAAXDir_64}\{#MyBinaryName}.aaxplugin"; Check: Is64BitInstallMode; Components:aax_64; Attribs: system;

[Files]

; AAX
Source: "{#MyBinaryName}.aaxplugin\*"; DestDir: "{code:GetAAXDir_64}\{#MyBinaryName}.aaxplugin"; Flags:ignoreversion createallsubdirs recursesubdirs; Check: Is64BitInstallMode; Components:aax_64;
Source: "{#MyBinaryName}.aaxplugin\desktop.ini"; DestDir: "{code:GetAAXDir_64}\{#MyBinaryName}.aaxplugin"; Flags:ignoreversion; Attribs: hidden system; Check: Is64BitInstallMode; Components:aax_64;
Source: "{#MyBinaryName}.aaxplugin\PlugIn.ico"; DestDir: "{code:GetAAXDir_64}\{#MyBinaryName}.aaxplugin"; Flags:ignoreversion; Attribs: hidden system; Check: Is64BitInstallMode; Components:aax_64;


Make sure to code sign the binary upfront! (Eden)
Fabien from Tokyo Dawn Records

Check out my audio processors over at the Tokyo Dawn Labs!

LePou
KVRist
Topic Starter
42 posts since 12 Mar, 2009

Post Sat Aug 05, 2017 12:07 pm

Works perfectly.
Thank you very much FabianTDR

Return to “DSP and Plug-in Development”