Mulab 7 Importing Midi - hit and miss

Official support for: mutools.com
heks
KVRist
237 posts since 28 Oct, 2002

Post Sat Aug 27, 2016 2:05 am

@Jay65, MuLab is similar to Orion, but in the same way completely different. I think due to the similar "look" its easy to try and use MuLab like Orion and thats where things can get confusing. I've been moving over to MuLab since Richard announced Orion was dead and there's been moments where I've been completely stumped by the new work flow/process. But searching this forum and reading the MuTools Doc's has just about sorted most things out. I still have problems with right/left mouse clicks doing things different to Orion and find I'm deleting things, understandable after 14/15 years of using Orion, but on the other hand plugins that crashed Orion run in MuLab. I just love the modular view, I can see and change the signal routing, its like looking behind the desk and seeing all the connections.
I own Orion Prof, Sonar Prof, Fl studio, Cubase, Trackton, Studio one ,Energy and now MuLab and use MuLab 90% of the time now (studio One 10%, more if it wasn't so over blown), so just bear with it Jay65 just remember to save all the time .
I'd love to lock Orion 8 and MuLab 7 in a dark room, the resulting progeny would be amazing. :love: :lol: :)

Jay65
KVRer
29 posts since 23 Aug, 2016

Re: Mulab 7 Importing Midi - hit and miss

Post Sat Aug 27, 2016 6:17 am

" Any idea why midi files sometimes don't show up in the piano-roll, but still plays back ?? That's really baffling me".


"Do you have a precise step-by-step how to repeat that issue?"


Hi Mutools

I found a way to reproduce the problem, using pljones suggestion above:

1. Open MuLab, New project.

2. Basic Synth Rack is already loaded.

3. Press "Control" and draw in a blank sequence, enabling a blank piano-roll also.

4. In compose or edit mode, input a Midi file into the Basic Synth Rack.

5. Set loop points around the midi sequence if you want.

6. Press "Play". The Basic synth rack plays back the midi file..

7. BUT.. piano roll & sequence (compose mode) are empty !



This has happened to me several times this week (before I knew to
use Control to bring up an empty sequence/piano-roll).

Hope you can get to the bottom of this anomaly Mutools.

Many thanks

Jay65
KVRer
29 posts since 23 Aug, 2016

Re: Mulab 7 Importing Midi - hit and miss

Post Sat Aug 27, 2016 6:37 am

Hi heks

Thanks for the info & encouragement.

I've used Orion as my only daw since 2001; so I realise I'm stuck in my ways. There's still a lot that still baffles me because I use Orion as mainly a host, for it's own generators and all my vst's.

Once I've made my sequences/loops.. I render to wav, and arrange my track in Acid Pro.

Never liked arranging on Orion. Find it cumbersome with audio files.

Like you, some of my vst's didn't work in Orion; but do in MuLab.
I always raved about Orion's sound engine.. but I think MuLab's is superior.

I've looked to MuLab as something I can use on my new Windows 7 pc; not being sure if Orion 6 will work with Windows 7.

MuLab is different, but I'm liking it a lot. Even if Orion loads on my new pc; I can see myself using MuLab as my main daw. Quality is great and workflow seems faster.. (and I'm a MuLab newbie !)

I do hope I can still use Orion though.. just for the Wasp synth. I use that all the time..lol

mutools
KVRAF
9582 posts since 24 Jun, 2008 from Europe

Re: Mulab 7 Importing Midi - hit and miss

Post Sat Aug 27, 2016 7:54 am

Jay65 wrote:4. In compose or edit mode, input a Midi file into the Basic Synth Rack.
Can you be more precise about this step? What steps do you take here?

Jay65
KVRer
29 posts since 23 Aug, 2016

Re: Mulab 7 Importing Midi - hit and miss

Post Sat Aug 27, 2016 9:28 am

Okay..

So MuLab has launched and a Basic Synth Rack is already open.

1. Click "Project" tab

2. Click on "Import MIDI File"

3. File browser opens showing my folder of stored samples & Midi
folders.

4.I choose the folder I want by moving the mouse pointer to highlight it.

5. Clicking on the folder I've chosen, opens it.. showing for example,
a list of Midi files

6. I Choose the midi file I want by clicking on it.
It highlights.

7. I click on the "OK" box

8.MuLab box appears "Import MIDI File"

9. "Position" says 1.1.000
"Track" says Basic Synth Rack

10. I click on the "OK" box

11. Sequence box stays empty. Piano-roll empty.

12. BUT click "Play" button and Basic Synth Rack plays the imported
Midi sequence. Sound shows up screen bottom.. Master mixer strip & Basic Synth Rack mixer strip

User avatar
pljones
KVRAF
6328 posts since 8 Feb, 2003 from London, UK

Re: Mulab 7 Importing Midi - hit and miss

Post Sat Aug 27, 2016 1:11 pm

Does this happen for all MIDI files or only for specific ones?

I just tried it with a file and I got four tracks created - one targeting "Basic Synth Rack" like I asked and three targeting "None", which was unexpected.

All four sequences show up in the browser ("What" set to "Sequences", "Where" set to "This project", "Sequence(1)" to "Sequence(4)" listed).

Jay65
KVRer
29 posts since 23 Aug, 2016

Re: Mulab 7 Importing Midi - hit and miss

Post Sat Aug 27, 2016 3:18 pm

Seems to be completely random pljones.

I've had the notes showing up in the sequence/piano-roll as expected;
and not showing up, using the same Midi file.

I've not had multiple tracks created like you did though. How odd..

mutools
KVRAF
9582 posts since 24 Jun, 2008 from Europe

Re: Mulab 7 Importing Midi - hit and miss

Post Sun Aug 28, 2016 2:08 am

Jay65 wrote:I've not had multiple tracks created like you did though. How odd..
Maybe you imported a MIDI file with only one track?

Jay65
KVRer
29 posts since 23 Aug, 2016

Re: Mulab 7 Importing Midi - hit and miss

Post Mon Aug 29, 2016 11:11 am

mutools wrote:
Jay65 wrote:I've not had multiple tracks created like you did though. How odd..
Maybe you imported a MIDI file with only one track?

I forgot about that Mutools. Yes I am using Midi files with one track only.

Any news yet about my original problem ?
Have you been able to recreate it yourself ?

Best wishes.. Jay

mutools
KVRAF
9582 posts since 24 Jun, 2008 from Europe

Re: Mulab 7 Importing Midi - hit and miss

Post Mon Aug 29, 2016 11:33 am

Euh, i thought everything was resolved now. Which remaining issue you mean?

Jay65
KVRer
29 posts since 23 Aug, 2016

Re: Mulab 7 Importing Midi - hit and miss

Post Mon Aug 29, 2016 1:20 pm

mutools wrote:Euh, i thought everything was resolved now. Which remaining issue you mean?
Midi sequence not appearing in the piano-roll or compose sequence.. but plays back in the assigned synth

User avatar
pljones
KVRAF
6328 posts since 8 Feb, 2003 from London, UK

Re: Mulab 7 Importing Midi - hit and miss

Post Mon Aug 29, 2016 1:46 pm

Jay65 wrote:Midi sequence not appearing in the piano-roll or compose sequence.. but plays back in the assigned synth
Unless you can track it down to a repeatable sequence of steps that always produces the problem, it's going to be hard to diagnose. I've not had it happen here - but I don't have many MIDI files to try.

Do all files always do it? (You seem to have said "no" already to that.)
Do all files sometimes do it?
Do some files always do it but others always work?
Do some files sometimes do it but others always work?

And you've still not explicitly stated what shows up in the Browser.

Jay65
KVRer
29 posts since 23 Aug, 2016

Re: Mulab 7 Importing Midi - hit and miss

Post Mon Aug 29, 2016 2:07 pm

"So MuLab has launched and a Basic Synth Rack is already open.

1. Click "Project" tab

2. Click on "Import MIDI File"

3. File browser opens showing my folder of stored samples & Midi
folders.

4.I choose the folder I want by moving the mouse pointer to highlight it.

5. Clicking on the folder I've chosen, opens it.. showing for example,
a list of Midi files

6. I Choose the midi file I want by clicking on it.
It highlights.

7. I click on the "OK" box

8.MuLab box appears "Import MIDI File"

9. "Position" says 1.1.000
"Track" says Basic Synth Rack

10. I click on the "OK" box

11. Sequence box stays empty. Piano-roll empty.

12. BUT click "Play" button and Basic Synth Rack plays the imported
Midi sequence. Sound shows up screen bottom.. Master mixer strip & Basic Synth Rack mixer strip"

Happens every time I follow the steps above.
Seems to be completely random. I've had Midi files which behave this way; but after re-launching MuLab, work as it should.

Maybe it's related to me using MuLab 7 (free) with Windows XP ??

mutools
KVRAF
9582 posts since 24 Jun, 2008 from Europe

Re: Mulab 7 Importing Midi - hit and miss

Post Mon Aug 29, 2016 9:04 pm

Note that when you import a midi file, it creates new parts in the composer. When you have the sequence editor open while importing a midi file, that sequence editor is showing the sequence part that was already in the composer, it's not auto shifting to any of the newly imported midi file parts. Solution: switch to composer, select the part you want to edit, switch back to sequence editor. Does this help?

Jay65
KVRer
29 posts since 23 Aug, 2016

Re: Mulab 7 Importing Midi - hit and miss

Post Tue Aug 30, 2016 1:18 pm

Afraid not Mutools.
I've tried switching between compose and edit mode several times. No change.

I have a .MuProject song file saved where you can see this happening. Could I send it to you ?

Return to “MUTOOLS”