o clip au version validation

Official support for: audio.d3ck.net
KVRian
653 posts since 26 Sep, 2014 from Kingshill Valley

Post Mon Jan 19, 2015 2:17 pm

hello there,

got a problem with the au version of o-lip. i have updated to 1.6, however logic pro x still lists o-clip 1.5 in the au manager and reports a failed validation of the old version (1.6 is validated, though). i really don't know why this happens - i only have one o-clip component in my plugins folder (which should be the newer version) so logic actually couldn't/shouldn't know about a second version at all. any ideas or suggestions? this is pretty annoying for every time logic scans the plugins it reports this failure. deleting the infamous .plist file didn't work neither.

thanks

-simon

User avatar
KVRian
770 posts since 23 Apr, 2002 from audio/hamburg/germany/earth/space/unkown!

Post Mon Jan 19, 2015 2:40 pm

Have you looked in both component folders?
At some point we changed the installation location from the user's home directory
Users/<username>/Library/Audio/Plug-Ins/Components
to the global one:
/Library/Audio/Plug-Ins/Components

cheers!

JM

KVRian

Topic Starter

653 posts since 26 Sep, 2014 from Kingshill Valley

Post Mon Jan 19, 2015 4:56 pm

yes, i have checked on that - and there is no plugin in the user directory (at all, that is)... that's what's so weird about it, i really cannot figure out where the other version lies hidden...

User avatar
KVRian
770 posts since 23 Apr, 2002 from audio/hamburg/germany/earth/space/unkown!

Post Mon Jan 19, 2015 6:21 pm

did you try removing it all, the 1.6 too? Does it still show up?

User avatar
KVRian
770 posts since 23 Apr, 2002 from audio/hamburg/germany/earth/space/unkown!

Post Mon Jan 19, 2015 6:45 pm

dasdeck wrote:Did you try removing it all, the 1.6 too? Does it still show up?

KVRian

Topic Starter

653 posts since 26 Sep, 2014 from Kingshill Valley

Post Tue Jan 20, 2015 3:15 am

ah - we're getting closer now :D after removing the component from the plugin folder both, version 1.5 and 1.6 aren't listed in the au-manager any more. but if i put the component back they're both there again. at first i thought about just re-installing it, but actually i did install the version 1.6 whereupon the problem occurred...

KVRian

Topic Starter

653 posts since 26 Sep, 2014 from Kingshill Valley

Post Wed Jan 21, 2015 1:48 am

do you think this might be a bug in the 1.6 file or do you have any other idea what to do about it?

User avatar
KVRian
770 posts since 23 Apr, 2002 from audio/hamburg/germany/earth/space/unkown!

Post Wed Jan 21, 2015 6:21 pm

Sim.Sky wrote:do you think this might be a bug in the 1.6 file or do you have any other idea what to do about it?
I don't think it has anything to do with the binary. I suspect the installer failed at some point?
So does the 1.6 now work if you install it from an empty start?

I'll have time to take a close look into this the next few days.

Cheers!

KVRian

Topic Starter

653 posts since 26 Sep, 2014 from Kingshill Valley

Post Thu Jan 22, 2015 4:58 am

i'm afraid, but - nope. removed everything, installed the latest version and it added 1.6 and 1.5 again.

User avatar
KVRian
770 posts since 23 Apr, 2002 from audio/hamburg/germany/earth/space/unkown!

Post Thu Jan 22, 2015 7:44 am

Sim.Sky wrote:i'm afraid, but - nope. removed everything, installed the latest version and it added 1.6 and 1.5 again.
Thanks for testing :)
I'll fix it asap.

Cheers!

KVRian

Topic Starter

653 posts since 26 Sep, 2014 from Kingshill Valley

Post Thu Jan 22, 2015 8:00 am

never mind, glad i could contribute at least something ;)
looking forward to the update and thanks for your support!

User avatar
KVRian
770 posts since 23 Apr, 2002 from audio/hamburg/germany/earth/space/unkown!

Post Sat Jan 24, 2015 10:04 pm

I was able to reproduce the behaviour, however, the latest Version does not suffer from this issue, so I'll put this error on the stack in case it shows up again.

You can update to the latest beta version (1.7), which should be just as stable as version 1.6.

http://archive.d3ck.net/beta

cheers!

JM

KVRian

Topic Starter

653 posts since 26 Sep, 2014 from Kingshill Valley

Post Sun Jan 25, 2015 5:08 am

yes, 1.7 solved it - thanks again!

Return to “audioD3CK”