Troubles with T7 after a Windows update

Discussion about: tracktion.com
Mark Swanson
KVRist
174 posts since 9 Dec, 2016 from Grand Rapids, Michigan USA

Post Wed Mar 15, 2017 6:49 pm

I had a frustrating evening. I fired up things to work on a modest mix I have been finishing up. I saw the Windows updated itself, no big deal. But when I loaded Tracktion 7 and the file I have been working on, I started getting some dropouts, and stops for a few seconds and then playing again, static and so on.
I have rendered out most of my tracks, and I am really not using very many plug ins. I am running an 8-core Xeon, WIndows 10 and a SSD. My CPU meter in Tracktion is running about halfway, I was getting this behavior when I had a lot of plug ins and the CPU meter was much higher. So I rendered my tracks and cut the plug ins with no improvement. While recording I can run my buffer at 256, and I tried 1024 and also 2048 for mixing and it has not made any difference. The dropouts and garbage continue. It generally stops just a few seconds into the song.
Could it be something in the new Windows update that Tracktion does not like? Any other ideas?
Mark Swanson, guitarist and luthier
Click to visit Swanson Guitars
http://www.MarkSwansonMusic.com

Peter Widdicombe
KVRist
322 posts since 29 Aug, 2014

Re: Troubles with T7 after a Windows update

Post Thu Mar 16, 2017 4:00 pm

If you've just applied an update, Windows will be doing some applies in the background, that could take a few hours... ? What's your CPU and disk usage even when NOT running any applications (like Tracktion)? It hopefully drops off after a little while.

Mark Swanson
KVRist
174 posts since 9 Dec, 2016 from Grand Rapids, Michigan USA

Re: Troubles with T7 after a Windows update

Post Fri Mar 17, 2017 7:31 am

Well, I am still quite stuck. My problem is worse than ever, and I am not sure why. I had a suggestion from a helpful member to install and run Process Explorer, https://technet.microsoft.com/en-us/sys ... lorer.aspx and it is showing me spiking on my CPU, and it says that Tracktion is using 80%- 85% of CPU at that moment. Everything freezes for a bit and then goes on but I have these stoppages every few seconds. Its very bad. Even on a very basic edit.
Mark Swanson, guitarist and luthier
Click to visit Swanson Guitars
http://www.MarkSwansonMusic.com

klangbastler
KVRist
465 posts since 1 Feb, 2006

Re: Troubles with T7 after a Windows update

Post Fri Mar 17, 2017 7:39 am

did you do a complete reboot? not the simple shutdown windows does to make the next start faster, i mean a real reboot?

Mark Swanson
KVRist
174 posts since 9 Dec, 2016 from Grand Rapids, Michigan USA

Re: Troubles with T7 after a Windows update

Post Fri Mar 17, 2017 2:33 pm

Well, yes, I completely shutdown my system over night and came back the next day. It was even worse the next day. So unless you mean something else, thats it.
Mark Swanson, guitarist and luthier
Click to visit Swanson Guitars
http://www.MarkSwansonMusic.com

klangbastler
KVRist
465 posts since 1 Feb, 2006

Re: Troubles with T7 after a Windows update

Post Fri Mar 17, 2017 3:28 pm

next thing i would try is to install tracktion again over the existing install (or maybe uninstall and reinstall).
maybe windows overwrote something ...

then reinstall audiodrivers for used interfaces.

Mark Swanson
KVRist
174 posts since 9 Dec, 2016 from Grand Rapids, Michigan USA

Re: Troubles with T7 after a Windows update

Post Sat Mar 18, 2017 8:28 am

Ok, and update here. I am still stuck. Things seem a bit better now but I am still having a lot of troubles. I went and looked at my startup programs and cleared everything I could out of there, I don't know if that helped or not.
I have been running tests with Process Explorer. It tells me that my interrupts are running under 4%, sometimes under 3%. Tracktion shows as the next item in the list and it is typically running under 10%, sometimes down to 6%... until it spikes up to 90% and then stops, and will start again once it catches up.
I am also getting moments where the CPU meter in Tracktion spikes and peaks out, while the music falls into horrible blasting static. I found that going into my settings window and hitting "reset device" brings it back, only to happen again in a few seconds. This makes me wonder if the interface may be having troubles. (M-Audio Fast Track Ultra) so I deleted the driver and re-installed it, no change.
Something is still damn wrong, and it happened right after that update. And of course the "restore point" system was turned off, so I cannot try that.
Mark Swanson, guitarist and luthier
Click to visit Swanson Guitars
http://www.MarkSwansonMusic.com

klangbastler
KVRist
465 posts since 1 Feb, 2006

Re: Troubles with T7 after a Windows update

Post Sat Mar 18, 2017 12:52 pm

oh my ... :(
i really wish you a fast and "to the point" solution for your troubles, mark!

Mark Swanson
KVRist
174 posts since 9 Dec, 2016 from Grand Rapids, Michigan USA

Re: Troubles with T7 after a Windows update

Post Sat Mar 18, 2017 2:36 pm

I am quite concerned and really upset about it...I hope that if all else fails, Waveform will fix it.
Mark Swanson, guitarist and luthier
Click to visit Swanson Guitars
http://www.MarkSwansonMusic.com

Jerru
KVRist
351 posts since 11 Nov, 2007 from Motown

Re: Troubles with T7 after a Windows update

Post Sun Mar 19, 2017 7:32 am

Mark, If your computer was originally Windows 8 and the update you referenced was going to Windows 8.1, you could possibly try to roll back to Windows 8. Please note, I have not tried this myself so I cannot vouch for how it might affect things. If you try this, make sure to select the "Refresh your PC without affecting your files" option. Might be worth some further research into this hack if all else has failed....
https://www.youtube.com/watch?v=2t4rIAeybFk

Good Luck!

Mark Swanson
KVRist
174 posts since 9 Dec, 2016 from Grand Rapids, Michigan USA

Re: Troubles with T7 after a Windows update

Post Sun Mar 19, 2017 8:00 am

Thanks a whole bunch. But I am using Windows 10. I might as well update you all on my progress, I am still working on this...I did undo the update. And things are a bit better, but I still am having the problems. It's noticably better and when I use Process Explorer I can see the performance graph is much smoother- AFTER it loads in a project. Upon loading in, things are very rough and I usually have to wait or play things for a minute or so and then Tracktion settles down. What the hell!
Mark Swanson, guitarist and luthier
Click to visit Swanson Guitars
http://www.MarkSwansonMusic.com

jabe
KVRAF
1734 posts since 9 Oct, 2008 from UK

Re: Troubles with T7 after a Windows update

Post Sun Mar 19, 2017 8:40 am

I'm glad to hear it's more usable, Mark. It may be that future W10 updates sort out the problem. My laptop had Windows 8 when I got it, and it ran well, but after putting Windows 10 on it, a few weeks after its release, my wired internet connection was flakey, and would just drop out intermittently. In the end, I found an updated driver for my network socket device, but it had run without problem under W8 and W8.1.
[W10-64, T5/6/7/W8/9, 32&64, Spike],[W7-32, T5/6/7/W8, Gina16] everything underused.

Mark Swanson
KVRist
174 posts since 9 Dec, 2016 from Grand Rapids, Michigan USA

Re: Troubles with T7 after a Windows update

Post Sun Mar 19, 2017 7:00 pm

Yes, it is better but I am lucky if I can get through one song without an issue.
Mark Swanson, guitarist and luthier
Click to visit Swanson Guitars
http://www.MarkSwansonMusic.com

jabe
KVRAF
1734 posts since 9 Oct, 2008 from UK

Re: Troubles with T7 after a Windows update

Post Sun Mar 19, 2017 8:32 pm

Fingers crossed for Waveform then. Can only be days away.
[W10-64, T5/6/7/W8/9, 32&64, Spike],[W7-32, T5/6/7/W8, Gina16] everything underused.

Mark Swanson
KVRist
174 posts since 9 Dec, 2016 from Grand Rapids, Michigan USA

Re: Troubles with T7 after a Windows update

Post Mon Mar 20, 2017 6:19 pm

I may have solved my issue! I hope so, tonight I played through a few edits, and I did not have one single incident. here is what I did....
I followed the first two steps on this page- http://news.softpedia.com/news/windows- ... 0908.shtml
I hope this did it. So far, so good!
Mark Swanson, guitarist and luthier
Click to visit Swanson Guitars
http://www.MarkSwansonMusic.com

Return to “Tracktion”