Is it at all reasonable to think I can have all my NI software running?

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
jancivil
KVRAF
17560 posts since 20 Oct, 2007 from No Location

Post Fri Feb 15, 2019 3:40 pm

1.5.2 DFD extension shows here.

If I had income riding on any of the old Kontakt stuff I would just get it up in a modern-day Kontakt tbh.
FWIW, Kontakt 4 was too much of a PITA here to worry about. I wanted to get portions of the Factory Library up via Kore 2 .ksds and a smattering of files but it was a terrific waste of time for me in the end (ie., I gave up and did it the normal way, downloaded all of it in NA). I've gotten Kore 2 up and running on more than one system, a real problem under OSX.10 and above), and other things, because I'm just stubborn but after a point, no.

Ah_Dziz
KVRAF
2482 posts since 2 Jul, 2005

Re: Is it at all reasonable to think I can have all my NI software running?

Post Fri Feb 15, 2019 5:25 pm

Had a hiccup with my browser. Just looked on my phone and it was there it only had a Mac link on my desktop. I have most of those backed up. I used to save multis along with each project. Got lazier. This job is a client trying to get around sample clearances for a movie license at the last minute. And the song is 10 years old. I’m amazed I found the project.
Don't F**K with Mr. Zero.

Ah_Dziz
KVRAF
2482 posts since 2 Jul, 2005

Re: Is it at all reasonable to think I can have all my NI software running?

Post Fri Feb 15, 2019 5:33 pm

EvilDragon wrote:
Fri Feb 15, 2019 3:01 pm
The plugin should have the same version number as standalone, of course. If this isn't happening, then indeed something is up with the install somehow.

What's weird is that if standalone is not throwing demo mode, the plugin should behave the same. If they don't, that is REALLY weird, I haven't seen that happen ever...

You may have to bite the bullet and just uninstall everything completely and reinstall from scratch. Clear NI registry hives too (this will also null all your settings in each program, unfortunately).


But what I would actually try and spend time on is converting your old projects to load newer versions of Kontakt instead...
Yeah. I’m moving to just fully bouncing everything to Audi when I archive stuff. This isn’t my material though. It’s me cleaning up a clients stuff for a movie. So the plugin won’t launch at all to tell me the “version number” in the “about tab”. Won’t even run in demo mode inside a host. It pops up a error box that says your install needs to be registered go do that in service center. But the version in “about” in the standalone does not match the version number under the “properties” tab of the .dll.

I have a plan for fixing up my own stuff that uses the first two Kontakt versions so I don’t have this problem down the road. I have to stockpile an remix tons of it for a music library and will do the conversions there. Thanks again for all the help! Still wondering about pro 53 etc. they also won’t launch at all in a host. Errors only. Gonna go see if I can fix at least Kontakt 2 for now.

JJ
Don't F**K with Mr. Zero.

Ah_Dziz
KVRAF
2482 posts since 2 Jul, 2005

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 8:54 am

I saw video online of a guy editing xml files because libraries won’t show up in Kontakt. It was on a Mac and the issue was that some activations shared the same number. The solution was to just change one number in the xml to a random new number. I’m curious if this would make me able to load both elektrik piano, and electric piano 1.5. I also can’t get akoustik piano to show up at all still in Kontakt 5. They work in Kontakt 4 though. This is very odd. I’m down for a full reinstall of all my stuff, but now I’m scared that K5 will stop working and then I’ll be getting no work done.
Don't F**K with Mr. Zero.

User avatar
ew
KVRAF
9162 posts since 23 Jul, 2002 from Pequot Lakes, MN

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 9:08 am

In regards to the non-matching plugin versions, it sounds as if the updated plugins installed themselves somewhere else.

Look in the corresponding standalone folder and see if the plugins are there; I've seen that happen more than once. If they aren't do a search and see where they installed to. When you find them, you can just move them to where they belong.

ew
A spectral heretic...

User avatar
EvilDragon
KVRAF
17714 posts since 7 Jan, 2009 from Croatia

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 10:56 am

For Akoustik/Elektrik Piano, try this:

https://support.native-instruments.com/ ... elp-en-us-

You need those .nicnt files.

Background info: since Kontakt 5.6.8, all Service Center related activation stuff was removed from Kontakt, so certain libraries might act up.

User avatar
jancivil
KVRAF
17560 posts since 20 Oct, 2007 from No Location

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 11:32 am

If you can get 5.6.6 or below, they still have 'add library' independently of NA. I would save those in later versions once the library shows.

Oh ok, that's at that knowledge base answer.

surreal
KVRian
1165 posts since 3 Dec, 2006

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 2:03 pm

EvilDragon wrote:
Sat Feb 16, 2019 10:56 am
For Akoustik/Elektrik Piano, try this:

https://support.native-instruments.com/ ... elp-en-us-

You need those .nicnt files.

Background info: since Kontakt 5.6.8, all Service Center related activation stuff was removed from Kontakt, so certain libraries might act up.
I noticed that my service center was just deleted after the updated.. this is really uncool of native instruments as this was done without my knowledge and consent.. I would like to keep service center running for my older plugs like pro 53 ect

User avatar
jancivil
KVRAF
17560 posts since 20 Oct, 2007 from No Location

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 2:25 pm

after _what_ updated? I tend to doubt anything else updating is going to go in and delete SC.

User avatar
EvilDragon
KVRAF
17714 posts since 7 Jan, 2009 from Croatia

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 3:07 pm

surreal wrote:
Sat Feb 16, 2019 2:03 pm
I noticed that my service center was just deleted after the updated.. this is really uncool of native instruments as this was done without my knowledge and consent.. I would like to keep service center running for my older plugs like pro 53 ect
That sounds weird. If you meant Native Access, no, it does not remove Service Center at all. They coexist on the same system just fine.


At any rate, you should be able to reinstall Service Center if it somehow bizarrely got removed. Scroll down:

https://www.native-instruments.com/en/s ... her-files/

surreal
KVRian
1165 posts since 3 Dec, 2006

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 4:12 pm

I updated native acess last year in october and my service center folder showed the same modification date as the update of my native access.When i checked my folder i found the servicecenter.exe file is missing out the folder. The shortcut that was on my desktop linking to the exe file of tye service center also showed the same modification date as the same date as my native access update and the exe file infact was missing... I read somewhere that native acess has taken total control aggressively of the legacy plugins that NI previously stated that service center would actually run making service center totally obsolete which could explain the deletion of service centers exe file. It is just this kinda behaviour borders on the same behaviour of malware programmes as nowhere did ni ask me if I wanted to remove service center

surreal
KVRian
1165 posts since 3 Dec, 2006

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 4:14 pm

EvilDragon wrote:
Sat Feb 16, 2019 3:07 pm
surreal wrote:
Sat Feb 16, 2019 2:03 pm
I noticed that my service center was just deleted after the updated.. this is really uncool of native instruments as this was done without my knowledge and consent.. I would like to keep service center running for my older plugs like pro 53 ect
That sounds weird. If you meant Native Access, no, it does not remove Service Center at all. They coexist on the same system just fine.


At any rate, you should be able to reinstall Service Center if it somehow bizarrely got removed. Scroll down:

https://www.native-instruments.com/en/s ... her-files/

surreal
KVRian
1165 posts since 3 Dec, 2006

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 4:15 pm

surreal wrote:
Sat Feb 16, 2019 4:14 pm
EvilDragon wrote:
Sat Feb 16, 2019 3:07 pm
surreal wrote:
Sat Feb 16, 2019 2:03 pm
I noticed that my service center was just deleted after the updated.. this is really uncool of native instruments as this was done without my knowledge and consent.. I would like to keep service center running for my older plugs like pro 53 ect
That sounds weird. If you meant Native Access, no, it does not remove Service Center at all. They coexist on the same system just fine.


At any rate, you should be able to reinstall Service Center if it somehow bizarrely got removed. Scroll down:

https://www.native-instruments.com/en/s ... her-files/
Thank you for links

Ah_Dziz
KVRAF
2482 posts since 2 Jul, 2005

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sat Feb 16, 2019 6:33 pm

So none of the “versions” of any of ,my NI stuff match when I’m looking at properties or hovering over the .exe or .dll files. This is consistent up to the newest stuff. The “about screen” when you click on the logo or “about” under options or whatever does not match either number. I can’t launch the problematic programs as plugins to even look at the “about” screen. If anybody with a working copy of Kontakt 2, Pro 53, or vokator that is fully functional under Windows 7 64-bit, please tell me the “properties” version number, the vst .dll file “properties” version number and then the numbers displayed under “about” from inside the program. That would help immensely. “If it works for you then I can make it work for me” is what I’m thinking. I’d like to see what I can confirm as being “wrong” with what I have so I can try and move forward.
Don't F**K with Mr. Zero.

User avatar
EvilDragon
KVRAF
17714 posts since 7 Jan, 2009 from Croatia

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 10:33 am

That sounds horrible, whoa. Something really messed up there during all the installs and/or updates. Kontakt 2 stopped at version 2.2.4. Pro-53 is at 3.0.5.001. This to me sounds like the VST plugin folder was somehow incorrectly set in certain installs, so things went awry from there onwards.

Version number has to be the same for both standalone EXE and plugin DLL.

Return to “Instruments”