Omnisphere 2 slow interface

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
pluton
KVRer
21 posts since 3 Jan, 2020

Post Fri Jan 17, 2020 12:12 pm

Funkybot's Evil Twin wrote:
Fri Jan 17, 2020 8:49 am
The Spectrasonics GUI's being open cause the GUI's in all my DAWs to lag. Reaper, Cubase, Studio One, will all have terribly slow framerates as long as Omnisphere or Keyscape are open. This is on Windows 10 x64. GPU is an AMD Radeon R7 200 series with 1GB of RAM, so nothing insanely high spec'd, but I also can't think of anything overtly complex happening with Omnisphere's GUI that should also tax anything that much.
I also have StylusRMX, Trilian and Keyscape, all of them have fast GUI except Omnisphere

pluton
KVRer
21 posts since 3 Jan, 2020

Re: Omnisphere 2 slow interface

Post Sat Jan 18, 2020 2:15 pm

here I made another video, this time its even slower

https://www.youtube.com/watch?v=pcOY_51e4cw

User avatar
zvenx
KVRAF
7384 posts since 16 Feb, 2005 from Kingston, Jamaica

Re: Omnisphere 2 slow interface

Post Sat Jan 18, 2020 2:42 pm

pluton wrote:
Sat Jan 18, 2020 2:15 pm
here I made another video, this time its even slower

https://www.youtube.com/watch?v=pcOY_51e4cw
Ouch. Omnisphere seems to be in a very 'relaxed' mood on your computer.
Sorry
rsp
sound sculptist

pluton
KVRer
21 posts since 3 Jan, 2020

Re: Omnisphere 2 slow interface

Post Sat Jan 18, 2020 5:35 pm

zvenx wrote:
Sat Jan 18, 2020 2:42 pm
pluton wrote:
Sat Jan 18, 2020 2:15 pm
here I made another video, this time its even slower

https://www.youtube.com/watch?v=pcOY_51e4cw
Ouch. Omnisphere seems to be in a very 'relaxed' mood on your computer.
Sorry
rsp
any idea what can be causing it ?

User avatar
zvenx
KVRAF
7384 posts since 16 Feb, 2005 from Kingston, Jamaica

Re: Omnisphere 2 slow interface

Post Sat Jan 18, 2020 5:54 pm

None. what has spectrasonics said?

rsp
sound sculptist

Kinh
KVRian
1302 posts since 26 Aug, 2012

Re: Omnisphere 2 slow interface

Post Sat Jan 18, 2020 7:38 pm

It's not the GUI that lags it's the program itself. I got a 4 gig graphics card and it still takes a few seconds to launch as does kontakt, falcon and some others. It's a sample based synth with a tone of presets. Of course it's gonna take time to launch especially if you got your content on a separate drive

noiseboyuk
KVRAF
2960 posts since 25 Jan, 2007

Re: Omnisphere 2 slow interface

Post Sun Jan 19, 2020 12:12 am

In the past, updates have changed this for me. I had it that slow once, contacted support and the just told me to update everything - I hadn’t realised its was out of date. Voila, suddenly it was tons better. I suspect you’re on the latest version though, and your response is massively slower than mine (content on a nvme and about 9,000 third party patches), so all I can suggest is to contact their support with your full specs and see what they say.
http://www.guyrowland.co.uk
http://www.sound-on-screen.com
W10, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2019 Ultimate, Cubase Pro 10.5
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD

Echoes in the Attic
KVRAF
7725 posts since 12 May, 2008

Re: Omnisphere 2 slow interface

Post Mon Jan 20, 2020 7:14 am

I’ve never had issues with the GUI being anywhere near that slow. I have had issues with presets changing extremely slow before but mostly seems to have gone away with updates. Oddly it was presets using the wave tables that were the worst and are still a little slow. But the rest seems fine.
System: Windows 10, Dell XPS 2-in-1, Bitwig 3, Steinberg UR44.

pluton
KVRer
21 posts since 3 Jan, 2020

Re: Omnisphere 2 slow interface

Post Tue Jan 21, 2020 6:01 am

Double post

DizzlerMusic
KVRer
2 posts since 28 Jan, 2020

Re: Omnisphere 2 slow interface

Post Sun Feb 09, 2020 4:58 pm

Omnisphere is sooo slow on my machine aswell, i had a 3570k for years and i thought its just too slow since it always spiked when changing stuff in Omnisphere, i upgraded to a 12 core 3900x and im still having the same issues. In Fl Studio there is a FPS counter and whenever i move a knob it drops fps (not many but around 5-10) , but when im moving points in the envelope window it drops to 5 fps all the time. I tested Serum and it never drops even a single FPS, no lag whatsoever.I contacted Spectrasonics when 2.5 came out after i noticed the lags, send them multiple videos, and .... they never fixed it. I tried to go back to 2.3.2h because that version was soooo smoth but it was already too late since alot of patches were corrupted. So yeah ,the 2.5 update killed my omnisphere and now im not even using it anymore because its so frustrating,and the sad part i paid like 1000$(?) for it(omnisphere+trillian+keyscape) lol

User avatar
StompIt
KVRist
66 posts since 15 Jul, 2019 from MS, USA

Re: Omnisphere 2 slow interface

Post Sun Feb 09, 2020 7:42 pm

,the 2.5 update killed my omnisphere and now im not even using it anymore because its so frustrating,and the sad part i paid like 1000$(?) for it(omnisphere+trillian+keyscape) lol
Ouch!! That hurts!

billybong
Banned
95 posts since 18 Dec, 2019

Re: Omnisphere 2 slow interface

Post Sun Feb 09, 2020 8:08 pm

Had issues with interface on a Mac with 2.5. Wrote to them, they replied with a fix and all good now. Have the Win people been chasing Spectra?

Return to “Instruments”