DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Alma Mare
KVRer
9 posts since 10 Apr, 2018

Post Tue Jan 21, 2020 4:10 pm

moss wrote:
Tue Jan 21, 2020 11:14 am
Reckon104 wrote:
Tue Jan 21, 2020 9:05 am
Alma Mare wrote:
Mon Jan 20, 2020 7:02 pm
Howdy, sorry to bother again. Still have a couple of doubts on the Launchpad X functionality:

1 - In the volume view, I can't use the second row pads (the ones who'd put the volume at 0db; instead it also adds the first row and sets the volume at +3.2 dB. What could be causing this?
I am experiencing same issue, also with "pan" view
I cannot reproduce that. Can you give some steps how to get to this problem? Did you select a specific mode before?
Did you do any custom mappings? Are you running the latest Firmware?
I'm running firmware V.103, build 348. I have no costum mappings. I can reproduce the issue on a fresh Bitwig session, with no other controller plugged in. Add some tracks, go into Volume view, lower the volume, and when I press the second row it jumps to +3.2

You can simply remap the MIDI channel in the track settings (left hand window) in Bitwig.
Yeah, I can, but I only have notes coming from channel 1. Suppose I have 2 synth tracks that are both armed for recording (in order to be able to be played from other controllers on the fly). How could I be able to separate the input from the launchpad in order to trigger only one of the synths while keeping both armed for recording?

Cheers!

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 1:23 am

Alma Mare wrote:
Tue Jan 21, 2020 4:10 pm
I'm running firmware V.103, build 348. I have no costum mappings. I can reproduce the issue on a fresh Bitwig session, with no other controller plugged in. Add some tracks, go into Volume view, lower the volume, and when I press the second row it jumps to +3.2
Is there a pattern to "on some tracks"? E.g. Groups, Audio, Instruments?!
Alma Mare wrote:
Tue Jan 21, 2020 4:10 pm
Yeah, I can, but I only have notes coming from channel 1. Suppose I have 2 synth tracks that are both armed for recording (in order to be able to be played from other controllers on the fly). How could I be able to separate the input from the launchpad in order to trigger only one of the synths while keeping both armed for recording?
I am not sure if I fully understand what you are trying to do. If you want to control different tracks with different controllers you can select only that controller for the track (not all).
Or do you ask to control 2 tracks from the Launchpad at once on different MIDI channels?

Alma Mare
KVRer
9 posts since 10 Apr, 2018

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 8:23 am

moss wrote:
Wed Jan 22, 2020 1:23 am
Alma Mare wrote:
Tue Jan 21, 2020 4:10 pm
I'm running firmware V.103, build 348. I have no costum mappings. I can reproduce the issue on a fresh Bitwig session, with no other controller plugged in. Add some tracks, go into Volume view, lower the volume, and when I press the second row it jumps to +3.2
Is there a pattern to "on some tracks"? E.g. Groups, Audio, Instruments?!
Alma Mare wrote:
Tue Jan 21, 2020 4:10 pm
Yeah, I can, but I only have notes coming from channel 1. Suppose I have 2 synth tracks that are both armed for recording (in order to be able to be played from other controllers on the fly). How could I be able to separate the input from the launchpad in order to trigger only one of the synths while keeping both armed for recording?
I am not sure if I fully understand what you are trying to do. If you want to control different tracks with different controllers you can select only that controller for the track (not all).
Or do you ask to control 2 tracks from the Launchpad at once on different MIDI channels?
Well, just to make sure I tried on a new project by default. The standard 1 Inst, 1 audio, 1 effect and master that bitwig creates by default. Jump to the volume page in the Launchpad and it behaves as we've described :\

I've noticed a bunch of red messages on the script console. I have mp clue if it's helpful, but might as well, I suppose
Called init()
Crash during flush.
java.lang.NullPointerException
at de.mossgrabers.controller.launchpad.command.trigger.LaunchpadCursorCommand.updateArrowStates(LaunchpadCursorCommand.java:64)
at de.mossgrabers.framework.command.trigger.mode.ModeCursorCommand.canScroll(ModeCursorCommand.java:98)
at de.mossgrabers.controller.launchpad.LaunchpadControllerSetup.lambda$registerTriggerCommands$3(LaunchpadControllerSetup.java:232)
at de.mossgrabers.framework.controller.AbstractControllerSetup.lambda$addLight$8(AbstractControllerSetup.java:670)
at de.mossgrabers.bitwig.framework.hardware.HwSurfaceFactoryImpl.lambda$createLight$2(HwSurfaceFactoryImpl.java:104)
at My1.currentValue(SourceFile:26)
at My1.WlB(SourceFile:70)
at JvE.Zue(SourceFile:39)
at zkV.updateHardware(SourceFile:153)
at de.mossgrabers.bitwig.framework.hardware.HwSurfaceFactoryImpl.flush(HwSurfaceFactoryImpl.java:188)
at de.mossgrabers.framework.controller.AbstractControlSurface.flushHardware(AbstractControlSurface.java:852)
at de.mossgrabers.controller.launchpad.controller.LaunchpadControlSurface.flushHardware(LaunchpadControlSurface.java:275)
at de.mossgrabers.framework.controller.AbstractControlSurface.lambda$flush$8(AbstractControlSurface.java:611)
at de.mossgrabers.framework.utils.LatestTaskExecutor.lambda$execute$0(LatestTaskExecutor.java:43)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:835)

Firmware version: 348
Running.
As for my other question, the thing is I have several HW synths, each living on their own tracks, which I'd like to have input monitoring at all times since some of them are running their own sequences. I'm looking for a way to be able to select and play them one at a time and send the Pad notes only to that synth without triggering the other ones who aren't recording at that time (but are having their inputs monitored). On my M-audio Code I do that by selecting the correspondent midi channel on the unit itself. The Launchpad only sends on channel 1, so even though I can select the track I want to play, the notes I play trigger all synths.

Thanks for the help!

peemge
KVRer
7 posts since 10 Mar, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 10:06 am

hexfarmer wrote:
Tue Jan 21, 2020 2:31 pm
What I find really strange is that it 'half works'... the big knob moves the cursor, some of the knobs work and pads work when global channel is set to 1 with MCC, but I simply cannot change modes.
Note that you can also check the MIDI channel by using the CHAN button right to the SHIFT one.

hexfarmer wrote:
Tue Jan 21, 2020 2:31 pm
It is the play mode I would like with the ability to change octaves and the ability to chose scales sounds amazing but alas, I cant get it to work.
It's not working for me either (see my first post), but at least, something is displayed on the screen (eg. C-G-A-Bb..., Major-MinorMixolydian..., etc.)

hexfarmer wrote:
Tue Jan 21, 2020 2:31 pm
I have a question about the controller settings is BW, does it matter what the pads are set to?
the section where it says "convert poly aftertouch to..." I have it set to poly aftertouch, does it matter what this is set to?
From what I understand, it should not interfere. You can always discard aftertouch by choosing to convert to 'Off' (it didn't change anything for me).

hexfarmer wrote:
Tue Jan 21, 2020 2:31 pm
I bought it used from someone else, is there any chance there is some weird setting on it and I need to return it to factory reset before I load Moss' template?
There is some sort of factory reset since firmware v1.2.0.3. It's poorly explained in release notes. After some tries, I understand that you have to press RECALL+PLAY buttons while powering the unit on (this last instruction is not written in release notes, but if you try when already powered on, the RECALL+PLAY combo has no effect)

hexfarmer wrote:
Tue Jan 21, 2020 2:31 pm
Is there some sort of test I can perform on the beatstep to make sure it is functioning well or that it is the right state to work with Moss' template?
Try the MIDI console in MCC, or MIDI-OX: when moving the first knob, the CC number should be 14 (hexadecimal value), next would be 15, etc.

hexfarmer wrote:
Tue Jan 21, 2020 2:31 pm
Thanx again for trying to help this is driving me nuts, I feel so close to getting it to work properly
Remember that it's not working for me either ;). But if you managed to get it working a little bit more, you may help me to debug my situation :hug:

esq1
KVRist
50 posts since 28 Mar, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 10:35 am

moss wrote:
Tue Jan 21, 2020 11:20 am
esq1 wrote:
Mon Jan 20, 2020 9:39 pm
  • There is a possibility to call the function "show clip luncher" as if i was using the "L" key on my PC Keyboard?
Keep the Master button pressed, on the screen you see now different panes you can show/hide. Select the "clip launcher" to toggle.
Super! I find it ! Thaaaaank you !!!

@Jürgen: I don't dare to ask the support is already awesome and fun :) , butWould it be possible for a future update if there were a label on the display for this funktions?

esq1
KVRist
50 posts since 28 Mar, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 10:48 am

moss wrote:
Tue Jan 21, 2020 11:20 am
esq1 wrote:
Mon Jan 20, 2020 9:39 pm
  • if i use a LFO in "POLY GRID" i can move the Encoders, the value was changed in the LFO Modul but the values it is not shown in the PUSH display. Is this a bug in Bitwigs "POLY Grid"?
Did you map the LFO control you want to change to a remote control page?
I hope I can describe it reasonably with google translate :)

I have deleted in POLY GRID all modules to test. If i darg and drop the LFO Modul and I turn to the encoders the values in the PUSH Display do not change. If i load e.g a Oscillator Modul, or a ADSR, AD all works fine.

I have now in the Bitwig remote control all default mappings of the LFO Modul deletet and and reassigned. It works now. Somehow it seems to be a mistake in Bitwig?????

Alma Mare
KVRer
9 posts since 10 Apr, 2018

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 12:06 pm

Moss, I'm sorry to be a nuisance, but I had to point this out:

I was looking back at your video on the Launchpad X support in Bitwig ( https://www.youtube.com/watch?v=O1r8zePOmos ) because I wanted to check out the behaviour of the cursor keys on the top row (right now, for me, they just exit volume page and send me to Note page) and I noticed that at 2:20, you are showcasing the volume page and it behaves exactly as we described here :p

Reckon104
KVRist
119 posts since 16 Jul, 2018

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 7:39 pm

Alma Mare wrote:
Wed Jan 22, 2020 12:06 pm
Moss, I'm sorry to be a nuisance, but I had to point this out:

I was looking back at your video on the Launchpad X support in Bitwig ( https://www.youtube.com/watch?v=O1r8zePOmos ) because I wanted to check out the behaviour of the cursor keys on the top row (right now, for me, they just exit volume page and send me to Note page) and I noticed that at 2:20, you are showcasing the volume page and it behaves exactly as we described here :p
Yes, I almost hate to bring it up as well, because I am so thankful for the work done on this, but yes, at a bit after 2:20 you see what we are talking about and it also happens on the "pan" setting for me. One thing, I do have 7.60 because I can't afford to upgrade bitwig at this point, so my guess is that 7.6 won't be updated anyway, but at least I know it's not just me.

User avatar
hexfarmer
KVRer
17 posts since 9 Jan, 2020

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 7:59 pm

peemge wrote:
Wed Jan 22, 2020 10:06 am

There is some sort of factory reset since firmware v1.2.0.3. It's poorly explained in release notes. After some tries, I understand that you have to press RECALL+PLAY buttons while powering the unit on (this last instruction is not written in release notes, but if you try when already powered on, the RECALL+PLAY combo has no effect)

Remember that it's not working for me either ;). But if you managed to get it working a little bit more, you may help me to debug my situation :hug:
Thank You Arnaud!!
This was it, the RECALL+PLAY and power on unit has worked :)
You rock man, now I can change modes and I actually see messages on screen when I do that.

The octave and scale changes did not work at first but after resetting BW, they now work!

User avatar
hexfarmer
KVRer
17 posts since 9 Jan, 2020

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Jan 22, 2020 9:33 pm

peemge wrote:
Sun Jan 19, 2020 9:05 am

Here are some problems I went through:
  • when I change modes with Shift+Pad, a 'note on' message (corresponding to the Pad I press) is sent
    [I would assume there isn't any 'note on' message sent when selecting a mode];
  • in play mode, if I switch to the Chromatic view (where only notes that are in scale are lit), the major scale in C seems not right when I switch from the bottom line of pads to the upper line;
    [To be precise, in my case, pad 9 is C, pad16 is G and pad 1 is G#, which seems incorrect regarding your wiki or your first YT video at 7:12, where I should have pad1 as D#, right?]
  • always in play mode, the base note and octave knobs have no effect on what is played;
  • when navigating in the browser, knobs are not corresponding to columns as shown on your YT video.
    [Knob#11 isn't on the third column from the left but on the small cell that is right under the second column and knob#15 is on the cell under the first column; not sure if it is what to expect]
regarding your issues, here is how my unit is behaving in comparison to yours.

1, when you are saying that a 'note on' message is sent, do you mean that you see midi activity on BW when you change modes? (yellow light as you hold shift and hit the pad?) and does it perhaps make a sound/trigger a synth if one is selected?
if yes, then this is not happening on mine. when I hit a pad alone in play mode, I see midi activity (yellow light) but if I am holding shift and hit a pad, it does not do this.

2, you are correct in this observation, I have the same result. the top pads do not align with the wiki.

3, I am not sure what you mean by this, perhaps you can elaborate? are you saying that the base/root note (pad 9) is always the same tone?

4, Ill have to watch the YT video and see if mine is doing the same.
Ill try to do this tomorrow (it is almost 1am here in toronto) but at this moment I am so excited that my beatstep is working with bitwig (thanx again for helping me figure that out :)

peemge
KVRer
7 posts since 10 Mar, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Jan 23, 2020 12:56 am

hexfarmer wrote:
Wed Jan 22, 2020 7:59 pm
now I can change modes and I actually see messages on screen when I do that.
Good news!

hexfarmer wrote:
Wed Jan 22, 2020 7:59 pm
The octave and scale changes did not work at first but after resetting BW, they now work!
What do you mean by resetting Bitwig?
I actually tried to reset Bitwig by:
  • removing the program;
  • deleting 'Bitwig Studio' folders in both %USERPROFILE%\Documents and %USERPROFILE%\AppData\Local\;
  • removing every registry entry that contains 'bitwig' string;
but it always behave the same.

hexfarmer wrote:
Wed Jan 22, 2020 9:33 pm
1, when you are saying that a 'note on' message is sent, do you mean that you see midi activity on BW when you change modes? (yellow light as you hold shift and hit the pad?) and does it perhaps make a sound/trigger a synth if one is selected?
if yes, then this is not happening on mine. when I hit a pad alone in play mode, I see midi activity (yellow light) but if I am holding shift and hit a pad, it does not do this.
(...)
3, I am not sure what you mean by this, perhaps you can elaborate? are you saying that the base/root note (pad 9) is always the same tone?
1. Yes, this is indeed my problem: when I'm holding shift and hit a pad, I see MIDI activity (yellow light) and it makes a sound if a synth is selected. I have the same problem when selecting a track in the TRACK mode; every time I switch to a track, there is MIDI activity and a sound is triggered.

3. That's right, the tone of pad9 stays the same even if I change the base note or octave via dedicated knobs.

hexfarmer wrote:
Wed Jan 22, 2020 9:33 pm
2, you are correct in this observation, I have the same result. the top pads do not align with the wiki.
So this could be a bug in the script.

hexfarmer wrote:
Wed Jan 22, 2020 9:33 pm
4, Ill have to watch the YT video and see if mine is doing the same.
Ill try to do this tomorrow (it is almost 1am here in toronto) but at this moment I am so excited that my beatstep is working with bitwig (thanx again for helping me figure that out :)
Time zone shift let us at least some time to respond to each other ;)
Glad that it's working on your side. Now I'm sure that something is missing from mine, I'll try again later today.

vincenzoml
KVRist
62 posts since 26 Feb, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Jan 23, 2020 1:51 am

Hi, the new note repeat mode on the launchpad pro is just amazing. One hidden gem is that aftertouch will change the velocity of the repeated notes (at least that's what seems to me... how is this controlled?).

I have a feature request though: in note mode, I need a way to start recording a clip on the fly without removing my two hands from the keyboard[*].

Think e.g. a single button that will launch a new clip (first empty slot available) on the current track. In general in note mode it's uncomfortable to switch to session mode for that.

There are three session buttons that are not used in note mode, what about using the middle one for starting recording in an empty slot in the currently selected track? Just like the double function, but start recording instead of adding an empty clip. Also note that in note repeat mode if I press "shift" because I want to duplicate a clip, the repetition is stopped.

Also: do you think it would be possible to make the track "sticky" i.e. not follow bitwig's selected track, but keep an internal memory in the script and just stay on the track selected via the launchpad in note mode?


[*] That's wonderful for live improvisation: I first explore the keyboard until I find an arpeggio that I love, then want to record it, but both hands are already on the keyboard. A "hold" button could also do something, but then the ability to modulate velocity using aftertouch is lost and that's a pity.

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Jan 23, 2020 5:46 am

Alma Mare wrote:
Wed Jan 22, 2020 8:23 am
I've noticed a bunch of red messages on the script console. I have mp clue if it's helpful, but might as well, I suppose
Called init()
Crash during flush.
java.lang.NullPointerException
Yes, that bug is already known and fixed. Will be available in the next update.
Alma Mare wrote:
Wed Jan 22, 2020 8:23 am
As for my other question, the thing is I have several HW synths, each living on their own tracks, which I'd like to have input monitoring at all times since some of them are running their own sequences. I'm looking for a way to be able to select and play them one at a time and send the Pad notes only to that synth without triggering the other ones who aren't recording at that time (but are having their inputs monitored). On my M-audio Code I do that by selecting the correspondent midi channel on the unit itself. The Launchpad only sends on channel 1, so even though I can select the track I want to play, the notes I play trigger all synths.
You should use the hardware instrument device then it is not necessary to have record enabled for listening (which is also not necessary in general, only the input monitor needs to be active). Create yourself a song template which contains your hardware synth setup then you have it available each time you start Bitwig.

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Jan 23, 2020 5:47 am

esq1 wrote:
Wed Jan 22, 2020 10:35 am
@Jürgen: I don't dare to ask the support is already awesome and fun :) , butWould it be possible for a future update if there were a label on the display for this funktions?
Not sure what you mean. The different panes and layouts are already named on the Push display. Do you mean to view a notification in Bitwig?

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Jan 23, 2020 5:54 am

Alma Mare wrote:
Wed Jan 22, 2020 12:06 pm
Moss, I'm sorry to be a nuisance, but I had to point this out:

I was looking back at your video on the Launchpad X support in Bitwig ( https://www.youtube.com/watch?v=O1r8zePOmos ) because I wanted to check out the behaviour of the cursor keys on the top row (right now, for me, they just exit volume page and send me to Note page) and I noticed that at 2:20, you are showcasing the volume page and it behaves exactly as we described here :p
Ah, you mean when I press the 2nd row counting from the top! This is just a little rounding error depending on how hard you press the pads on this row. If it is hard it already lights the top pad.

Return to “Controller Scripting”