DrivenByMoss - Bitwig extension for lots of controller devices (and more)

tslays
KVRist
33 posts since 6 Apr, 2020

Post Mon Apr 06, 2020 2:00 am

Hi Jürgen,

First of all, I want to say thank you. Thank you for making all these devices so awesome in Bitwig. I couldn't have switched so easily without you. Again, THANK YOU!

Second: You made an update for the Launchpad so that the master track content in the clip launcher is not showing. So you don't have this empty cell when you don't use the master track content.

Can you please update the Launchkey Mini Mk3 to have the same option? That would be awesome! Thanks! :)

Tobias

User avatar
moss
KVRAF
2055 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Apr 06, 2020 2:11 am

tslays wrote:
Mon Apr 06, 2020 2:00 am
Hi Jürgen,

First of all, I want to say thank you. Thank you for making all these devices so awesome in Bitwig. I couldn't have switched so easily without you. Again, THANK YOU!

Second: You made an update for the Launchpad so that the master track content in the clip launcher is not showing. So you don't have this empty cell when you don't use the master track content.

Can you please update the Launchkey Mini Mk3 to have the same option? That would be awesome! Thanks! :)

Tobias
Sure.

Yokai
KVRian
872 posts since 7 Nov, 2017

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 6:35 am

moss wrote:
Sat Apr 04, 2020 6:55 am
If you like RTFM there is now a DrivenByMoss PDF manual (will also be included in future updates)! Many thanks to Ryan for contributing those nice Launchpad images!

https://github.com/git-moss/DrivenByMos ... Manual.pdf
Kudos! Very helpful, you two.

One feature request, though... Can you set your PDF generator to enable hyperlinking from the TOC entries?

User avatar
moss
KVRAF
2055 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 6:52 am

Yokai wrote:
Tue Apr 07, 2020 6:35 am
One feature request, though... Can you set your PDF generator to enable hyperlinking from the TOC entries?
Depends on which you mean. The PDF bookmarks work fine as well as the Contents links (with that you have to click the text not the page numbers!).
What is broken are the links in the Introducion list. I wasted several hours trying to fix this. If someone is an expert in converting Markdown to PDF, please get in touch with me!

KleinAberFein
KVRer
21 posts since 22 Mar, 2020

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 1:38 pm

Hi,

I noticed something called Bome Virtual Midi in the programs installed on my Laptop and I did not install it as far as I know.
Is it part of your Software?

Cheers
KAF
My preferred genre, Ethnic EDM, aka Oriental Techno:
https://open.spotify.com/playlist/3fVKm ... z7KIOLyFYw

User avatar
strovoknights
KVRist
415 posts since 22 Aug, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 3:26 pm

Thanks for DrivenByMoss!
Maybe AMD USB issues ?
My setup is Komplete Kontrol M32 and Launchkey Mini MK3 with AMD X570 and Ryzen 3700X.
When I use Launchkey MINI MK3 and KK M32 at the same time, KK M32 freezes when I start Bitwig.
Disconnecting Launchkey MINI MK3 and starting Bitwig, KK M32 not freeze and it will be recognized.
and I love functions of Launchkey Mini MK3 and DrivenBymoss!
VST Mappings for Bitwig
Maschine MK2/JAM/ for Bitwig

Mantras
KVRist
53 posts since 31 Dec, 2005

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 9:11 pm

I bought a Push 1 to use with Bitwig with the moss script and I am experiencing some major issues with display lag, and unresponsive display behavior.

I am using the latest version of Bitwig 3.1.3 and the Driven By Moss script 8.95 with OSX 10.12.6.

I can confirm this Push 1 works absolutely normally with Ableton 10 and shows no anomalies when checked with a midi monitor application. So what is going on here???
 I uploaded a .gif version of video I recorded with my phone on gfycat.

https://gfycat.com/physicalflamboyantcalf

What is shown here is a mild example. Sometimes when I am running a project where it takes the display about 8 seconds to respond from when I am turning the knob.

https://gfycat.com/sarcasticcharmingaztecant

This lag seems to be present throughout in different things, not only volume. Sometimes when I click Octave Down or Octave Up it will get stuck showing that C1 to C5 information for a very long time, making it impossible to see the other parameters even if I click a button.

Finally, when I click the Clip button I will get the display showing "Please select a clip."
After that I can never get back to any other display information, whatever button I press the same message stays in the display. The only solution after pressing the clip button is to restart both Bitwig and Push1.

Edit: I did see some improvement on the lag issue when turning off the VU meters in the settings. But then still I get stuff happening like this:

https://gfycat.com/wickedrepulsivebream

I am not touching the knobs in this video. One would think there is an issue with the knobs but there is not, I have confirmed both in Ableton and with midi monitor. The knobs works fine.
Last edited by Mantras on Tue Apr 07, 2020 10:03 pm, edited 2 times in total.

Mantras
KVRist
53 posts since 31 Dec, 2005

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 9:57 pm

MarkRM wrote:
Sun Mar 08, 2020 8:06 pm
I was wondering if anyone could help with an issue I've been having with Push4Bitwig since I first gave it a shot.

It's an awesome thing but I've always have huge lag with the display on my Push 1. For example, if I grab the Pan parameter and perform, say, five quick left-right movements, the Push 1 display will keep moving after I've stopped, taking time to catch up with my movements.

Has anyone else ever had this issue and been able to solve it? The Push 1 is running on USB bus power. Perhaps people have had better luck running it off a power supply?

Thanks!
I am having the same issue, and power supply or no power supply the issue is the same.

MarkRM
KVRist
76 posts since 8 Mar, 2009

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 10:23 pm

Mantras wrote:
Tue Apr 07, 2020 9:57 pm
MarkRM wrote:
Sun Mar 08, 2020 8:06 pm
I was wondering if anyone could help with an issue I've been having with Push4Bitwig since I first gave it a shot.

It's an awesome thing but I've always have huge lag with the display on my Push 1. For example, if I grab the Pan parameter and perform, say, five quick left-right movements, the Push 1 display will keep moving after I've stopped, taking time to catch up with my movements.

Has anyone else ever had this issue and been able to solve it? The Push 1 is running on USB bus power. Perhaps people have had better luck running it off a power supply?

Thanks!
I am having the same issue, and power supply or no power supply the issue is the same.
Thanks Mantras. Yeah, I've never been able to fix this problem. I'm really not sure if this is a known issue and it's just the way it is with the Push 1. I've posted about it a couple of times and never had a response from Moss confirming that or from other users of the script saying they do/don't have the same problem.

Mantras
KVRist
53 posts since 31 Dec, 2005

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 11:19 pm

Ok.. Here is one more video.

I am turning on Push, and then opening Bitwig and choosing new project.
With nothing playing in the new project, there is obvious lag when turning the tempo knob.
What is going on here??? Can someone with a Push 1 confirm this behavior?

https://gfycat.com/pessimisticevenaruanas

vincenzoml
KVRist
65 posts since 26 Feb, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 11:26 pm

Hi @moss, here is a suggestion for the LP Pro script (and maybe other controllers): when changing volume, pan or sends, it's easy to find the track I want to control, since colours are present. What about showing colours of tracks also for track select (and maybe record arm, mute, solo)? Especially track select is messy for live usage (for me at least). I usually first press volume to identify the right track, and then release it, and select the track. I tried keeping a stable template but that doesn't work since sometimes I need to quickly add a track for one more parallel loop of the same instrument.

User avatar
moss
KVRAF
2055 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 11:29 pm

KleinAberFein wrote:
Tue Apr 07, 2020 1:38 pm
I noticed something called Bome Virtual Midi in the programs installed on my Laptop and I did not install it as far as I know.
Is it part of your Software?
No. If you remember you simply copied the file DrivenbyMoss.bwextension...

AFAIK, it is part of NI Komplete Kontrol and used for internal MIDI communication (I assume they create the *DAW MIDI ports with it). The company BOME provides several MIDI tools, check out his website: https://www.bome.com/

User avatar
moss
KVRAF
2055 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 11:30 pm

strovoknights wrote:
Tue Apr 07, 2020 3:26 pm
Thanks for DrivenByMoss!
Maybe AMD USB issues ?
My setup is Komplete Kontrol M32 and Launchkey Mini MK3 with AMD X570 and Ryzen 3700X.
When I use Launchkey MINI MK3 and KK M32 at the same time, KK M32 freezes when I start Bitwig.
Disconnecting Launchkey MINI MK3 and starting Bitwig, KK M32 not freeze and it will be recognized.
and I love functions of Launchkey Mini MK3 and DrivenBymoss!
Sounds like an USB issue. Try using different ports, exchange cables, different USB hubs, the usual USB fun...

User avatar
moss
KVRAF
2055 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Apr 07, 2020 11:34 pm

MarkRM wrote:
Tue Apr 07, 2020 10:23 pm
Mantras wrote:
Tue Apr 07, 2020 9:57 pm
MarkRM wrote:
Sun Mar 08, 2020 8:06 pm
I was wondering if anyone could help with an issue I've been having with Push4Bitwig since I first gave it a shot.

It's an awesome thing but I've always have huge lag with the display on my Push 1. For example, if I grab the Pan parameter and perform, say, five quick left-right movements, the Push 1 display will keep moving after I've stopped, taking time to catch up with my movements.

Has anyone else ever had this issue and been able to solve it? The Push 1 is running on USB bus power. Perhaps people have had better luck running it off a power supply?

Thanks!
I am having the same issue, and power supply or no power supply the issue is the same.
Thanks Mantras. Yeah, I've never been able to fix this problem. I'm really not sure if this is a known issue and it's just the way it is with the Push 1. I've posted about it a couple of times and never had a response from Moss confirming that or from other users of the script saying they do/don't have the same problem.
I can reproduce that on Mac but it is not as bad as on your system (it feels a bit sloppy except leaving Clip mode taskes about 10 seconds). On Windows it does not happen, except leaving the Clip mode is a bit slow.
It happens also in the device simulator, so it is not a hardware issue. Need to analyse this further but this might take some time.

KleinAberFein
KVRer
21 posts since 22 Mar, 2020

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Wed Apr 08, 2020 2:56 am

Well, you know more than NI about NI.
That was my first thought because NI was mentioned in my Google searches, but I've asked them in chat and they said no.
I guess some of the chat people don't really know so much.
Thanks...
My preferred genre, Ethnic EDM, aka Oriental Techno:
https://open.spotify.com/playlist/3fVKm ... z7KIOLyFYw

Return to “Controller Scripting”