Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Discussion about: tracktion.com
johnzo
KVRer
3 posts since 31 Mar, 2020

Post Fri Apr 03, 2020 11:25 am

Hi folks--

I am having some framerate and UI freezing problems with Waveform Free on Ubuntu Studio 19.10

The problem is triggered by the EDM template. When I start a new project based on this template and play it, the framerate visibly starts to suffer and the gauges lag. The stop/play button and volume do not respond to clicks. The song plays fine.

I do have "Use Low Detail Interface" checked.

My computer doesn't seem to have any resource constraints. It is an 8-thread i7 with 16GB of RAM. I have a 4K monitor, a nvidia

- System load is below 2 during the problem.

- Waveform is using 100%-150% CPU.

- the CPU meter on Waveform is <20% even as the UI fps visibly decline and buttons fail to respond to clicks.

- the detailed CPU usage shows that the 4OSC synths are all using 10%-40% of a CPU.

- cpufreq is set to Performance for all CPUs.

It doesn't look like Waveform is starved of resources, and also keep in mind that the music playback is smooth while the UI FPS suffer.

Also note that I have "Use Low Detail Interface" checked. I've tried adjusting the UI scaling to 100% (unusable on a 4K screen) and that doesn't help.

edit: Here's a video showing the problem: https://youtu.be/Qlfph6RvxqA

I couldn't record the sound, the screen recorder didn't want to deal with Jack, but rest assured the song is playing perfectly.

When I start playing the song the FPS issues are shown by the sine wave modifier on the hi-hat track, it gets visibly chunky.

I click the stop button once on measure 5 of the song, but the song keeps playing. I try to open the volume control around bar 9, no response. The song continues playing and repeats. Note how the mouse cursor is stuck in the up/down arrow. Finally I have to kill the program with the shell

Note that the video the system load and CPU are higher due to my screen recorder, but the symptom is identical regardless of whether the screen recorder is active or not.

Kott
KVRist
199 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Sun Apr 05, 2020 5:57 am

I can confirm. Moreover this is coincidence of two issues.
1. Sometime GUI became unresponsive during loop playing. After second iteration it is active again, but I didn't find exact step to reproduce before.
2. Huge framedrops in this edit. Maybe it's possible to isolate problem with freezing/rendering tracks one by one.

Kott
KVRist
199 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Fri May 08, 2020 6:35 pm

It's still unfixed in 11.0.26. Actually, this problem makes Waveform unusable on more or less complex edits in Linux.

johnzo
KVRer
3 posts since 31 Mar, 2020

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Sat May 09, 2020 1:12 pm

yeah, I gave up on Traktion for Linux and moved onto Bitwig Studio for Linux, which has been rock-solid.

dRowAudio
KVRAF
1709 posts since 30 Dec, 2012

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Thu May 21, 2020 10:17 am

I notice that you've got the popup help displaying in your video. If you turn that off bottom left hamburger menu -> "Help" -> "Turn off popup help" does that improve things?

I tried replicating this with a 19.10 VM but it seemed to perform ok.
Was it only this Edit or all Edits that exhibit the sluggish UI?

Kott
KVRist
199 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Thu May 21, 2020 3:35 pm

Turing popups off doesn't help.
Was it only this Edit or all Edits that exhibit the sluggish UI?
This Edit is the quickest way to reproduce problem. With some Edit (simple plugins, not many tracks) all works fine.
I cannot find the border where it start to misbehavior.
Slow FPS is not only problem. As I say before, GUI became unresponsive during loop playing for a while or for such long so I have to kill process.

Kott
KVRist
199 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Thu May 21, 2020 3:44 pm

How can I help to provide evidences and diagnostic, videj, strace, etc?
Is it possible due lack of HW, such CPU command sets?

madrang
KVRist
48 posts since 21 Jun, 2016

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Fri May 22, 2020 12:06 am

I do not have that issue, but those commands could help to find it.
Also could be worth sharing a perf.data file with the devs and forum so we can compare results.

This will create a perf.data file that can be analysed.

Code: Select all

sudo perf record /usr/bin/Waveform11
Will display time spent in libraries.

Code: Select all

perf report --stdio -g none --sort comm,dso -i ./perf.data
To display time in functions

Code: Select all

perf report --stdio -g none -i ./perf.data 
Selection_368.png
Selection_369.png
Selection_370.png
You do not have the required permissions to view the files attached to this post.

Kott
KVRist
199 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Fri May 22, 2020 2:06 am

Thanks, I'll do.
Could you tell what is your system, HW and OS?

Kott
KVRist
199 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Fri May 22, 2020 2:17 am

Before digging into perf. I have 3 results now:
AMD FX8120 NVIDIA blob - openSUSE TW- bad
i5-2410M - openSUSE TW- good!!!
i7-3770K - Ubuntu18.04 in VM - bad

Kott
KVRist
199 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Fri May 22, 2020 2:59 am

dRowAudio wrote:
Thu May 21, 2020 10:17 am
I tried replicating this with a 19.10 VM but it seemed to perform ok.
madrang wrote:
Fri May 22, 2020 12:06 am
I do not have that issue, but those commands could help to find it.
What is your video card and resolution, guys?
I think I found where the shoe pinches.

Two my systems have 2K displays (2560x1440 and 2560x1080), and both affected. Laptop has 1600x900 and no troubles.
So, I switched down my 2K desktop to 1920x1080 and got almost (but not exact) same low fps and glitched (but not stucked) GUI. I switched to 1600x900 - and all is fine.

It is good news, for what it's worth.

PS. And yes, "Use low detail interface" hasn't effect. And original post was about 4K display.

madrang
KVRist
48 posts since 21 Jun, 2016

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Fri May 22, 2020 10:39 am

Kott wrote:
Fri May 22, 2020 2:59 am
What is your video card and resolution, guys?
I'm on a four display setup.

Ubuntu 20.04 LTS (64 bit)
Intel(R) Core(TM) i7-5930K CPU @ 3.50GH
NVIDIA Corporation GeForce GTX TITAN
NVIDIA 440.64

Display 1 Resolution: 1920 x 1080 (16:9)
Display 2 Resolution: 1680 x 1050 (16:10)
Display 3 Resolution: 1680 x 1050 (16:10)
Display 4 Resolution: 1920 x 1080 (16:9)
Desktop Resolution: 5280 x 2160

Had a segfault in the past due to DPI and my weird screen setup, but GUI performance has been fine.
viewtopic.php?f=22&t=509852&p=7167251#p7167251

Kott
KVRist
199 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Fri May 22, 2020 3:31 pm

So your Waveform window is about 5280 x 2160 size?

User avatar
astey
KVRist
107 posts since 9 Feb, 2017

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Sat May 23, 2020 3:11 am

I'm on Windows 10 64bit and can relate to that.
I'm running 4 displays:
1x QHD@165hz
3x FHD@60hz

I use Waveform on 2560x1440: it's very sluggish and the GUI stalls. I'm running a Nvidia 1070GTX and i7 7700k@4.9ghz atm. Since W11 doesn't take benefits of graphics cards, the CPU is the main focus. Task manager reports 80-100% usage on a single core by using the mouse lasso.
GUI scaling performance is the main issue on Windows 10. Running W11 on a tiny footprint leaves it quite responsive.

I made a video running W11 in a very small window compared to QHD fullscreen. I use the cursor lasso in a circular motion to demonstrate that W11 can't keep up at all on fullscreen. This video is the third take. On the first take W11 even crashed without log. Strange.
Dropbox link:
https://www.dropbox.com/s/1g22zkm534ms3 ... s.mp4?dl=0

Can imagine what it's like on 4k.
Its the only Daw that behaves this way. Studio one, Bitwig, Ableton, Reaper run fine on my setup.

(I'm going to upgrade my setup to a Samsung G9 this summer (5120x1440@240hz), 'guess then I'm going to run into real trouble, if I want to use Waveform.)

User avatar
astey
KVRist
107 posts since 9 Feb, 2017

Re: Tracktion Waveform Free FPS / UI unresponsive issues on Ubuntu Studio 19.04

Post Mon May 25, 2020 2:32 am

Here is a quick side by side comparison of the GUI performance:
Trackton Waveform 11 vs. Bitwig 3.
Both apps loaded a small/medium sized project. Both apps run simultaneously.
Comparison:
  • Cursor scroll in a circular motion on the arranger.
  • Cursor selects notes in midi editor.
  • Cursor moves some notes in midi editor
Result: Bitwig's interface performance is superior compared to W11.
(Bitwig would stay snappy on larger projects as well.)

Specs:
  • Windows 10
  • Cpu: Intel i7 7700k @4.9ghz
  • Graphics: Nvidia GTX 1070
  • RAM: 16gb
  • Display: Acer 27" 2560x1440 @165hz
  • Scaling: 100% on both W11 & Bitwig. W11: "Use Low Detail Interface" enabled
http://vimeo.com/422383817

I hope the performance of Waveform will be improved to keep up or even surpass other DAWs. Its current GUI performance is insufficient for larger projects.

Cheers

Return to “Tracktion”