XLN Audio - XO - Improvement, Pros, Cons

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
Jkist
KVRist
39 posts since 21 Jul, 2020

Post Fri Jul 31, 2020 3:27 pm

I downloaded the demo. I then proceeded to point it to my "music creation" master folder, which contains a bajillion samples from Komplete 12 Ultimate, Omnisphere, and a bunch of other libraries I own. Its been sorting my sounds for over an hour now :hihi:

User avatar
Jkist
KVRist
39 posts since 21 Jul, 2020

Post Sat Aug 01, 2020 1:13 am

yellowmix wrote:
Sat Jun 27, 2020 12:29 pm
colabean wrote:
Sat Jun 27, 2020 8:53 am
Can XO be easily used as a 'sample searcher' to be used in conjunction with a *different* method of sequencing?
Yes, as good as the sequencing is, that's primarily how I use it. You can drag and drop directly from the export panel to Battery, Geist, your DAW timeline, etc.. You can drag a entire kit into Battery and Geist (haven't tried others) and it will automatically arrange across cells.
Thats pretty cool about the dragging entire kits onto Battery. One big limitation of XO is only 8 slots, but this means you can drag two different kits into one battery kit, or even 3 kits. So I can use XO to find and build kits, then simply use Battery to trigger them. Pretty neat!

gondii
KVRist
112 posts since 8 Oct, 2019

Post Sat Aug 01, 2020 1:53 am

You can also drag individual samples straight from the cloud into another VST. That's super fast. XO just plays extremely well with others.

User avatar
LoveEnigma18
KVRAF
2454 posts since 12 Jan, 2018

Post Sat Aug 01, 2020 2:32 am

gondii wrote:
Sat Aug 01, 2020 1:53 am
You can also drag individual samples straight from the cloud into another VST. That's super fast. XO just plays extremely well with others.
That's an excellent way to make unique and interesting sounds simply by dragging any sound from XO directly into Pigments 2 or ANA 2. :tu:
Never imagined we would get to play with toys in adulthood. :)

User avatar
LoveEnigma18
KVRAF
2454 posts since 12 Jan, 2018

Post Sat Aug 01, 2020 3:39 am

I am using the latest version of XO and I realized that sometimes I hear no sound when I click/navigate in the XO Space. The click pointer appears like a big circle. When I drag my mouse, no sound comes. Anyone else facing this? There is no scan pending for my libraries if that matters.

Using XO as a VST inside FL Studio latest version.
Never imagined we would get to play with toys in adulthood. :)

JiggSaw
KVRist
140 posts since 28 Jun, 2004

Post Sat Aug 01, 2020 4:26 am

Anyone willing to trade presets? Would love to see what kind of patterns other users are coming up with

User avatar
Rivanni
KVRist
379 posts since 4 Feb, 2017

Post Sat Aug 01, 2020 9:22 am

LoveEnigma18 wrote:
Sat Aug 01, 2020 3:39 am
I am using the latest version of XO and I realized that sometimes I hear no sound when I click/navigate in the XO Space. The click pointer appears like a big circle. When I drag my mouse, no sound comes. Anyone else facing this? There is no scan pending for my libraries if that matters.

Using XO as a VST inside FL Studio latest version.
What is the scaling of XO? I have this problem of not being able to select anything if I don't start at 100% zoom. I can change the zoom after opening XO at 100%. I mustn't forget to reset back to 100% when I close XO. And yes, this was already reported as a bug months ago.

User avatar
LoveEnigma18
KVRAF
2454 posts since 12 Jan, 2018

Post Sat Aug 01, 2020 10:04 am

Rivanni wrote:
Sat Aug 01, 2020 9:22 am
LoveEnigma18 wrote:
Sat Aug 01, 2020 3:39 am
I am using the latest version of XO and I realized that sometimes I hear no sound when I click/navigate in the XO Space. The click pointer appears like a big circle. When I drag my mouse, no sound comes. Anyone else facing this? There is no scan pending for my libraries if that matters.

Using XO as a VST inside FL Studio latest version.
What is the scaling of XO? I have this problem of not being able to select anything if I don't start at 100% zoom. I can change the zoom after opening XO at 100%. I mustn't forget to reset back to 100% when I close XO. And yes, this was already reported as a bug months ago.
Thanks for the information. But before I read your message, I did a forced re-scan of my entire library, which I did not want but that's only thing I could think of. To my surprise, the problem disappeared and I could hear the sound when dragging in the XO Space. I still need to verify this by opening the XO VST in my DAW.

Next time this happens, I will try out your suggestion.

I had dropped an email to XO too and got this suggestion:
What if you search your computer for XO.dll and remove that file, then run the Online Installer and let it repair your XO and see if it works as it should.
When emailing back to them, I will mention both my and your observations and hopefully they will look into it. Forced re-scan isn't amusing at all, so worst case, I hope your scaling suggestion solves the problem next time it happens, and that too only until they fix the actual thing.
Never imagined we would get to play with toys in adulthood. :)

User avatar
Jkist
KVRist
39 posts since 21 Jul, 2020

Post Sat Aug 01, 2020 1:06 pm

Oof yeah, it took over an hour to scan the first time around for me. Definitely wouldn't want to do that often.

User avatar
WatchTheGuitar
KVRAF
2372 posts since 30 Apr, 2019

Post Sat Aug 01, 2020 2:00 pm

Last time I did the full scan was after I'd added everything from Samples From Mars.
Very glad I'd relocated the samples folder to a 3500MB/s M2 drive. It still took bloody ages.

Return to “Instruments”