Minor gripes/suggestions (M8)

Official support for: mutools.com
yul
KVRian
1170 posts since 26 Sep, 2002 from Montreal, CANADA

Post Wed Dec 09, 2020 1:53 pm

Hello! Proud owner of M8.6.17. I haven't update since a few months sorry if this has been adressed.

A couple things I would love to see if that's possible I believe it may be of value to all:

backup project files : sometimes by mistake one can open a backup file instead of the project file. It would be nice to have a warning when opening such a file (ideally a flag in the project as well)

Active compose track/multitimbral instrument: when I open a project, the active track/midi notes does not correspond to the instrument part that is being played. It always reverts to channel 1 unless I click the already selected track. This is limited to multitimbral instruments sharing different midi channels. Causes confusion and potential errors..

Mixer/modular : sometimes some pieces of the mixer can get displaced with erratic mouse movements. This makes me nervous. Also the mixer strip levels can slide into the mixer rack and cannot be deleted. Deletion removed the entire rack...It would be nice to lock down the modular aspects if needed.

Fullscreen : the actual fullscreen does not seem to be really fullscreen, but rather enlarged screen. Sometimes erratic mouse moves can resize unintentionnally..

Thanks!

User avatar
KVRAF
1873 posts since 28 Mar, 2008 from a Galaxy S7 far far away

Post Wed Dec 09, 2020 2:44 pm

I think MuLab shouldn't show the backup files in general, perhaps unless an option is set to show/hide them.
I'm sure I mentioned this fullscreen thing many years ago? I agree. It should be properly maximized.

User avatar
KVRAF
10976 posts since 24 Jun, 2008 from Europe

Post Fri Dec 11, 2020 10:05 am

yul wrote:
Wed Dec 09, 2020 1:53 pm
Active compose track/multitimbral instrument: when I open a project, the active track/midi notes does not correspond to the instrument part that is being played. It always reverts to channel 1 unless I click the already selected track. This is limited to multitimbral instruments sharing different midi channels. Causes confusion and potential errors..
I cannot repeat this.
As a test i made a simple project with rack with a MUX with a channel splitter to 2 different sounds.
Created 2 tracks for that same rack, but track 1 to chan 1, track 2 to chan 2.
Then i selected track 2 and MIDI input goes to that MUX chan 2, as expected.
I saved the project, then reloaded it and immediately played MIDI input without clicking anything and it was the MUX chan 2 sound that was playing, as expected.

yul
KVRian

Topic Starter

1170 posts since 26 Sep, 2002 from Montreal, CANADA

Post Sun Dec 13, 2020 8:11 am

mutools wrote:
Fri Dec 11, 2020 10:05 am
I cannot repeat this.
Thanks for looking into this.

I tried again with a different plugin and will a lesser amount of midi track. It's the same result.

Attached is a small test with mux and polysynth. When opening the project, the selected active track is the 2nd and should be on channel 2. But midi sent to this track is going to channel 1 unless you click on the track again it gets reassigned to channel 2 like it should.
You do not have the required permissions to view the files attached to this post.

User avatar
KVRAF
10976 posts since 24 Jun, 2008 from Europe

Post Sun Dec 13, 2020 2:50 pm

Thx, i can repeat it now. Will be fixed in the next update.

Return to “MUTOOLS”