New Linux builds, revision 10721

User avatar
KVRian
827 posts since 6 Jun, 2016 from San Marcos, Texas

Post Thu Jan 21, 2021 6:11 pm

stevehollx wrote:
Thu Jan 21, 2021 3:27 pm
Progress! Running Diva on a Rock Pi X with Ubuntu and Carla. Pressing a softkey on Diva shows sound output, DSP load idling at 20-30% though. After hitting some keys it spikes to 100%. No audio out the board working yet, so not sure if there is clipping or if DSP load can be tuned.

TODO:
[*] Don't have sound coming out of the audio jack yet, but can visually see it is hitting the audio out in the OS.
[*] Haven't tried USB MIDI into it yet.
[*] Need to spend some time with VNC setup.
[*] Need to work on getting Carla/Diva to auto-launch on OS boot.
Nice!
Do you have a Class Compliant USB audio interface around? You should try that see what happens. CPU usage should go down.
I see you have Carla installed, so I take it Jack is being used as well?

KVRist
130 posts since 6 Nov, 2011

Post Fri Jan 22, 2021 5:48 pm

Please note that there is a new Hive 2.1 public beta in the parent forum place..
viewtopic.php?f=31&t=559585

KVRer
3 posts since 31 Dec, 2020

Post Mon Jan 25, 2021 9:28 am

lunardigs wrote:
Thu Jan 21, 2021 6:11 pm
stevehollx wrote:
Thu Jan 21, 2021 3:27 pm
Progress! Running Diva on a Rock Pi X with Ubuntu and Carla. Pressing a softkey on Diva shows sound output, DSP load idling at 20-30% though. After hitting some keys it spikes to 100%. No audio out the board working yet, so not sure if there is clipping or if DSP load can be tuned.

TODO:
[*] Don't have sound coming out of the audio jack yet, but can visually see it is hitting the audio out in the OS.
[*] Haven't tried USB MIDI into it yet.
[*] Need to spend some time with VNC setup.
[*] Need to work on getting Carla/Diva to auto-launch on OS boot.
Nice!
Do you have a Class Compliant USB audio interface around? You should try that see what happens. CPU usage should go down.
I see you have Carla installed, so I take it Jack is being used as well?
Plugged in a Scarlett 2i2 that I have and got OS audio via ALSA. Couldn't get audio working with Carla+ALSA yet, so I switched to Reaper. Get audio coming out of Diva now.

CPU chokes in poly mode above Accuracy of 'fast' but seems to hang by in fast. With a lot of note input the display driver will stall in the OS due to CPU bog for a bit (Reaper has highest realtime CPU priority).

Been just playing with the onscreen keyboard so far. Haven't tried USB MIDI yet. That's next, to assess if I want to explore this project further.

KVRist
48 posts since 22 Apr, 2018

Post Mon Jan 25, 2021 11:34 am

stevehollx wrote:
Mon Jan 25, 2021 9:28 am
lunardigs wrote:
Thu Jan 21, 2021 6:11 pm
stevehollx wrote:
Thu Jan 21, 2021 3:27 pm
Progress! Running Diva on a Rock Pi X with Ubuntu and Carla. Pressing a softkey on Diva shows sound output, DSP load idling at 20-30% though. After hitting some keys it spikes to 100%. No audio out the board working yet, so not sure if there is clipping or if DSP load can be tuned.

TODO:
[*] Don't have sound coming out of the audio jack yet, but can visually see it is hitting the audio out in the OS.
[*] Haven't tried USB MIDI into it yet.
[*] Need to spend some time with VNC setup.
[*] Need to work on getting Carla/Diva to auto-launch on OS boot.
Nice!
Do you have a Class Compliant USB audio interface around? You should try that see what happens. CPU usage should go down.
I see you have Carla installed, so I take it Jack is being used as well?
Plugged in a Scarlett 2i2 that I have and got OS audio via ALSA. Couldn't get audio working with Carla+ALSA yet, so I switched to Reaper. Get audio coming out of Diva now.

CPU chokes in poly mode above Accuracy of 'fast' but seems to hang by in fast. With a lot of note input the display driver will stall in the OS due to CPU bog for a bit (Reaper has highest realtime CPU priority).

Been just playing with the onscreen keyboard so far. Haven't tried USB MIDI yet. That's next, to assess if I want to explore this project further.
Have you tried setting your cpu governer to performance instead of powersave?

KVRAF
2931 posts since 3 Nov, 2015

Post Fri Feb 19, 2021 7:11 am

tasmaniandevil wrote:
Wed Dec 16, 2020 2:59 am
There is no updated The Dark Zebra (ZebraHZ) yet, we first want to make sure that the current versions are stable enough. If so, we will update the ZebraHZ download package in a few weeks. You can then request it the usual way via the myLicenses form on the website.
There IS a Dark Zebra update. Just did it. Revision 10721 now. It'd be useful to state that there IS an update on the main post. Just read the first post today and thought there were no updates. Fortunately I was reminded that there was an update, so I got it.

It's of course not possible to poll periodically using 'myLicense' to know if there is or not any updates. Not knowing there was an update I would have passed on Sonic Underworld's new sound set.

Cheers.

KVRian

Topic Starter

1094 posts since 22 Mar, 2005 from Germany

Post Fri Feb 19, 2021 9:08 am

We added that ZebraHZ update very recently, and simply forgot to mention this here. Sorry.

KVRer
9 posts since 21 Oct, 2015

Post Thu Apr 22, 2021 7:26 am

THANKS!

Now I try Diva and Hive.... Repro....? Thanks for Linux version....

KVRAF
8048 posts since 6 Oct, 2004

Post Mon Apr 26, 2021 6:35 pm

tasmaniandevil wrote:
Fri Feb 19, 2021 9:08 am
We added that ZebraHZ update very recently, and simply forgot to mention this here. Sorry.
Thanks for the recent handy and informative plugin status report U 8) he

Return to “u-he Linux support”