FXpansion’s BFD Acquired by inMusic

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
KVRist
52 posts since 10 May, 2004

Post Mon May 03, 2021 3:36 am

Thanks for the help
Ill give it a shot

User avatar
KVRist
86 posts since 24 Oct, 2006

Post Mon May 03, 2021 12:31 pm

Thanks, Drew, for all the help. So far (and once I made sure no residue from FXP's BFD3 was anywhere near any data paths upon which my DAWs tread), everything seems stable both as stand-alone, and in Waveform 11.5.9, Bitwig 3.3.7, and Studio One 5.2.1. FXPansion had no idea why their License Manager offered me (and still is offering me) an "update" back to their BFD 3.3.1.33 after migration, but I seem to have managed to have that issue sequestered away from causing anymore instability, so I'm unconcerned. Panic button is weird, but that's the only thing with which I've seen a "problem" so far. So thanks for the help and your exceptional patience with me and my issues.
“In a time of deceit, telling the truth is a revolutionary act.” ∞ GEORGE ORWELL, 1984

KVRer
7 posts since 29 Apr, 2021

Post Mon May 03, 2021 8:31 pm

Out of nowhere, I've run into some kind of bug. When I try to scan my user content folder, BFD just hangs and now doesn't see my user stuff at all. I uninstalled BFD3 and installed again and initially my user content was showing and working, but the minute I try and scan it, it hangs again and will not see my user folder. On macOS High Sierra btw and haven't updated anything. This is completely strange, as it was working fine. It also froze trying to do something else too and after I re-installed, the GUI was all messed up and got the beach ball. Any ideas?

Edit: I tried another uninstall, this time deleting all preferences and a few other things that doesn't get uninstalled, reinstalled again and it seems to be ok. I can scan my user content and it doesn't freeze. That was so odd, one minute it was fine and then things got all wonky with beachballs.
Last edited by Fender_Bender on Tue May 04, 2021 7:58 am, edited 1 time in total.

KVRer
3 posts since 13 Aug, 2017

Post Mon May 03, 2021 11:57 pm

I have bfd 3
and all of the sudden(post installin v3.4) I can't seem to find my bfd2,evil drums EJB 1,neil peart(rip),custom maple and signature snares presets(nor kits)-can I revert to my previous version?

KVRer
3 posts since 13 Aug, 2017

Post Mon May 03, 2021 11:57 pm

??

KVRAF
7154 posts since 7 Mar, 2003

Post Tue May 04, 2021 12:20 am

Amorphosynthesis wrote:
Mon May 03, 2021 11:57 pm
I have bfd 3
and all of the sudden(post installin v3.4) I can't seem to find my bfd2,evil drums EJB 1,neil peart(rip),custom maple and signature snares presets(nor kits)-can I revert to my previous version?
You shouldn't need to. They'll still be on your system somewhere. Check these locations:

OSX - /Library/Application\ Support/FXpansion/BFD2/System/Presets/
Win - C:\ProgramData\FXpansion\BFD2\System\Presets

Copy the files inside there to wherever you want to keep them, and then add that path your contents location panel.
My Youtube Channel - Wires Dream Disasters :: My Band - Tacoma Narrows Bridge Disaster
Disclosure: I'm an audio engineer, product owner, and content developer working for inMusic Brands

User avatar
KVRAF
4229 posts since 8 Jul, 2009

Post Tue May 04, 2021 6:58 pm

Fender_Bender wrote:
Mon May 03, 2021 8:31 pm
Out of nowhere, I've run into some kind of bug. When I try to scan my user content folder, BFD just hangs and now doesn't see my user stuff at all. I uninstalled BFD3 and installed again and initially my user content was showing and working, but the minute I try and scan it, it hangs again and will not see my user folder. On macOS High Sierra btw and haven't updated anything. This is completely strange, as it was working fine. It also froze trying to do something else too and after I re-installed, the GUI was all messed up and got the beach ball. Any ideas?

Edit: I tried another uninstall, this time deleting all preferences and a few other things that doesn't get uninstalled, reinstalled again and it seems to be ok. I can scan my user content and it doesn't freeze. That was so odd, one minute it was fine and then things got all wonky with beachballs.
I reported this via PM, on my system I can't reliably scan grooves. During the scan, it will hang when it hits grooves. But not specific grooves - its sporadic. I manually removed all grooves from my media path and bfd3 completed the scan. When it would hang I would need to force quit. I haven't heard an update from inMusic about this issue.

KVRAF
7154 posts since 7 Mar, 2003

Post Wed May 05, 2021 2:52 am

Hey all, just a heads up that I'll be off work from tomorrow until next Monday, so I most likely won't get to any serial requests for those 4 days. If in dire need, please email support@bfddrums.com

Cheers!
My Youtube Channel - Wires Dream Disasters :: My Band - Tacoma Narrows Bridge Disaster
Disclosure: I'm an audio engineer, product owner, and content developer working for inMusic Brands

KVRian
787 posts since 8 Jan, 2012 from frankfurt, Germany

Post Wed May 05, 2021 12:15 pm

first start is very slow, can you deactivate scanning the whole library on startup, there should be no need to scan on every starttup again

KVRAF
8347 posts since 16 Aug, 2006

Post Wed May 05, 2021 12:23 pm

sacer wrote:
Wed May 05, 2021 12:15 pm
first start is very slow, can you deactivate scanning the whole library on startup, there should be no need to scan on every starttup again
It shouldn't be doing that. It should only scan the content the first first time, subsequent runs should startup quickly.

Return to “Instruments”