Relab LX480L essential - my latest reverb addiction

VST, AU, etc. plug-in Virtual Effects discussion
KVRAF
2381 posts since 1 Sep, 2016

Post Fri Jul 30, 2021 10:58 am

Installed the demo but it crashes FL Studio every time.

KVRAF
5238 posts since 28 Dec, 2015 from Hanover, Germany

Post Fri Jul 30, 2021 11:18 am

Have you tried Reaper?

KVRAF
29237 posts since 11 Apr, 2010 from Germany

Post Mon Aug 02, 2021 10:25 am

Just played a bit with Largo and LX480. Absolutely ace this thing. Best $35 I spent in a long time on audio software. Actually, probably the best $35 I ever spent. :) Sounds absolutely spot on. Everyone who praised it here was 100% right.
Plugins and a DAW. On an operating system. Which runs on a computer.

User avatar
KVRAF
1886 posts since 6 Jul, 2013

Post Mon Aug 02, 2021 11:32 am

chk071 wrote:
Mon Aug 02, 2021 10:25 am
Just played a bit with Largo and LX480. Absolutely ace this thing. Best $35 I spent in a long time on audio software. Actually, probably the best $35 I ever spent. :) Sounds absolutely spot on.
Yep.
chk071 wrote:
Mon Aug 02, 2021 10:25 am
Everyone who praised it here was 100% right.
Yeah, this happens to me a lot... ;)

Glad you're digging it.

KVRAF
5238 posts since 28 Dec, 2015 from Hanover, Germany

Post Mon Aug 02, 2021 11:37 am

chk071 wrote:
Mon Aug 02, 2021 10:25 am
Just played a bit with Largo and LX480. Absolutely ace this thing.
Da wächst zusammen, was zusammen gehört.
(Frei nach Willy Brandt)

KVRAF
29237 posts since 11 Apr, 2010 from Germany

Post Mon Aug 02, 2021 11:38 am

:tu:
Plugins and a DAW. On an operating system. Which runs on a computer.

KVRian
1213 posts since 26 Feb, 2016

Post Mon Aug 02, 2021 10:55 pm

Relab has several good sounding verbs.

KVRAF
4186 posts since 17 Aug, 2004

Post Mon Aug 02, 2021 11:30 pm

Vortifex wrote:
Fri Jul 30, 2021 10:58 am
Installed the demo but it crashes FL Studio every time.
It works perfectly fine here. I had to enable "fixed size buffer" tweak though - to avoid weird sound. But no crashing whatsoever.

A possible tip: was it activated properly on your ilok usb key?

KVRAF
2381 posts since 1 Sep, 2016

Post Tue Aug 03, 2021 1:54 am

I use soft iLok. Fixed sized buffers didn't help. Loading the plugin would crash the DAW 100% of the time. Sometimes instantly, sometimes not before outputting +30dB noise redlining the meters. I already emailed the devs about it but my ridiculously short demo period is over already so I won't be able to test it further.

KVRist
387 posts since 8 Jan, 2012

Post Tue Aug 03, 2021 1:26 pm

Crashed on two Windows 10 Pro machines I have running latest Studio One Prof.Very disappointing.

KVRAF
2277 posts since 30 Aug, 2012 from Sweden

Post Tue Aug 03, 2021 2:05 pm

AKJ wrote:
Fri Jun 25, 2021 8:14 am
I only demoed the full version. I cannot say how it compares to a hardware but I did not sound good at all to me. In fact, one of the worst reverbs I tried. But maybe I am just not too much into 80s vintage reverb sound.
:lol: :lol: :lol: :dog:

KVRer
2 posts since 24 Jan, 2020

Post Wed Aug 04, 2021 3:19 am

Vortifex wrote:
Tue Aug 03, 2021 1:54 am
I use soft iLok. Fixed sized buffers didn't help. Loading the plugin would crash the DAW 100% of the time. Sometimes instantly, sometimes not before outputting +30dB noise redlining the meters. I already emailed the devs about it but my ridiculously short demo period is over already so I won't be able to test it further.
Sorry you had trouble - Let support know your trial ended, we'll get you a trial extension and get you up and running no problem.
Last edited by Relab on Wed Aug 04, 2021 3:22 am, edited 1 time in total.

KVRer
2 posts since 24 Jan, 2020

Post Wed Aug 04, 2021 3:21 am

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.
LAGinz wrote:
Tue Aug 03, 2021 1:26 pm
Crashed on two Windows 10 Pro machines I have running latest Studio One Prof.Very disappointing.
Sorry that happened to you - if you submit a ticket, we'll get you up and running. Sounds like something specific as it had been pretty solid overall on Studio One

https://help.relabdevelopment.com/submit-a-ticket/ (https://help.relabdevelopment.com/submit-a-ticket/)

KVRist
387 posts since 8 Jan, 2012

Post Wed Aug 04, 2021 11:08 am

Already opened a ticket. Support was unhelpful. But Relab gave me a refund, which I appreciate.

KVRAF
29237 posts since 11 Apr, 2010 from Germany

Post Wed Aug 04, 2021 11:40 am

Relab wrote:
Wed Aug 04, 2021 3:21 am
Sounds like something specific as it had been pretty solid overall on Studio One
No issues here on Windows 10 and Studio One 4 Pro, FWIW.
Plugins and a DAW. On an operating system. Which runs on a computer.

Return to “Effects”