Xhun Audio LittleOne : version 4.x Released

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
KVRian

Topic Starter

866 posts since 17 Feb, 2010

Post Sun Sep 05, 2021 4:40 am

Hi, as described here :

https://www.xhun-audio.com/site/xhun.php?page=support

On most recent versions of macOS, there's a thing happening :

instead of the proper "~/Library/" path, the system wants certain plugins installed under the "/Library/" in order to be visible to a Host.

Try "Library/Audio/Plug-Ins/Components/" instead of "~/Library/Audio/Plug-Ins/Components/".
bruno @ Xhun Audio || www.xhun-audio.com || Twitter || Facebook || Instagram
Image

User avatar
KVRian

Topic Starter

866 posts since 17 Feb, 2010

Post Tue Sep 07, 2021 4:39 am

LittleOne version 4.x preview image : the new synthesizer panel GUI.

Image
bruno @ Xhun Audio || www.xhun-audio.com || Twitter || Facebook || Instagram
Image

User avatar
KVRAF
34940 posts since 11 Aug, 2008 from another dimension

Post Tue Sep 07, 2021 4:47 am

Very blurred. Tiny text, buttons, dials. Difficult to read.
Hi-de-Hi!

User avatar
KVRian

Topic Starter

866 posts since 17 Feb, 2010

Post Tue Sep 07, 2021 6:17 am

Just before being published, the image above has been pre-processed adding light glow shading and desaturation.

...because it's a "sneak-preview" :)
bruno @ Xhun Audio || www.xhun-audio.com || Twitter || Facebook || Instagram
Image

KVRist
43 posts since 25 Jun, 2021

Post Tue Sep 07, 2021 9:37 am

xhunaudio wrote:
Tue Sep 07, 2021 4:39 am
LittleOne version 4.x preview image : the new synthesizer panel GUI.

Image
It looks great! I can't wait :phones:

KVRist
434 posts since 10 Jan, 2008

Post Wed Sep 08, 2021 7:26 am

Looks great so far.
Will a parameter change by any GUI element be reflected in the display, at least for a while?

Release Party is excatly when? ;)

User avatar
KVRian

Topic Starter

866 posts since 17 Feb, 2010

Post Wed Sep 08, 2021 11:00 am

Knobs are fully analogue, so you'll have to turn them up and turn them down until you'll get THE sound :)

Release party? Very soon. There *could* be a potential delay of 1 or 2 weeks so I'd prefer not to mention the exact day for now, until I'm sure any delay is avoided.
bruno @ Xhun Audio || www.xhun-audio.com || Twitter || Facebook || Instagram
Image

KVRAF
3468 posts since 20 Feb, 2004

Post Wed Sep 08, 2021 1:10 pm

Looking forward to more technical information. Any updates to the sound engine or features/functionality? (Not saying that this was needed, it already sounds really good.)
A well-behaved signature.

KVRian
850 posts since 8 Jan, 2012 from frankfurt, Germany

Post Wed Sep 08, 2021 10:15 pm

xhunaudio wrote:
Thu Sep 02, 2021 6:32 am
Yes it is natively backward compatible.

Anyway, for a possible missing compatibility scenario (the worst case, it should never happen), it is sufficient to :

- load your old project using LittleOne version 3.x
- for each instance of LittleOne version 3.x, manually save each of the "states" of the plugin (= simply press the SAVE preset button)
- close the Host, remove LittleOne version 3.x and install LittleOne version 4.x
- reload your project (now using LittleOne version 4.x) and if necessary, for each instance, load the corresponding presets you saved before

This will force into a 100% compatibility, if that is not achieved automatically.
hope you can bring V4 to work that it still open the used preset from V3 in a project. I have used littleOne in so many projects :)

KVRist
43 posts since 25 Jun, 2021

Post Thu Sep 09, 2021 1:57 am

sacer wrote:
Wed Sep 08, 2021 10:15 pm
hope you can bring V4 to work that it still open the used preset from V3 in a project. I have used littleOne in so many projects :)
I think in your case you’d just have both v3 and v4 installed. If you then want to swap over to v4 for some cases, you can then follow the steps. No point in running stuff in v4 for the sake of it.

User avatar
KVRian

Topic Starter

866 posts since 17 Feb, 2010

Post Thu Sep 09, 2021 11:17 am

JerGoertz wrote:
Wed Sep 08, 2021 1:10 pm
Looking forward to more technical information. Any updates to the sound engine or features/functionality? (Not saying that this was needed, it already sounds really good.)
Hi Jeremiah,

yes LittleOne version 4.x brings improvements in 3 main areas.

1-
On the GUI side, there's the new synth panel mentioned above. Also, there's a minor GUI overhaul for the rack too.

2-
On the DSP side there's an important accuracy improvement.

3-
And there's also a new rack unit, affecting the sequencer and trancegate effect.

I'll talk about the last two in the next few days.
bruno @ Xhun Audio || www.xhun-audio.com || Twitter || Facebook || Instagram
Image

User avatar
KVRAF
2675 posts since 31 Dec, 2004 from People's Republic of Minnesota

Post Thu Sep 09, 2021 7:28 pm

xhunaudio wrote:
Sun Sep 05, 2021 4:40 am
Hi, as described here :

https://www.xhun-audio.com/site/xhun.php?page=support

On most recent versions of macOS, there's a thing happening :

instead of the proper "~/Library/" path, the system wants certain plugins installed under the "/Library/" in order to be visible to a Host.

Try "Library/Audio/Plug-Ins/Components/" instead of "~/Library/Audio/Plug-Ins/Components/".
Hi there. I did that, rescanned all of my AUs, and restarted and they're still not showing under any of my AU hosts (Logic, MainStage, HostingAU).

User avatar
KVRian

Topic Starter

866 posts since 17 Feb, 2010

Post Fri Sep 10, 2021 1:16 am

PS : There's also the Gatekeeper thing...

At today, many users are running LittleOne (and any other XA software) on latest macOS with M1 and Rosetta 2.

LittleOne didn't break compatibility with macOS. It is fully compatible with the plugin model Apple adopted for 2 decades.

From a general viewpoint, from a couple of years Apple (legitimately) decided to break compatibility with existing macOS softwares, introducing new and new incompatibilities and obtrusive requirements on a daily basis.

Apple is fully legitimate in doing what it does, my duty is not to blindly adhere. In addition, my opinion is that an OS should have to be JUST solid and transparent, period - not a way to change the rules every 12 hours. And sadly, this rarely happens today.

LittleOne and any other XA software come "as is". As a small developer and as always happened in the past, I'm happy to continue to give my support and help to customers for what is in my human possibilities, but I can't accomplish the *impossible* task of upgrading my IDE once a week.

My suggestion is to always try the demo before purchase. If the demo works fine, the full version will work fine too, 100% guarranteed.

Said that, we are about to enter a very exciting period for computer science, and in the medium-run the "pre-compiled audio plugin" concept could be replaced with something different. And AU/VST2/VST3/... differences could just belong to the past.

Let's see!
bruno @ Xhun Audio || www.xhun-audio.com || Twitter || Facebook || Instagram
Image

User avatar
KVRAF
2675 posts since 31 Dec, 2004 from People's Republic of Minnesota

Post Fri Sep 10, 2021 6:18 am

xhunaudio wrote:
Fri Sep 10, 2021 1:16 am
PS : There's also the Gatekeeper thing...

At today, many users are running LittleOne (and any other XA software) on latest macOS with M1 and Rosetta 2.

LittleOne didn't break compatibility with macOS. It is fully compatible with the plugin model Apple adopted for 2 decades.

From a general viewpoint, from a couple of years Apple (legitimately) decided to break compatibility with existing macOS softwares, introducing new and new incompatibilities and obtrusive requirements on a daily basis.

Apple is fully legitimate in doing what it does, my duty is not to blindly adhere. In addition, my opinion is that an OS should have to be JUST solid and transparent, period - not a way to change the rules every 12 hours. And sadly, this rarely happens today.

LittleOne and any other XA software come "as is". As a small developer and as always happened in the past, I'm happy to continue to give my support and help to customers for what is in my human possibilities, but I can't accomplish the *impossible* task of upgrading my IDE once a week.

My suggestion is to always try the demo before purchase. If the demo works fine, the full version will work fine too, 100% guarranteed.

Said that, we are about to enter a very exciting period for computer science, and in the medium-run the "pre-compiled audio plugin" concept could be replaced with something different. And AU/VST2/VST3/... differences could just belong to the past.

Let's see!
That’s all fine. When I demoed it on my Intel Mac it worked fine. Now as I’m on M1/Rosetta it’s not working, and I can’t resell my licenses. So at this point I’m stuck with a license I can’t use. Awesome.

KVRist
64 posts since 1 Feb, 2015

Post Fri Sep 10, 2021 8:36 am

Works fine on my M1...
Ableton Live 11, NI KK S61 mk2, Deepmind 12D, Hydrasynth, Bass Station2, Modal Cobalt8M, Microfreak, korg NTS-1, Eventide H9 Max

Return to “Instruments”