Kawai K1 as VSTi - Nils' K1v is here

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
KVRist

Topic Starter

275 posts since 22 Oct, 2004 from Neuss, Germany

Post Wed Jul 21, 2021 9:04 am

kneelherring wrote:
Tue Jul 20, 2021 8:05 am
dependency walker states the following required dll files are not present.

DWMAPI.DLL
D2D1.DLL
DWRITE.DLL

seems they are all related to graphical elements?
would you consider a gui-less build (even as a one off), permitting use on xp with an external midi editor? (simple fix?)

cheers
Yes that is correct, the only reason why I am unable to support Windows XP is the GUI. I use VSTGUI and they dropped support for XP, or, GDI (non-plus) to be precise, quite a while ago.

This is also the case for the Juce framework, so anyone that wants to support XP can't use either of the two main frameworks for GUI.

I never thought that a headless version might be useful, doing that is pretty much straightforward as I already have a headless build locally to test on environments that do not necessarily have any desktop, such as Raspberry Pi, Servers & such.
bwwd wrote:
Wed Jul 21, 2021 6:40 am
IMO dev should separate the sourcecode and open it up for samples then charge $$$ for it.
I am unable to charge any money for it as I have permission by Kawai to distribute these plugins under the condition that they are free.

I've got plenty of reports that the VST3 is making problems, I'm gonna look into that. At the same time, some people do not seem have problems, Cubase owners of example. This is a bit weird.
https://k1v.nilsschneider.de - Kawai K1 emulated as VSTi/AU
https://heatvst.com - Android Synthesizer with full VST integration
https://gpuimpulsereverb.de - Use your GPU as reverberation DSP

KVRist
489 posts since 27 Feb, 2007

Post Wed Jul 21, 2021 10:49 am

Change the skin, change rom samples - you have your own synth.Only rom samples were from original synth, the rest was done by You, your code, you can do derivatives of it with your own added
features.
+ Slap unison on it , maybe filter , sample some synths, id definitely take advantage of this engine.

----
Oh man... i spent like 2 evenings, about 10 hours total to make my presets in KV1, saved them using bank export to syx... i load it up today and its all gone, it saved just first preset :cry:
This is quite horrible, how could this happen? This part of this synth definitely needs some work, and some different format to export all settings you make to banks and individual sounds as one package.
It just reset all my custom patches to default ones... very uncool.I lost everything.
Theres just no way that it exports any bank at all, just look at the size of the syx file, just one kilobyte.IT only exported singles bank, multis werent exported and arent exported at all... i wish i knew that.Or export should be grayed out when youre on multi panel.
I also still dont know if bank export of multis would contain singles as well, because i did edit the singles to create new multis sounds.So IMO it should export both anyway.There shouldnt be option to export just singles or just banks, maybe to import singles only or banks only, but never to export just one of these adn they depend on each other heavily currently.
But its a life lesson i guess, never trust any save feature and check the file in txt editor at least to see the content and filesize.

User avatar
KVRAF
7702 posts since 11 Jun, 2006

Post Wed Jul 21, 2021 2:23 pm

kneelherring wrote:
Tue Jul 20, 2021 8:05 am
layzer wrote:
Fri Jul 03, 2020 6:01 pm
Nils Schneider wrote:
Fri Jul 03, 2020 1:57 am
layzer wrote:
Thu Jul 02, 2020 11:30 pm
crashes with dll errors.
Could you copy the error message? I didn't test on XP but I didn't implement anything Vista+ specific so it should work, in theory at least :) I'm going to try it in a virtual machine.
hi and thanks for your support of us rare vintage OS affectionados. :D

well, the error says it cant find dwmapi.dll am i missing some kind of runtime?
im using winxp sp3 x32.
dependency walker states the following required dll files are not present.

DWMAPI.DLL
D2D1.DLL
DWRITE.DLL

seems they are all related to graphical elements?
would you consider a gui-less build (even as a one off), permitting use on xp with an external midi editor? (simple fix?)

cheers
nahhh, i got M1, ravity and purity that satisfy my rompler needs
in winxp with no hassles.
HW SYNTHS [KORG T2EX - AKAI AX80 - YAMAHA SY77 - ENSONIQ VFX]
HW MODULES [OBi M1000 - ROLAND MKS-50 - ROLAND JV880 - KURZ 1000PX]
SW [CHARLATAN - OBXD - OXE - ELEKTRO - MICROTERA - M1 - SURGE - RMiV]
DAW [ENERGY XT2/1U RACK WINXP / MAUDIO 1010LT PCI]

KVRer
7 posts since 13 May, 2006

Post Wed Jul 21, 2021 5:07 pm

Nils Schneider wrote:
Wed Jul 21, 2021 9:04 am

I never thought that a headless version might be useful, doing that is pretty much straightforward as I already have a headless build locally to test on environments that do not necessarily have any desktop, such as Raspberry Pi, Servers & such.

i would find that useful. i was actually planning on dedicating a separate laptop to k1v in order to use it in an xp based studio, controlled via an editor from xp, but a headless version would be much more versatile and simple.

KVRist
489 posts since 27 Feb, 2007

Post Sun Oct 17, 2021 11:16 am

Hey Nils do You plan to update the plugins way of saving multis and singles ? Can you make the multis always save singles its using as well ? I lost a lot of sounds with that weird way of saving stuff.
You can always ask if singles should be imported with multis or something but on the other hand do you know even one single situation when you would you not want to also import singles that are actually required to create multis you want to use ? Without singles - multis are useless because multis require particular singles.
Or am i just dumb as hell, sometimes icheck and singles are there and sometimes they arent cause names are different, i think singles are not updated right away on importing multis till i click on something but i have no idea what i have to do.
OK im not stupid, multis just dont save their own singles... what the hell ? Why would you want that behaviour ? Also why would y ou want only singles imported without multis ? the only case is when you start building multis from 0 and thats very rare, it should not be default behaviour.
Multis an singles in this synth are very codependent, they should not be imported separately unless you specifically want that ocassionally for some weird reason.
Id change that so each bank import will import multis and singles that are beign used by multis.
I also have a gripe with situation when i create my multis from the singles in bank, and i want to replace one single to use it in multi, so i go to sinles, import single, then i go back to multi and its still using old single ! What the hell ? THis should never ever work like this.
Now i have to export singles, then export multis and pray i get them back on importing next day.
I also find clicking by accident on K1V annoying as hell cause it wants to take you to website, cant you just have some button for it on area where you dont accidentally click it ?

User avatar
KVRAF
6368 posts since 6 Jan, 2017 from Outer Space

Post Tue Oct 19, 2021 10:29 pm

Its an emulator, it works like the original (I guess…)
Only touching the logo did not send you to the www, but only because it didn‘t exist back then. It might have made the phone ring though…; - )

KVRist
489 posts since 27 Feb, 2007

Post Wed Oct 20, 2021 1:36 am

yup, prety funny to lose 2 days worth of making own patches cause of very confusing saving methods. :party: Great feeling.

KVRist
47 posts since 8 Sep, 2015

Post Tue Nov 02, 2021 12:19 am

accidentally found this plugin yesterday and loved it.
thank you for native Linux version.

KVRer
2 posts since 3 Mar, 2021

Post Fri Nov 12, 2021 5:16 pm

My DAW (Tracktion Waveform 11 Free) isn't reloading the bank, page, and patch selection when closing and reopening a track. I also noticed that program change messages (or whatever they're called, I'm no midi/sysex expert) aren't being sent to the DAW, which means the little program indicator in Waveform doesn't change when I change patches in the K1v. However, it does work the other way around-- I can select patches via the program indicator in Waveform and it does select them in the K1v. This still doesn't save though.

User avatar
KVRer
6 posts since 13 Nov, 2021 from Canada

Post Fri Nov 12, 2021 5:47 pm

K1v is amazing and I love it. However, it's a bit buggy, but for free it's hard to complain.

KVRist

Topic Starter

275 posts since 22 Oct, 2004 from Neuss, Germany

Post Sat Nov 13, 2021 4:19 pm

pl4sma2389 wrote:
Fri Nov 12, 2021 5:16 pm
My DAW (Tracktion Waveform 11 Free) isn't reloading the bank, page
What plugin format do you use, VST3 x64 by any chance?

I already fixed this locally, will be part of the next release.
https://k1v.nilsschneider.de - Kawai K1 emulated as VSTi/AU
https://heatvst.com - Android Synthesizer with full VST integration
https://gpuimpulsereverb.de - Use your GPU as reverberation DSP

KVRer
1 posts since 15 Nov, 2021

Post Mon Nov 15, 2021 12:20 pm

Hi,
new here. As K1 owner I was thrilled to see VST version of it. The first blow was Win XP ;) I put K1v on side and waited for better times. Now, I came across Win 10 laptop and installed Cubase Elements 11 (trial). Happy to finally see and hear K1V v1.24 plugin as there came another blow. GUI is just a white rectangle with just standard patch names, arrows, R, W buttons. I can change and hear presets, but thats all. I've tried both VST3 and VST2 options with the same result. It must be something missing in my system, as nobody reported such kind of error.

Image

Other plugins, such as PG-8x, FB-7999, Cyclone works normally
Windows 10 Pro, Cubase Elements 11(trial), 64-bit. K1V v 1.24

regards,
Yuri

KVRer
2 posts since 3 Mar, 2021

Post Mon Nov 15, 2021 7:17 pm

Nils Schneider wrote:
Sat Nov 13, 2021 4:19 pm
pl4sma2389 wrote:
Fri Nov 12, 2021 5:16 pm
My DAW (Tracktion Waveform 11 Free) isn't reloading the bank, page
What plugin format do you use, VST3 x64 by any chance?

I already fixed this locally, will be part of the next release.
Yep, VST3. Thanks!

KVRian
588 posts since 4 Jan, 2007

Post Tue Nov 23, 2021 12:37 pm

The VST3 isn't saving the actual program in the project on Reaper Win10. It doesn't neither allow changing program through Reaper's preset selection. I guess it is the same issue.

Return to “Instruments”