DrivenByMoss - Bitwig extension for lots of controller devices (and more)

User avatar
KVRAF

Topic Starter

2973 posts since 13 May, 2004

Post Tue Oct 26, 2021 4:34 am

twolegstoneworks wrote:
Mon Oct 18, 2021 11:10 am
So now I've tried to uninstall the DrivenByMoss extention, but all my colours are still f**ked up on my Push... how to fix this really annoying issue? What file does this extention alter in the Push setup?
The colors are set on startup. To reset them you need to switch off the Push and turn it on again.
I did not get any reports so far that the colors are not set correctly. What Firmware is installed on your Push?

User avatar
KVRAF

Topic Starter

2973 posts since 13 May, 2004

Post Tue Oct 26, 2021 4:35 am

cremoer wrote:
Mon Oct 18, 2021 6:43 am
Hi, Jürgen.
Not quite sure, but the "Stop" button on my Maschine Mk3 does not work anymore. (It works with the original controller settings from Bitwig, so it's obviously no hardware issue). Could this be due to the latest MacOS Update perhaps? Any other idea?
Maybe you somehow accidently changed the settings of the Stop button in the editor?! Try to re-import the DrivenByMoss template.

User avatar
KVRAF

Topic Starter

2973 posts since 13 May, 2004

Post Tue Oct 26, 2021 9:41 am

cremoer wrote:
Mon Oct 18, 2021 3:46 pm
cremoer wrote:
Mon Oct 18, 2021 6:43 am
Hi, Jürgen.
Not quite sure, but the "Stop" button on my Maschine Mk3 does not work anymore. (It works with the original controller settings from Bitwig, so it's obviously no hardware issue). Could this be due to the latest MacOS Update perhaps? Any other idea?
Just to take the confusion a little step further (at least for me): In a new project in Bitwig the "Stop" button works. When I switch back and forth between the projects, in the one project (the new one) the "Stop" button on the Maschine works, in the other one it doesn't.
I tested with Macos 11.6.0 and now 11.6.1 but cannot reproduce your issue. Are you already on Monterey?

User avatar
KVRian
1410 posts since 12 Jun, 2003 from Denmark

Post Wed Oct 27, 2021 2:36 am

moss wrote:
Tue Oct 26, 2021 4:34 am
twolegstoneworks wrote:
Mon Oct 18, 2021 11:10 am
So now I've tried to uninstall the DrivenByMoss extention, but all my colours are still f**ked up on my Push... how to fix this really annoying issue? What file does this extention alter in the Push setup?
The colors are set on startup. To reset them you need to switch off the Push and turn it on again.
I did not get any reports so far that the colors are not set correctly. What Firmware is installed on your Push?
Well, I had the whole setup switched off and then back on, including the Push2 and that didn't change anything, and in fact it affected the Push2 pad-colours when I was using Ableton Live 11 as well. I'm not sure what version the Push2 firmware is on, but it's the latest version.
Anyway, if this is the first report on crazy pad-colours then so be it. I've uninstalled the script for now and I'll probably just live without the Push when using Bitwig.
music // twolegs // geometriae
sounddesign // twolegstoneworks

KVRer
4 posts since 26 Aug, 2017

Post Wed Oct 27, 2021 2:50 pm

Is it possible to get more slots or is 200 a magic number? I have a need for 276.........

User avatar
KVRAF

Topic Starter

2973 posts since 13 May, 2004

Post Thu Oct 28, 2021 12:01 am

manymanyhaha wrote:
Wed Oct 27, 2021 2:50 pm
Is it possible to get more slots or is 200 a magic number? I have a need for 276.........
Really? What are you doing? :o

It is not a natural limit. Will check if there are any negative effects if I increase it.

KVRer
4 posts since 26 Aug, 2017

Post Thu Oct 28, 2021 4:42 am

I have two controllers (Yaeltex) going through a Midihub and have 276 things I can map and am going to utilize all of them, either in Live or Bitwig (gave up on Reaper for now). Currently having a lot of problems getting these controllers up and running in Bitwig but this is the first hindrance. That would be great if it is possible to have enough slots, appreciate you looking at that.

I have two more questions:

1) With Generic Flexi, is there supposed to be feedback? I get feedback with these controllers in Live and Reaper (via ReaLearn) but spent all evening last night trying to get feedback with either your extension (thank you by the way for the extension, it's awesome) or with the TomsMultiBiController script I found. Had no success. I'm sure it is is something I am doing or not doing :)

2) This is related: If I want to map the mute button on Track 87 (or any number beyond 8 ), how does that work? I can map it by using the "hand" in the right hand corner, but there is no feedback. If I go through the DrivenByMoss interface, there is only the option of Track 1-8. Or am I not understanding something? (Probably so :), haha).

And thank you!

User avatar
KVRAF

Topic Starter

2973 posts since 13 May, 2004

Post Thu Oct 28, 2021 10:52 am

manymanyhaha wrote:
Thu Oct 28, 2021 4:42 am
1) With Generic Flexi, is there supposed to be feedback? I get feedback with these controllers in Live and Reaper (via ReaLearn) but spent all evening last night trying to get feedback with either your extension (thank you by the way for the extension, it's awesome) or with the TomsMultiBiController script I found. Had no success. I'm sure it is is something I am doing or not doing :)
Yes, but only if the light is controlled by the exact same command as the button sends.
manymanyhaha wrote:
Thu Oct 28, 2021 4:42 am
2) This is related: If I want to map the mute button on Track 87 (or any number beyond 8 ), how does that work? I can map it by using the "hand" in the right hand corner, but there is no feedback. If I go through the DrivenByMoss interface, there is only the option of Track 1-8. Or am I not understanding something? (Probably so :), haha).
All things are paged by 8 and there are functions to navigate these pages (select next / previous bank page). I cannot make this configurable since you would then also need a flexible number of the commands, which is not possible.

KVRer
11 posts since 19 Sep, 2017

Post Thu Oct 28, 2021 11:25 am

Hi!
A big issue with Bitwig on Linux is that there are no Jack or Alsa Midi Clients, so impossible to connect to other softs...
I'd like to use OSC, but how do I set the virtual midi port, as said in the doc?

User avatar
KVRAF

Topic Starter

2973 posts since 13 May, 2004

Post Thu Oct 28, 2021 11:31 am

blindekinder wrote:
Thu Oct 28, 2021 11:25 am
Hi!
A big issue with Bitwig on Linux is that there are no Jack or Alsa Midi Clients, so impossible to connect to other softs...
I'd like to use OSC, but how do I set the virtual midi port, as said in the doc?
Choose any MIDI input you do not need (I know it is stupid but the only way to get MIDI into Bitwig).

KVRer
4 posts since 26 Aug, 2017

Post Thu Oct 28, 2021 12:01 pm

moss wrote:
Thu Oct 28, 2021 10:52 am
Yes, but only if the light is controlled by the exact same command as the button sends.
Just want to make sure I understand correctly: If I send CC 10 on channel 6 from the button, so long as the feedback LED is set exactly the same, it should work, correct?
moss wrote:
Thu Oct 28, 2021 10:52 am
All things are paged by 8 and there are functions to navigate these pages (select next / previous bank page). I cannot make this configurable since you would then also need a flexible number of the commands, which is not possible.
I think I understand. So in the aforementioned example, if I were to map the mute for track 87, I'd navigate to bank 11 and there assign the mute to track 7. If I am understanding correctly. Or am I not?

Thanks again.....

KVRer
11 posts since 19 Sep, 2017

Post Thu Oct 28, 2021 12:45 pm

moss wrote:
Thu Oct 28, 2021 11:31 am
blindekinder wrote:
Thu Oct 28, 2021 11:25 am
Hi!
A big issue with Bitwig on Linux is that there are no Jack or Alsa Midi Clients, so impossible to connect to other softs...
I'd like to use OSC, but how do I set the virtual midi port, as said in the doc?
Choose any MIDI input you do not need (I know it is stupid but the only way to get MIDI into Bitwig).
That is the point: I have no MIDI client within Bitwig as long as I don't connect any device. And on this project I have no device handy...

User avatar
KVRAF

Topic Starter

2973 posts since 13 May, 2004

Post Thu Oct 28, 2021 1:28 pm

blindekinder wrote:
Thu Oct 28, 2021 12:45 pm
moss wrote:
Thu Oct 28, 2021 11:31 am
blindekinder wrote:
Thu Oct 28, 2021 11:25 am
Hi!
A big issue with Bitwig on Linux is that there are no Jack or Alsa Midi Clients, so impossible to connect to other softs...
I'd like to use OSC, but how do I set the virtual midi port, as said in the doc?
Choose any MIDI input you do not need (I know it is stupid but the only way to get MIDI into Bitwig).
That is the point: I have no MIDI client within Bitwig as long as I don't connect any device. And on this project I have no device handy...
Did a quick search, e.g. here is a little tutorial how to get virtual ports: https://github.com/anton-k/linux-audio- ... al-midi.md

KVRist
78 posts since 31 Dec, 2005

Post Fri Oct 29, 2021 3:33 am

I have a question about the generic controller script.

If I have 2 controllers, one officially supported where I can navigate the "session box" with up-down-left-right buttons, to basically steer what tracks and clips are in focus by 8x8, and another controller with the generic script - is it possible to have the generic controller script to chain on to whatever the "session box" is set at by the official controller?

I hope you understand. For instance, by the generic script controlling pan, send or volume on whatever tracks is in the "focus" from the other controller.

User avatar
KVRAF

Topic Starter

2973 posts since 13 May, 2004

Post Fri Oct 29, 2021 4:34 am

Mantras wrote:
Fri Oct 29, 2021 3:33 am
I have a question about the generic controller script.

If I have 2 controllers, one officially supported where I can navigate the "session box" with up-down-left-right buttons, to basically steer what tracks and clips are in focus by 8x8, and another controller with the generic script - is it possible to have the generic controller script to chain on to whatever the "session box" is set at by the official controller?

I hope you understand. For instance, by the generic script controlling pan, send or volume on whatever tracks is in the "focus" from the other controller.
You cannot combine them to create a larger grid if that is what you asking. But sure you can use both to e.g. edit on one the plugin, control volumes on a second and play on a third.

Return to “Controller Scripting”