Vengeance Producer Suite - AVENGER - 1.8.0 CM free update released

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
DigiPRO
KVRist
133 posts since 7 Mar, 2007

Post Sun Dec 05, 2021 9:43 pm

invisiblesun wrote:
Mon Sep 13, 2021 1:15 pm
DigiPRO wrote:
Thu Sep 09, 2021 10:15 pm
I have some weird VST3 version issues.

If using a pitch bender in a VPS Avenger VST3 preset, the next loaded preset loads out of tune, so I need to reset it by moving the pitch bender again.

That only happens with VPS Avenger VST3.

I had an email conversation with their support, but without any solution to my problem.

I want to ask if this is a common/documented bug, or am I alone with this bug?

Using the VSP Avenger 1.7 and Cubase Pro 10.5 with a lot of RAM on PC.

I have no probe using the VSP Avenger VST2, but from the computer resource standing point, the VST3 version should be much more CPU-friendly.

I hope someone can shed some light on this one.
Is it this?
https://www.youtube.com/watch?v=q4YbSa6V4E4

If so, I have the same issue. Made a forum post about it a while ago and promised to report back after troubleshooting. Well it happens with any keyboard/ controller and it only happens with Avenger. So I am pretty sure it's an Avenger issue. Now that we are two that have this, maybe the devs will look into it.

Cheers MW
Yes, exactly that's the error. I gave up using the VST3 version of Avenger because of this. Maybe They've fixed this in 1.8.0 but I can't confirm that because of 1.8.0. the installer seems to install the 32-bit version. I've opened a ticket. Thank you for bringing this to life again.

DigiPRO
KVRist
133 posts since 7 Mar, 2007

Post Sun Dec 05, 2021 9:49 pm

In short: Is it possible to download the 1.7.0 VPS Avenger installer version?

After installation of VPS Avenger 1.8.0., the DAW sequencers show the x64 VPS Avenger as an 'incompatible 32-bit file'. The VST3 version is nowhere to be found.

As I'm waiting on the support to respond, is it possible to download the previous installer version which would be 1.7.0. Can't find it on the web.

Thanks in advance.

DigiPRO
KVRist
133 posts since 7 Mar, 2007

Post Mon Dec 06, 2021 1:12 am

DigiPRO wrote:
Sun Dec 05, 2021 9:49 pm
In short: Is it possible to download the 1.7.0 VPS Avenger installer version?

After installation of VPS Avenger 1.8.0., the DAW sequencers show the x64 VPS Avenger as an 'incompatible 32-bit file'. The VST3 version is nowhere to be found.

As I'm waiting on the support to respond, is it possible to download the previous installer version which would be 1.7.0. Can't find it on the web.

Thanks in advance.
Solved by VPS Avenger support Andre, I got the 1.8.1. installer and it works now. Thanks a lot for the super-fast resolution.
Last edited by DigiPRO on Mon Dec 06, 2021 1:18 am, edited 1 time in total.

DigiPRO
KVRist
133 posts since 7 Mar, 2007

Post Mon Dec 06, 2021 1:17 am

invisiblesun wrote:
Mon Sep 13, 2021 1:15 pm
DigiPRO wrote:
Thu Sep 09, 2021 10:15 pm
I have some weird VST3 version issues.

If using a pitch bender in a VPS Avenger VST3 preset, the next loaded preset loads out of tune, so I need to reset it by moving the pitch bender again.

That only happens with VPS Avenger VST3.

I had an email conversation with their support, but without any solution to my problem.

I want to ask if this is a common/documented bug, or am I alone with this bug?

Using the VSP Avenger 1.7 and Cubase Pro 10.5 with a lot of RAM on PC.

I have no probe using the VSP Avenger VST2, but from the computer resource standing point, the VST3 version should be much more CPU-friendly.

I hope someone can shed some light on this one.
Is it this?
https://www.youtube.com/watch?v=q4YbSa6V4E4

If so, I have the same issue. Made a forum post about it a while ago and promised to report back after troubleshooting. Well it happens with any keyboard/ controller and it only happens with Avenger. So I am pretty sure it's an Avenger issue. Now that we are two that have this, maybe the devs will look into it.

Cheers MW
I can confirm that this has not been resolved yet after installing 1.8.1. version. Have you opened a ticket for this issue?

JohnRosso
KVRist
193 posts since 5 Sep, 2017

Post Tue Dec 07, 2021 1:07 am

soooo... I just updated my avenger and v-manager... Are we have a new copy protection system now? I can delete CodeMeter? Should I deactivate the license in CodeMeter first?
Was using 1.7 for a loooong time... didn't know we have 1.8 now

UPD. just checked FB group and there's post about codemeter dropout due M1 compatibility - great!

noiseboyuk
KVRAF
3591 posts since 25 Jan, 2007

Post Tue Dec 07, 2021 1:55 am

JohnRosso wrote:
Tue Dec 07, 2021 1:07 am
soooo... I just updated my avenger and v-manager... Are we have a new copy protection system now? I can delete CodeMeter? Should I deactivate the license in CodeMeter first?
I updated to 1.8, made that license system work then deleted CodeMeter. All good.
http://www.guyrowland.co.uk
http://www.sound-on-screen.com
W10, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2019 Ultimate, Cubase Pro 10.5
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD

User avatar
Sampleconstruct
KVRAF
15736 posts since 12 Oct, 2008 from Here and there

Post Tue Dec 07, 2021 3:46 am

I just upgraded from 1.4.8 to version 1.8.0 - running the factory content installer in VMan crashed Logic instantly, after that I wasn't able to install the factory content file as it had changed its size from 6+ GB to 0KB, now I'm downloading the content again.

User avatar
Sampleconstruct
KVRAF
15736 posts since 12 Oct, 2008 from Here and there

Post Tue Dec 07, 2021 4:29 am

Sampleconstruct wrote:
Tue Dec 07, 2021 3:46 am
I just upgraded from 1.4.8 to version 1.8.0 - running the factory content installer in VMan crashed Logic instantly, after that I wasn't able to install the factory content file as it had changed its size from 6+ GB to 0KB, now I'm downloading the content again.
Logic keeps on crashing when trying to install the factory content via VMAN, hmmm....
----
EDIT
ok, I finally got it working without using the VMAN thing.

invisiblesun
KVRer
18 posts since 13 Oct, 2017

Post Tue Dec 07, 2021 11:20 am

DigiPRO wrote:
Mon Dec 06, 2021 1:17 am
invisiblesun wrote:
Mon Sep 13, 2021 1:15 pm
DigiPRO wrote:
Thu Sep 09, 2021 10:15 pm
I have some weird VST3 version issues.

If using a pitch bender in a VPS Avenger VST3 preset, the next loaded preset loads out of tune, so I need to reset it by moving the pitch bender again.

That only happens with VPS Avenger VST3.

I had an email conversation with their support, but without any solution to my problem.

I want to ask if this is a common/documented bug, or am I alone with this bug?

Using the VSP Avenger 1.7 and Cubase Pro 10.5 with a lot of RAM on PC.

I have no probe using the VSP Avenger VST2, but from the computer resource standing point, the VST3 version should be much more CPU-friendly.

I hope someone can shed some light on this one.
Is it this?
https://www.youtube.com/watch?v=q4YbSa6V4E4

If so, I have the same issue. Made a forum post about it a while ago and promised to report back after troubleshooting. Well it happens with any keyboard/ controller and it only happens with Avenger. So I am pretty sure it's an Avenger issue. Now that we are two that have this, maybe the devs will look into it.

Cheers MW
I can confirm that this has not been resolved yet after installing 1.8.1. version. Have you opened a ticket for this issue?
HI! Thanks for joining in on this. I have opened a support ticket about the issue today. So we'll see.

noiseboyuk
KVRAF
3591 posts since 25 Jan, 2007

Post Tue Dec 07, 2021 2:50 pm

Just doing some housekeeping on the Mac - I noticed I have the following:

VPS_Avenger_XP_Factory.avxp2 - 6.25gb (6 Dec 2019)

and

Factory.avxp - 5.07gb (folder whose contents are older, but the init update in 1.8.1 updated in here).

Do I need both of these? Thanks for any help.
http://www.guyrowland.co.uk
http://www.sound-on-screen.com
W10, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2019 Ultimate, Cubase Pro 10.5
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD

User avatar
msvs
KVRAF

Topic Starter

2116 posts since 18 Apr, 2011

Post Tue Dec 07, 2021 2:52 pm

no you only need the avxp2, the bigger file
http://www.vengeance-sound.com
join our VPS AVENGER usergroup on FB: https://tinyurl.com/y99jurk9
join our reFX NEXUS usergroup on FB:https://tinyurl.com/tc5o9x7

noiseboyuk
KVRAF
3591 posts since 25 Jan, 2007

Post Tue Dec 07, 2021 3:00 pm

msvs wrote:
Tue Dec 07, 2021 2:52 pm
no you only need the avxp2, the bigger file
Great, thanks Manuel.
http://www.guyrowland.co.uk
http://www.sound-on-screen.com
W10, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2019 Ultimate, Cubase Pro 10.5
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD

5Lives
KVRian
585 posts since 10 Nov, 2005 from New York City

Post Tue Dec 07, 2021 11:22 pm

Well shit, sold my license a couple years ago due to CM. Sadly - since this is a great synth.

Guess I’ll have to start hunting the marketplace for a second-hand license now.

Ohlson_M
KVRist
158 posts since 20 May, 2016

Post Wed Dec 08, 2021 6:16 am

Manuel, any plans you can reveal regarding future expansions? Maybe Tech House 2, Techno 2 or Retrowave 80s 2? 🤭

User avatar
msvs
KVRAF

Topic Starter

2116 posts since 18 Apr, 2011

Post Wed Dec 08, 2021 8:29 am

this year will come Italo Disco 2 and Melodic Techno 1
http://www.vengeance-sound.com
join our VPS AVENGER usergroup on FB: https://tinyurl.com/y99jurk9
join our reFX NEXUS usergroup on FB:https://tinyurl.com/tc5o9x7

Return to “Instruments”