DrivenByMoss - Bitwig extension for lots of controller devices (and more)

RELATED
PRODUCTS
Bitwig Studio Maschine
TommyC81
KVRist
59 posts since 30 Dec, 2018

Post Wed Oct 05, 2022 9:46 am

Updated my TouchOSC tablet template for Bitwig (using latest DrivenByMoss v18.0.0), available here: https://github.com/TommyC81/TouchOSC
DrivenByMossOSC - Bitwig - v2022-10-05 - Mixer.png
DrivenByMossOSC - Bitwig - v2022-10-05 - Remote.png
DrivenByMossOSC - Bitwig - v2022-10-05 - Clips.png
DrivenByMossOSC - Bitwig - v2022-10-05 - Pads.png
DrivenByMossOSC - Bitwig - v2022-10-05 - Keys.png
You do not have the required permissions to view the files attached to this post.

mauiwayne
KVRer
7 posts since 24 Jan, 2018

Post Wed Oct 05, 2022 2:24 pm

moss wrote: Sun Oct 02, 2022 7:46 am
mauiwayne wrote: Wed Sep 28, 2022 11:49 pm I'm using your DrivenByMoss v17.6.0 with Komplete Kontrol 2 v7.2 to run my S88 keyboard. Also, I just updated to Bitwig 4.3.8 (maybe that's the problem?) and whereas I'm a lot more musician than techie, I'm following Nick's advice to reach out to you. Your extension is a real positive game changer, so any expert help you have to remedy this situation is much appreciated.
I saw that crash once before. I guess this is an incompatibility or bug in the USB library I use.
Not sure if I can do anything about it (I only have a M1 Mac with latest OS for testing).
Does this happen straight away on startup or when you do something specific?

Could you please remove Nick's email from your post? Thanks.
Hi Moss, the problem was occurring right away during start up...but somehow it seems to have gone away! It hasn't occurred lately at all. Also, I removed the name of the Bitwig person like you requested. I hope that wasn't causing a problem. Thanks again for everything Moss, Cheers :-)

Zacchino
KVRist
182 posts since 20 Jan, 2005

Post Wed Oct 05, 2022 2:58 pm

Tj Shredder wrote: Fri Sep 30, 2022 10:53 pm They (M-Audio Code 49's Transport Buttons) might send MMC commands (Midi Machine Control). There are settings to make Bitwig respond to them…
I actually tried playing around with several MMC settings in Moss, but nothing seems to trigger Bitwig's Transport.

I also looked into Code 49's Manual, but it doesn't specify which MMC number these Play/Stop/Rec/Fw/Bw are using). It only says it's using Mackie Control / HUI for the Transport buttons:
003398.png
PS: Did you notice that Note CC 40 is missing (it's showing "30" instead) in the Number drop-down menu of DrivenByMoss' General Flexi settings:
003396.png
You do not have the required permissions to view the files attached to this post.

Zacchino
KVRist
182 posts since 20 Jan, 2005

Post Wed Oct 05, 2022 8:01 pm

Tj Shredder wrote: Fri Sep 30, 2022 10:53 pm They might send MMC commands (Midi Machine Control). There are settings to make Bitwig respond to them…
Got it! I'll look into it as well.
(I've tried all the Mackie presets in DrivenByMoss's script, but none of them work, even when assigning all these F1, F2 etc. specifically to Play/Stop and so on).

Oh and I almost forgot: 🙏Thanks so much for your kind help :)

User avatar
Tj Shredder
KVRAF
8003 posts since 6 Jan, 2017 from Outer Space

Post Wed Oct 05, 2022 10:29 pm

The first thing I do in those cases, grab a Midi Monitor and just see what that damn machine is sending. If its something with sysex, its the latest moment to grab the manual or ask google how to change or deal with it…

trevormeier
KVRist
65 posts since 2 Feb, 2021

Post Thu Oct 06, 2022 8:36 am

TommyC81 wrote: Wed Oct 05, 2022 9:46 am Updated my TouchOSC tablet template for Bitwig (using latest DrivenByMoss v18.0.0), available here: https://github.com/TommyC81/TouchOSC
Thanks for sharing! Just downloading it to give it a try, and for some reason the interface updates (VU meters and parameters appear correctly) but when I touch the interface nothing's updating in Bitwig. I've used OSC a bunch before but never in Bitwig - is there an easy way to diagnose why Bitwig's not receiving the OSC messages?

User avatar
moss
KVRAF
Topic Starter
3427 posts since 13 May, 2004

Post Thu Oct 06, 2022 10:55 am

mauiwayne wrote: Wed Oct 05, 2022 2:24 pm Hi Moss, the problem was occurring right away during start up...but somehow it seems to have gone away! It hasn't occurred lately at all. Also, I removed the name of the Bitwig person like you requested. I hope that wasn't causing a problem. Thanks again for everything Moss, Cheers :-)
Did you change your connected USB devices (or rearrange them)?
I did a look at the library I use and it seems it has some issues when it cannot open a device and in that case is likely to cause a crash.

Please keep me updated if it happens again.

User avatar
moss
KVRAF
Topic Starter
3427 posts since 13 May, 2004

Post Thu Oct 06, 2022 11:19 am

Zacchino wrote: Wed Oct 05, 2022 2:58 pm PS: Did you notice that Note CC 40 is missing (it's showing "30" instead) in the Number drop-down menu of DrivenByMoss' General Flexi settings:
Ah, thanks. Just a typo.

If I understand the excerpt from the manual correctly you have different settings you can choose from (MCU, HUI, ...). As it seems to support MCU you could also simply use the MCU extension of DrivenByMoss.

melodyz
KVRian
590 posts since 29 Mar, 2016

Post Fri Oct 07, 2022 1:02 pm

hi this has been fixed
Last edited by melodyz on Sun Oct 09, 2022 12:32 pm, edited 1 time in total.

delixfe
KVRer
4 posts since 15 Jul, 2022

Post Fri Oct 07, 2022 2:50 pm

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.
melodyz wrote: Fri Oct 07, 2022 1:02 pm hi it seems the new windows 11 22h2 broke your script (akai fire). they are not working on my system anymore. im using 18.0 with 4.3.10. Not sure why. none of the akai fire lights are lit on the various modes. the channel button is unresponsive, none of the buttons are working. I dont know whats going on. this is the latest update that broke my stuff. 2022-09 Cumulative Update for Windows 11 Version 22H2 for x64-based Systems (KB5017389) and this one 2022-09 Cumulative Update Preview for .NET Framework 3.5 and 4.8.1 for Windows 11, version 22H2 for x64 (KB5017271) Novation launchcontrol xl also is unresponsive at times and just crashed as Im trying to use it

Microsofts solution is to roll me back to windows 10. can you believe this?
I had the same issue with macOS :). In my case, the upgrade to 18.0 was the problem. There is a small bug in that version.
I dug into that problem and created a pull request: https://github.com/git-moss/DrivenByMoss/pull/326 (https://github.com/git-moss/DrivenByMoss/pull/326).

Hopefully, moss will have some time to look into that. Meanwhile, I could send you a build with the fix.

melodyz
KVRian
590 posts since 29 Mar, 2016

Post Sat Oct 08, 2022 2:01 am

can I please have 17.6 back? Its not online

User avatar
moss
KVRAF
Topic Starter
3427 posts since 13 May, 2004

Post Sat Oct 08, 2022 4:01 am

melodyz wrote: Sat Oct 08, 2022 2:01 am can I please have 17.6 back? Its not online
It is still there:
https://www.mossgrabers.de/Software/Bit ... Bitwig.zip

Sorry, for the stupid bug, will be fixed soon!

melodyz
KVRian
590 posts since 29 Mar, 2016

Post Sat Oct 08, 2022 4:32 am

moss wrote: Sat Oct 08, 2022 4:01 am
melodyz wrote: Sat Oct 08, 2022 2:01 am can I please have 17.6 back? Its not online
It is still there:
https://www.mossgrabers.de/Software/Bit ... Bitwig.zip

Sorry, for the stupid bug, will be fixed soon!
Thanks I rolled it back. I didnt realize the older versions are on the home tab.

delixfe
KVRer
4 posts since 15 Jul, 2022

Post Sat Oct 08, 2022 5:25 am

Hi moss,

thanks a million for your development and support. :clap: :clap:

I have another small Fire related issue.
Changing the scale base key in Note play mode (Shift+Alt+Grid buttons) also affects the base key of the drum. Thus the drum won't be aligned with Bitwig's 16x16 pattern.

Regards,

delixfe

User avatar
moss
KVRAF
Topic Starter
3427 posts since 13 May, 2004

Post Sat Oct 08, 2022 7:46 am

delixfe wrote: Sat Oct 08, 2022 5:25 am Hi moss,

thanks a million for your development and support. :clap: :clap:

I have another small Fire related issue.
Changing the scale base key in Note play mode (Shift+Alt+Grid buttons) also affects the base key of the drum. Thus the drum won't be aligned with Bitwig's 16x16 pattern.

Regards,

delixfe
I cannot reproduce that. Could you please give some exact steps of what you are doing?

Return to “Controller Scripting”