DrivenByMoss: Bitwig extension for many hardware controllers (version 23.2.1)

RELATED
PRODUCTS
Bitwig Studio 5 Maschine

Post

HPKVR wrote: Fri Feb 16, 2024 1:44 am Hi Moss,
there is some problem with color representation on AKAI APC40Mk2 (both native and moss script). The gear is brand new (used few months), Bitwig Studio works properly, OS W11Pro works fine...flawless, but color matching is TRAGIC. Problem occures with native and moss script. Problem is not with AKAI device, because it works almost perfect in Ableton Live 11. Also sent to Bitwig support. Sorry, but this is unusable.
I have made PDF with photos and screenshots, but it is too big to post it here so you can dowload it here https://filebin.net/1nvmkeqvdr9ffvo5/AP ... colors.pdf (it expires 6 days from now).

Thank you for an answer.

Petr
There is (still) no access to the new color palettes in Bitwig via the API. Therefore, my implementation only uses the classic palette. Furthermore, the color palette of the APC is fixed and you cannot address all RGB colors, e.g. you also see that on the last of your slides.

Post

matomaus wrote: Sat Feb 17, 2024 8:01 am Hi Moss,
thank you for your great work.
I just bought a Novation Launchkey 88 an want to use it with Bitwig 5.1.3.
It behaves, as you discribed in your manual, exept that it doesn't show anything from Bitwig in it's internal display, only the hardware features of the Launchkey.
Do you know, how to fix this? I use a Macbook Pro with the Operating System 14.2.1 (23C71).
Thank you in advance for your much appreciated help,
Nikolas from Frankfurt

P.S. It would be great, if the up and down Buttons of the launchkey would switch thru the Buttons of the left side of the new Bitwig brouwser. Is that possible?
Hmm, only thing I can suggest is to check if your Launchkey is running the latest Firmware with the Novation Components App.

Post

moss wrote: Sat Feb 17, 2024 1:03 pm
HPKVR wrote: Fri Feb 16, 2024 1:44 am Hi Moss,
there is some problem with color representation on AKAI APC40Mk2 (both native and moss script). The gear is brand new (used few months), Bitwig Studio works properly, OS W11Pro works fine...flawless, but color matching is TRAGIC. Problem occures with native and moss script. Problem is not with AKAI device, because it works almost perfect in Ableton Live 11. Also sent to Bitwig support. Sorry, but this is unusable.
I have made PDF with photos and screenshots, but it is too big to post it here so you can dowload it here https://filebin.net/1nvmkeqvdr9ffvo5/AP ... colors.pdf (it expires 6 days from now).

Thank you for an answer.

Petr
There is (still) no access to the new color palettes in Bitwig via the API. Therefore, my implementation only uses the classic palette. Furthermore, the color palette of the APC is fixed and you cannot address all RGB colors, e.g. you also see that on the last of your slides.
Thank you Moss,
in your script it is obviously the Bitwig API issue. And yes, I know about the limitations of APC fixed palette, there is 128 colors max (only 122 are unique) and it covers wide range of colors
BWRGB128big.png
but as you can see (in previous PDF), Ableton Live matches those colors very well. So I think, next move is on Bitwig side.
BW answer from support:
Hi Petr,
thanks for your report, we hope we can improve the colors in the future!

...so I hope too.

Anyway, thank you for your answer

Best regards
Petr
You do not have the required permissions to view the files attached to this post.
Lenovo Legion 5 Pro, Ryzen7 5800H, 8C/16T, 32MB RAM, 2x1TB M.2, NVIDIA RTX3060 Laptop GPU, Bitwig Studio 5.x, Presonus Studio One 5/6, Presonus Studio 26c, Presonus ATOM SQ, AKAI APC40 MKII, Evolution UC-33e, M-Audio Radium 49, Studiologic VMK 188 Plus

Post

Hi Moss,
thank you for your answer. I already updated the firmware of the Launchkey 88 to the latest version. When i turn the knobs of the launchkey, the display only shows a number-value between 0 and 127. Nothing else is shown in the display. I just contacted the customer service at novation. Maybe they have an idea.
The other thing is the new Browser window in Bitwig. When i open it with the ... Button, there is no use of the Scene-up und Scene-down buttons. It would be great, if you could use them to browse through the buttons on the left side of the Browser. Is that possible?
Thank you in advance,
Nikolas from Frankfurt
moss wrote: Sat Feb 17, 2024 1:11 pm
matomaus wrote: Sat Feb 17, 2024 8:01 am Hi Moss,
thank you for your great work.
I just bought a Novation Launchkey 88 an want to use it with Bitwig 5.1.3.
It behaves, as you discribed in your manual, exept that it doesn't show anything from Bitwig in it's internal display, only the hardware features of the Launchkey.
Do you know, how to fix this? I use a Macbook Pro with the Operating System 14.2.1 (23C71).
Thank you in advance for your much appreciated help,
Nikolas from Frankfurt

P.S. It would be great, if the up and down Buttons of the launchkey would switch thru the Buttons of the left side of the new Bitwig brouwser. Is that possible?
Hmm, only thing I can suggest is to check if your Launchkey is running the latest Firmware with the Novation Components App.

Post

Hi,
I'm using the generic flexi controller script and what I can say is that it is indeed very flexible just as its name implies. I wonder if project remotes/track remotes will be accessible as additional modes too so knobs mapped to 'Modes: Set item X value' would work with project/track remotes the same way as they work with mixer controls and devices.

Post

moss wrote: Sat Feb 17, 2024 12:56 pm
Vitaliy_raw wrote: Thu Feb 15, 2024 7:37 am Thank you very much for the wonderful script for Novation Launchkey Mini Mk3!
I have a couple of suggestions for improvement.
1. Session Mode:
When clips are launched, the pads blink green, is it possible to make them blink with their unique track color?
2. Dram mode:
When selecting tracks, the pads always light up yellow and only the drum machine lights up in its own unique color. Is it possible to load a different color when selecting all tracks, as is done in the Bitwig script by default?
Thanks for the suggestions but I tend not to address color wishes since there are too many ;-)
Thanks for the answer! It just turns out that when all the tracks are playing, they all glow green(.. And you have to look at the monitor to understand what each pad is responsible for.

Post

Hello, using the LaunchPad at the first track of an 8-track block, is it possible to jump to the next 9-16 block of tracks in a single step without having to press an arrow 8 times to go through all first 8 tracks ?

Post

matomaus wrote: Sun Feb 18, 2024 2:46 am Hi Moss,
thank you for your answer. I already updated the firmware of the Launchkey 88 to the latest version. When i turn the knobs of the launchkey, the display only shows a number-value between 0 and 127. Nothing else is shown in the display. I just contacted the customer service at novation. Maybe they have an idea.
The other thing is the new Browser window in Bitwig. When i open it with the ... Button, there is no use of the Scene-up und Scene-down buttons. It would be great, if you could use them to browse through the buttons on the left side of the Browser. Is that possible?
Thank you in advance,
Nikolas from Frankfurt
Keep me updated if the support has any idea.

Regarding the browser: sadly Bitwig did not yet update the API to match the new browser. You can complain with their support as well :D

Post

mevla wrote: Mon Feb 19, 2024 8:21 am Hello, using the LaunchPad at the first track of an 8-track block, is it possible to jump to the next 9-16 block of tracks in a single step without having to press an arrow 8 times to go through all first 8 tracks ?
You can either use Shift+Cursor buttons or the Birds Eye view (see the manual).

Post

Hi Moss,
I have a request for Akai APC40 Mk2 Clip/scene control. Cursor up/down moves focus by 1 scene, with shift by 5 scenes 1-5 to 6-10 etc. But cursor left/right moves focus by 8 clips/tracks 1-8 to 9-16 etc. (not by 1 as expected) and with shift it does nothing. So I can't focus/shift tracks using left/right cursor. Can you change this behaviour so that cursor left/right moves focus by 1 clip/track and shift+cursor left/right moves focus by 8 clips/tracks.

Thank you
Petr
Lenovo Legion 5 Pro, Ryzen7 5800H, 8C/16T, 32MB RAM, 2x1TB M.2, NVIDIA RTX3060 Laptop GPU, Bitwig Studio 5.x, Presonus Studio One 5/6, Presonus Studio 26c, Presonus ATOM SQ, AKAI APC40 MKII, Evolution UC-33e, M-Audio Radium 49, Studiologic VMK 188 Plus

Post

Hi,
has a same functionality with Novation Launchpad Pro (original) and Launchpad MK2 and X too?

thx

Post

moss wrote: Mon Feb 19, 2024 11:46 am
matomaus wrote: Sun Feb 18, 2024 2:46 am Hi Moss,
thank you for your answer. I already updated the firmware of the Launchkey 88 to the latest version. When i turn the knobs of the launchkey, the display only shows a number-value between 0 and 127. Nothing else is shown in the display. I just contacted the customer service at novation. Maybe they have an idea.
The other thing is the new Browser window in Bitwig. When i open it with the ... Button, there is no use of the Scene-up und Scene-down buttons. It would be great, if you could use them to browse through the buttons on the left side of the Browser. Is that possible?
Thank you in advance,
Nikolas from Frankfurt
Keep me updated if the support has any idea.

Regarding the browser: sadly Bitwig did not yet update the API to match the new browser. You can complain with their support as well :D
Hi Moss,
the customer service wasn´t any help. They just suggested, that the launchkey 88 was released after the other Launchkeys and that the script, you wrote, wouldn't fit for the 88 version. They proposed, that i should use the native Launchkey Script from Bitwig. But your script has much more features, and besides that, the native Version from Bitwig doesent show anything on my display as well. I afterwards installed an Ableton Live lite version on my computer, to find out, if the display would work there properly, and it did. So here is my question: Do you know from other users, if your script did show anything in the display on other Launchkeys 88s or have you used it with a Launchkey 88 yourself? If not, would it be an option, that i send my Launchkey 88 to you and you check the script on that device. May be the display is adressed differently on the 88 version.
Regarding the Browser: I will write to the Bitwig on that matter.
Thank you very much for your time an help,
Nikolas from Frankfurt

Post

HPKVR wrote: Tue Feb 20, 2024 10:49 am Hi Moss,
I have a request for Akai APC40 Mk2 Clip/scene control. Cursor up/down moves focus by 1 scene, with shift by 5 scenes 1-5 to 6-10 etc. But cursor left/right moves focus by 8 clips/tracks 1-8 to 9-16 etc. (not by 1 as expected) and with shift it does nothing. So I can't focus/shift tracks using left/right cursor. Can you change this behaviour so that cursor left/right moves focus by 1 clip/track and shift+cursor left/right moves focus by 8 clips/tracks.

Thank you
Petr
This is coming up from time to time and I already changed this quite often :-)
Maybe I will revisit this again but not any time soon.

Post

tomigonzo wrote: Fri Feb 23, 2024 12:09 pm Hi,
has a same functionality with Novation Launchpad Pro (original) and Launchpad MK2 and X too?

thx
Not sure if I understood the question. If you are asking if the feature set is identical, then the answer is yes besides the fact that the Pro has more buttons and can be easier navigated.

Post

matomaus wrote: Sat Feb 24, 2024 3:50 am Hi Moss,
the customer service wasn´t any help. They just suggested, that the launchkey 88 was released after the other Launchkeys and that the script, you wrote, wouldn't fit for the 88 version. They proposed, that i should use the native Launchkey Script from Bitwig. But your script has much more features, and besides that, the native Version from Bitwig doesent show anything on my display as well. I afterwards installed an Ableton Live lite version on my computer, to find out, if the display would work there properly, and it did. So here is my question: Do you know from other users, if your script did show anything in the display on other Launchkeys 88s or have you used it with a Launchkey 88 yourself? If not, would it be an option, that i send my Launchkey 88 to you and you check the script on that device. May be the display is adressed differently on the 88 version.
Regarding the Browser: I will write to the Bitwig on that matter.
Thank you very much for your time an help,
Nikolas from Frankfurt
Since I never got an error report for the 88 model, I simply supposed it worked. Who could think that they changed the sysex header for the 88 model. Argh!!!! Why?
But they have a good tradition for such things, there are no 2 Launchpad models with the same protocol!

Also the fader modes were inactive for the 88 model. Will both be fixed in the next update.
Will PM you a test version...

Return to “Controller Scripting”