SynthMaster 3 Official Thread - v3.0 Beta (VST2/VST3/AAX/AU2/Standalone) & Demo released

VST, AU, AAX, CLAP, etc. Plugin Virtual Instruments Discussion

Post

Jac459 wrote: Tue May 14, 2024 11:07 pm So the change is not that big hehe.
Well, as the developer I can confidently confirm that the change is big :)
Works at KV331 Audio
SynthMaster voted #1 in MusicRadar's "Best Synth of 2019" poll
SynthMaster One voted #4 in MusicRadar's "Best Synth of 2019" poll

Post

kv331 wrote: Wed May 15, 2024 12:18 am
Jac459 wrote: Tue May 14, 2024 11:07 pm So the change is not that big hehe.
Well, as the developer I can confidently confirm that the change is big :)
Then I think we can confidently saying you know better haha.

But I hope it was clear I was only joking, SM3 is clearly a big upgrade, but SM2 was already sounding great hehe.

Post

rev15128 (and possibly earlier?) seems to have a really bad bug where (multi)sample OSCs work okay but it crashes after i tried to load a "new" custom sample from a folder into a sample OSC, and also saves a (likely corrupted) global setting so that all instances of SM3 (vst2/3 in completely fresh Bitwig/Reaper/FLStudio) crash on any plugin instantiation (also fully crashes Reaper and FLStudio), to the point where not even reinstalling, or a full uninstall+reinstall or downgrading to 15110 fixes it.

I can't get it to launch anywhere at all, have no way to tell where the corrupted setting is hiding and as far as i can tell there's no error message, no crash- or debug-log or anything to even tell what's failing and why.

The crash is actually so early that DAW's trying to (re)scan SM3 will straight up refuse to list it as a valid plugin, even after a manual uninstall, cleaning out any folders and reg keys, rebooting and a fresh reinstall.
failed.png
e: to be clear, the problem isn't as much that SM3 instances don't work properly anymore, it's that i cant open any project that includes even one saved SM3 instance (until i completely uninstall SM3).
You do not have the required permissions to view the files attached to this post.
Last edited by RoadCrewWorker on Thu May 16, 2024 5:57 am, edited 1 time in total.

Post

RoadCrewWorker wrote: Thu May 16, 2024 5:07 am rev15128 (and possibly earlier?) seems to have a really bad bug where (multi)sample OSCs work okay but it crashes after i tried to load a "new" custom sample from a folder into a sample OSC, and also saves a (likely corrupted) global setting so that all instances of SM3 (vst2/3 in completely fresh Bitwig/Reaper/FLStudio) crash on any plugin instantiation (also fully crashes Reaper and FLStudio), to the point where not even reinstalling (or a full uninstall+reinstall) or downgrading to 15110 fixes it.

I can't get it to launch anywhere at all, have no way to tell where the corrupted setting is hiding and as far as i can tell there's no error message, no crash- or debug-log or anything to even tell what's failing and why.
The crash is actually so early that DAW's trying to (re)scan SM3 will refuse to list it as a valid plugin.

e: to be clear, the problem isn't as much that SM3 instances don't work properly anymore, it's that i cant open any project that includes even one saved SM3 instance.
I remember having similar problems - I fixed it by editing "SynthMasterSamplesFolders.txt" file located at Users\Public\Documents\Synthmaster3 (Windows) and deleting "SamplePaths" entry.
---
Samples_Folder.jpg
You do not have the required permissions to view the files attached to this post.

Post

Thanks, that actually worked!

I'm gonna be honest(ly frustrated): that's both a horrible location to drop persistent settings (and synthmaster is the only program doing it) that not even the official uninstaller cleans up and also a horrific way to (not) handle whatever error pops up. There needs to be some sort of sanity checking or input verification or logging so we can actually report this stuff properly.

... also are we supposed to be able to do anything (like add or remove paths) in this settings tab?
filepaths.png
You do not have the required permissions to view the files attached to this post.

Post

RoadCrewWorker wrote: Thu May 16, 2024 6:09 am I'm gonna be honest(ly frustrated): that's both a horrible location to drop persistent settings (and synthmaster is the only program doing it) that not even the official uninstaller cleans up and also a horrific way to (not) handle whatever error pops up. There needs to be some sort of sanity checking or input verification or logging so we can actually report this stuff properly.
One of the sample files you are trying to import has an incorrect WAV/AIFF data chunk and it IS causing SynthMaster 3 to crash. I would really appreciate if you could email me the WAV/AIFF files you are trying to import at: bulentbiyikoglu AT kv331audio DOT com so that I can debug and understand the problem with those WAV/AIFF files.

Public Documents folder is used by apps when they store global/machine-wide (not user specific) settings/data. That IS why we use that folder. Native Instruments for instance uses Public Documents as well. (Just double checked, there's a NI Resources folder on both Windows and MacOS)

Sorry for not being able to provide a logging infrastructure. (On MacOS crash logs provide valuable information so we have the mechanism to upload them to our server if the user wants to send them)
Works at KV331 Audio
SynthMaster voted #1 in MusicRadar's "Best Synth of 2019" poll
SynthMaster One voted #4 in MusicRadar's "Best Synth of 2019" poll

Post

kv331 wrote: Thu May 16, 2024 6:35 am [I would really appreciate if you could email me the WAV/AIFF files you are trying to import at: bulentbiyikoglu AT kv331audio DOT com so that I can debug and understand the problem with those WAV/AIFF files.
Wish i could, but the SamplePaths contained thousands of files and there's no error or log to tell which one caused it. I actually really don't want there to be an elaborate background scan, i just want to add a few dozen samples.

Drag and drop doesn't do anything either, so i have no idea how i could check.

Post

RoadCrewWorker wrote: Thu May 16, 2024 1:24 pm Wish i could, but the SamplePaths contained thousands of files and there's no error or log to tell which one caused it. I actually really don't want there to be an elaborate background scan, i just want to add a few dozen samples.
Do you have one root folder with subfolders or all of those 1000s of samples in one folder? Assuming subfolders -> If you want to add a few dozen samples try to import just the subfolder where those reside.
RoadCrewWorker wrote: Thu May 16, 2024 1:24 pm Drag and drop doesn't do anything either, so i have no idea how i could check.
What's your workflow? How are you dragging and dropping the samples? multiple files at one? drag-n-drop a folder? or drag-n-drop from DAW file browser? What's the exact scenario? I tested with all three options and they do work.
Works at KV331 Audio
SynthMaster voted #1 in MusicRadar's "Best Synth of 2019" poll
SynthMaster One voted #4 in MusicRadar's "Best Synth of 2019" poll

Post

I have the problem, that the beta lets me not download all the sounds, I have the all bundle.
artie fichelle sounds natural

Post

Artie Fichelle wrote: Fri May 17, 2024 12:54 am I have the problem, that the beta lets me not download all the sounds, I have the all bundle.
FREQUENTLY ASKED QUESTIONS:

1. How can I restore my SynthMaster One / SynthMaster 2 expansions inside SynthMaster 3 ?

For SynthMaster 3 to detect SynthMaster One / 2 presets, SynthMaster One / 2 must have been installed and authorized. Expansions for those synths should be restored inside those synths.
Works at KV331 Audio
SynthMaster voted #1 in MusicRadar's "Best Synth of 2019" poll
SynthMaster One voted #4 in MusicRadar's "Best Synth of 2019" poll

Post

i've got question about sm2 ,just hypothetically,is it possible to become one page synth uniting the two layers into one,something like sm1 or the structure didn't allow it?
SM1 is one of most intuitive and lovely one page synth out there,if sm2 become something like it after sm3 is done would be more easy for use.
I mean the two layer are kind of extended working time,when man can see and do everything in front is so easy and useful,that's why one page synths are so popular or maybe i am getting lazy,but prefer and use one page synths way more than enything else.
Asking hypothetically :)

Post

Thanks to you and greetings from South of Greece to Ankara. Btw. Together neighbors could do great things, just saying.
artie fichelle sounds natural

Post

Artie Fichelle wrote: Fri May 17, 2024 2:03 am Thanks to you and greetings from South of Greece to Ankara. Btw. Together neighbors could do great things, just saying.
:hug: :hug: :hug:
Works at KV331 Audio
SynthMaster voted #1 in MusicRadar's "Best Synth of 2019" poll
SynthMaster One voted #4 in MusicRadar's "Best Synth of 2019" poll

Post

kv331 wrote: Thu May 16, 2024 11:35 pm Do you have one root folder with subfolders or all of those 1000s of samples in one folder? Assuming subfolders -> If you want to add a few dozen samples try to import just the subfolder where those reside.

What's your workflow? How are you dragging and dropping the samples? multiple files at one? drag-n-drop a folder? or drag-n-drop from DAW file browser? What's the exact scenario? I tested with all three options and they do work.
I have a pretty large root folder, i'll try working with smaller folders.

Either way I don't really have a "workflow" yet, i'm really just trying to load custom wav samples (both short foley and longer synth sustains) into various parts.
-drag and drop 1 file into the "WAVEFORM EDITOR" seems to work (sometimes). Would be nice to have info why there's occasionally no effect (for example if max length is exceeded)?
-drag and drop 1 file into the "WAVETABLE EDITOR" usually works after a few attempts. Also a good fallback for single-cycles that dont work in the waveform editor?
-drag and drop 1 or multiple files into the "SAMPLE EDITOR": Dragging shows the "chromatic import"/"to white/black keys" options, but on drop doesn't create a group or adds any samples. Sadly no real feedback from the synth on what went wrong.

Btw, converting from an "empty" sample OSC (without groups?) to a wavetable bricks the preset and it only seems to produce clicks. The OSC view looks like this:
wt_bug.png
These are all very powerful features that i'm looking forward to! :) Current behavior seems a bit rough around the edges at the moment, without much feedback on why nothing happened. :(
You do not have the required permissions to view the files attached to this post.

Post

RoadCrewWorker wrote: Sat May 18, 2024 2:48 am Btw, converting from an "empty" sample OSC (without groups?) to a wavetable bricks the preset and it only seems to produce clicks. The OSC view looks like this:
wt_bug.png
I will fix this one. But for the other import issues, I need some samples to test with -> bulentbiyikoglu AT kv331audio DOT com is my email :)

So far I have tested with our factory samples, and they did work. I also tested importing wavetables / single cycle waveforms (I have a large collection to test with) and they did work.
Works at KV331 Audio
SynthMaster voted #1 in MusicRadar's "Best Synth of 2019" poll
SynthMaster One voted #4 in MusicRadar's "Best Synth of 2019" poll

Return to “Instruments”