VPS Avenger 2.2 [RELEASED - FAQ in OP]

VST, AU, AAX, CLAP, etc. Plugin Virtual Instruments Discussion
RELATED
PRODUCTS
Maelstrom for VPS Avenger 2 VPS Avenger VPS Avenger 2

Post

So far it looks like macbooks arent affected, but minis and studios are?

Quick question to the guys who've ran the test I outlined above - do you keep your avenger library on the internal or an external drive?

Post

External for me.
Ssd over usb 3.2
rsp
sound sculptist

Post

Macbook here. Could be an M1/Ableton thing.

I'm not moving off of 2.0.5, it's fine being exactly there.

Post

Avenger 2.2 - mini M2 Pro, Logic 11.0.1, Sonoma 14.5 = NO SPIKES

Post

remix68 wrote: Wed Jul 10, 2024 6:40 pm Could be an M1/Ableton thing.
I'm on Logic so its not that. I tested for a few hours this morning using different configurations and found this interesting. I booted up a fresh logic project and added one instance of avenger and left it idle with the Init preset loaded. The intermittent 100% cpu spikes continued, as I expected. After 5 minutes I added a second instance and the idle spikes stopped. Looking at the cpu history graph, you can see the efficiency cores were working overtime whilst I only had the first instance added, then they immediately dropped when I added a second.

FWIW, I dont have efficiency cores selected to be used in logics CPU settings, and as far as I'm aware, logic ignores efficiency cores completely anyway (even though it's listed in the options).

To anyone else getting idle spikes, maybe you could try this yourself and report back here. I'll send my findings to support, but hopefully it's a step towards working on what the f**k is going on.

Pasted Graphic.jpg
You do not have the required permissions to view the files attached to this post.

Post

Update: Ok scrap that theory - I just tried creating a real life project with 5 instances of avenger and it was causing CPU spikes left, right, and centre. Efficiency cores didn't seem to be a factor, at least not this time.

Post

I also have CPU spikes. However, they seem to go away to a good extent if I close Chrome. I guess Chrome competes with Avenger regarding graphics cores.

Mac Mini M1.
"If less is more, just think of how much more, more will be".

Post

I have an issue importing multisamples. I loaded a folder with some wave files from my analog synth. Every file is:
1) 48000Hz / 24bit
2) named with name_note (ex. saw_C2, saw_F#2 etc)
But when I play I ear a click and nothing else. Also, the file waveform is not visible in Avenger.
Ideas?

Post

arcy wrote: Sun Jul 14, 2024 8:06 am I have an issue importing multisamples. I loaded a folder with some wave files from my analog synth. Every file is:
1) 48000Hz / 24bit
2) named with name_note (ex. saw_C2, saw_F#2 etc)
But when I play I ear a click and nothing else. Also, the file waveform is not visible in Avenger.
Ideas?
Convert your samples to 44.1 kHz first otherwise they will play out of tune, concerning the clicking issue I have no idea what could be wrong. Maybe the conversion will solve the issue.

Post

Sampleconstruct wrote: Sun Jul 14, 2024 8:50 am
arcy wrote: Sun Jul 14, 2024 8:06 am I have an issue importing multisamples. I loaded a folder with some wave files from my analog synth. Every file is:
1) 48000Hz / 24bit
2) named with name_note (ex. saw_C2, saw_F#2 etc)
But when I play I ear a click and nothing else. Also, the file waveform is not visible in Avenger.
Ideas?
Convert your samples to 44.1 kHz first otherwise they will play out of tune, concerning the clicking issue I have no idea what could be wrong. Maybe the conversion will solve the issue.
It works, thanks!

Post

msvs wrote: Sat Sep 19, 2020 12:59 am
magicmusic wrote: Fri Sep 18, 2020 11:03 pm
msvs wrote: Fri Sep 18, 2020 10:33 am a rectangle grain env would cause 2 crackles (in/out)
when avenger maybe can allow exact settings. for 120 bpm need set the grain size to 250 ms and the grain density to 4 then the fades from grain env are on every beat and when use drums they can not hear. i think then avenger this way can sound better as many other slicer. many slicer do less or more clicks when rearrange.

but it can also work with shorter grainsize when read rate is same as wav then no grain env is need. only need the grain env when a position change happen to play another slice. maybe that the fades happen every grain size is because i can not set exact 40 grains per second on grain density
the granular engine can never become a good slicer. Like I said, we plan a real slicer module für 2.0. That makes more sense than somehow force the granular into something half baked
is there any progress for a slicer module and it come soon ? .btw . the post in the old avenger thread can delete. here is the right place
win 10 64 22H2 intel i5 8600K (6*3.6 GHZ) 32 GB Ram

Post

If I may ask, Manuel "msvs" when will the upgrade of the arpeggiator/sequencer midi import function be released?

Post

there is no timeframe yet, but its one of the next points on the list

Post

Quick PSA - Plugin Boutique has a 30% discount on Avenger 2 at the mo (and also do rent to own).
http://www.guyrowland.co.uk
http://www.sound-on-screen.com
W11, Ryzen 7900, 64gb RAM, RME Babyface, 1050ti, PT 2024 Ultimate, Cubase Pro 13
Macbook Air M2 OSX 10.15

Post

noiseboyuk wrote: Tue Jul 16, 2024 11:19 pm Quick PSA - Plugin Boutique has a 30% discount on Avenger 2 at the mo (and also do rent to own).
Crazy value ,❤️❤️❤️❤️❤️

Return to “Instruments”