Bug reports

Official support for: musicdevelopments.com
RELATED
PRODUCTS
Fyler RapidComposer

Post

BluGenes wrote: Tue Dec 13, 2022 8:44 am
lovemusic15 wrote: Thu Dec 08, 2022 7:32 pm BluGenes, do you know if there's a way to convert all of your custom phrases in your library back into midi files all at once.
I looked into this, and this is not bug... sorry!

Was that reply meant for me I wasn't asking about a bug

Post

lovemusic15 wrote: Tue Dec 13, 2022 8:55 am
BluGenes wrote: Tue Dec 13, 2022 8:44 am
lovemusic15 wrote: Thu Dec 08, 2022 7:32 pm BluGenes, do you know if there's a way to convert all of your custom phrases in your library back into midi files all at once.
I looked into this, and this is not bug... sorry!

Was that reply meant for me I wasn't asking about a bug
Yes it was.. You want stuff fixed? Why oh why would you start an off topic message in bug reports?

do you not understand how this works? Atilla see's new messages in bug reports, oh no, new bugs.. oh wait, not a bug, damn, just wasted time reading that.. time wasted for fixing stuff..

just start a new thread if you have a question.. anything not related to the topic is ignored.

Post

Deleted
You do not have the required permissions to view the files attached to this post.

Post

Please delete above image and file.

Post

Im getting lots of crashes on the newest RC version on my M1 Mac Mini 2020 running Ventura. I dont see how to generate a report that I can upload to here.
Last edited by lasvideo on Sat Dec 17, 2022 11:32 am, edited 1 time in total.

Post

Sometimes I have to use Force Quit to get the newest RC version on my M1 Mac Mini 2020 to quit even after using the Close function. The screen goes away but its still indicated as running. Cant reopen it either until force quit is used.
Last edited by lasvideo on Sun Dec 18, 2022 7:48 pm, edited 10 times in total.

Post

Heres a crash report.
RC Crash Report.zip
You do not have the required permissions to view the files attached to this post.

Post

Hi Attila. A couple of things:
Standalone v4.5.1 :
1. New composition > Add Track (as track 2, leaving track 1 untouched) > Right Click track 2 > Change Type to Percussion. Under Instrument > Choose RCDrumsAcou.sf2. The track type changes back to Type: Normal on its own.

2. In addition to the above, on track 2 > Add percussion generator > Line up bottom row to C2 (bass drum) > Press play. Plays as expected but Track 1 also shows output as well even though it is blank. Right click Track 1: it still shows instrument as piano but in fact, it has inherited the instrument and output routing from track 2, in this case, the drums.

I can easily reproduce this and can do a video if clarification is required.
Cheers.
Mike.

Post

I just downloaded and installed Rapid Composer v4.5.1. When I load a previous song from earlier versions of Rapid Composer, there is no sound. I am using a MIDI output from Rapid Composer running into LoopBe, then into Native-Instruments-Bandstand. This has been working fine in previous versions of RC, now it won't work at all. Sometimes LoopBe turns itself to "Mute." Sometimes I hear a waterfall of notes occurring in the space of half a second. Other times I only hear a single chord at the beginning of the composition which holds forever. RC v4.5.1 always continues the play-scroll bar, though there is no sound. Nothing stops the play-control bar. Sometimes I have to attempt to load a new composition, just to get the silent playback to quit. Sometimes I have to quit the program to get silent playback to stop.

I tried to revert to RC v4.4.3, which WAS working fine until I updated to v4.5.1, but now v4.4.3 won't load. Version 3.84 works fine. I tried uninstalling all the RC files and installing v4.5.1, but I got a "input your Authorization Code" challenge. I did not remove my RC files in the "Documents" folder, but renamed them. That's when I got the Authorization challenge. When I renamed them back, the Authorization challenge went away.

Now I only have v3.84.

Post

Hi, Attila.
1. Windows, standalone RC v4.5.1, new composition, save composition to "Untitled1.rcCOMP".
2. Reaper + RC VSTi, new composition - all work fine.
3. Reaper + RC VSTi, open composition from "Untitled1.rcCOMP" - I can't input and edit text data, for example track names.

Post

I have a sequence where the last note in the highlighted phrase will not play when playing the sequence. It plays just fine when I trigger just the phrase and when in the note editing mode it plays as well.

Screenshot 2022-12-20 at 7.06.20 PM.png
TS 3.4 Evolution.rcCOMP.zip
You do not have the required permissions to view the files attached to this post.

Post

Ive been away for a while. Does Attilla still visit this forum?

Post

Hi Attila,

I just tried the latest RC beta as a VSTI in Bitwig studio. The little keyboard icon, when active, feeds keyboard presses through to RC perfectly. In my view, RC is now a monster VSTI !!!

Thanks You, Sir

Post

Attila:
There is still a MAJOR BUG when running the newest version of RC On Mac OSX 13 M1 Ventura where RC wont shut down. I have to use FORCE QUIT in order to close the program.

Post

Problem solved by Attila. The Piano.VST I was using was causing the issue. When using the General User piano the problem is gone. :)

Return to “MusicDevelopments”