Z3TA+ 2 Bug Report Thread

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
KVRAF
2852 posts since 23 Feb, 2004 from Planet Earth...for now

Post Sat Aug 06, 2011 12:15 pm

The following is a list of all the bugs/complaints collected from this Thread, starting from page 30 (since Z3TA 2 was made available).
Note: This is only a list of what has been reported in that thread, and as such should be considered Unconfirmed.

BUGS:

01. Waveform Mouse Draw: drawing with mouse produces no audible change.

02. Waveshaper XY: Not working.
"I've noticed the joystick control for the XY barely works. I got it to work for a bit and then closed the GUI and it stopped working."

03. ARP: Weird Arpegiator behavior - stuck notes, no sound with some arps.

"I think there is a bug in the Arpeggiator. It has disabled completely on me when cycling through presets (even though it is enabled in the settings!). I had to completely close my host and reopen to get Z3ta+v2 to re-activate the arpeggiator."

"Jep, the Arp has a bug. If the project is playing always placed midi events all works fine. But if the project is stopped, playing over the keyboard doesn't work. Something with the synchronization seems to be broken."

04. Hide Preview Ribbon: Does not work in Reaper or Orion (the GUI gets corrupted) (works in FL and Sonar 8.5PE) but it's state is not remembered after closing.....would like to keep it hidden but it's shown by default after close/open.

05. GUI RAM Usage: opening the UI increases RAM usage by a whopping 300MB
"GUI takes a huge hit of RAM. 450 when first opened up in FL Studio. Close the GUI - 150!!!"

06. Limiter: (randomly, not all the time) If the limiter is activated a channel had decreased volume. Disable the limiter all works fine. Reloading the plug-in solved this too.

07. Oversampling: If you have a Preset that has realtime oversampling set to x2.0 and offline set to x1.0 then in Ableton live if you're exporting / mixing down such track then you'll get no sound. If you set realtime / offline oversampling like 1.0/1.0 or 2.0/2.0 then it works.

08. LFO: There seems to be a bug in lfo, when using the option Wave1- Random, knobs become slow, it is almost impossible to make any changes.

09. Program - PASTE: This doesn't work (nor should it under the new preset system). I even tried COPY - change folder - PASTE - did nothing but return me to the original folder.]

10. MIDI Learn = CPU Spikes: "Whenever I MIDI learn a knob and then use the controller (e.g. mod wheel or expression pedal) to 'turn' the knob, I get huge CPU spikes.



COMPLAINTS/SUGGESTIONS:

01. ARP compatability broken. Z3TA+2 overwrites already used arp patterns from 152-200. A cmp2midi utility could be a nice workaround - or better even, arp export to midi file - see #3

02. ARP Sync is missing the flyout menu. This was there in the previous version - PITA

03. ARP export would be great.

04. ARP pattern editing within window display.

05. Waveshaper GUI section: Even though they have increased the overall gui size the waveshaping controls are smaller and very cramped. Waveshaper controls far too small and fiddly to select with mouse (compared to old version) - not designed for performers

06. GUI General: "I think they should have kept the modules in the same spaces on the GUI -- LFO should be where Filter currently is and EG and Filter then swapped."

07. Why arrows in EG shape boxes when they don't do anything?

08. Only 2x Oversampling?

09. Removal of Microtuning :(

10. Removal of FX only version :(

11. Unison: "this is really weird detune system, honestly. What if i have 3 or 4 oscillators used in multiple-free mode? What a sound mess i'll get it? You definitely need a global unison module in updates."

12. Waveshaper X/Y and LFO morph control would have been cool as mod targets.

13. The Reverb could be better. Sounds (bad) like the last one. Filter could sound better

14. No DEMO :(

15. MODs no longer feasible - reimplement the "backhole" feature, where the plugin checks its root directory first.

16. Load Wavetable Set removed :( "Load Global Wavetable set" and "Load Program Wavetable set" were removed. Keeping this would have provided backward compatabilty for getting MODs or presets that used other .set files to work, i.e. The virus Mod (without the proper arps, but still)

17. Removed: "Get fx Setting from Program File" - This WAS a nice feature :(

18. Loading USER waveforms is tedious. It would be great to be able to click through the currently selected/set folder for each USER wave 1-6, essentially browsing waveforms like you can with all the other wavs

19. Add the option to "import with preset numbers" to avoid alphabetizing the bank

20. A nice consideration for preset designers would be to make a flyout menu for any parameter with, say, more than three options.
Last edited by 1-2-Many on Sat Aug 13, 2011 2:01 pm, edited 14 times in total.

Banned
168 posts since 29 Jun, 2011

Post Sat Aug 06, 2011 12:22 pm

(they sound pretty bad, even for a *.0 release)

KVRist
328 posts since 11 Apr, 2004 from Brazil

Post Sat Aug 06, 2011 1:21 pm

good thread, I'm having problems with the arp/sequencers not working... ;)

User avatar
KVRAF

Topic Starter

2852 posts since 23 Feb, 2004 from Planet Earth...for now

Post Sat Aug 06, 2011 1:50 pm

Added 14-17 to complaints/suggestions section
Last edited by 1-2-Many on Sat Aug 06, 2011 4:14 pm, edited 1 time in total.

KVRAF
1568 posts since 30 Jul, 2007

Post Sat Aug 06, 2011 2:55 pm

There is no FX version... Please provide one. Many people expected this. Thank you.

User avatar
KVRAF
15395 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sat Aug 06, 2011 3:10 pm

03. ARP: Weird Arpegiator behavior - stuck notes, no sound with some arps.


Confirmed. Arp is really wonky......changing to Sync mode sometimes causes the Arp to stop working.

+1 for the FX version. Z2's FX section would make a really great Rack of Effects.

"Hide Preview Ribbon" does not work in some hosts.

No answer from CW at their forum......I'll link to this thread from there........
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRer
5 posts since 23 May, 2004

Post Sat Aug 06, 2011 3:43 pm

Downloaded z3ta+ 2 tonight, loaded up the VST under Studio One, found "8-bar first contact" in its new location and -- yuck, no sequencing. None of the arp/sequence presets are working; some make noise (but no arping/sequencing), most are just silent.

However, for whatever reason, all the arp/sequence presents seem to work OK running z3ta+ 2 as a stand alone.

A bunch of my old ProSounds presets sound terrible. Am going to wait before trying out any other third party content to minimize further heartburn.

KVRer
5 posts since 23 May, 2004

Post Sat Aug 06, 2011 5:41 pm

Follow-up: found that the arps and sequences work in the VST version if the sequencer is actively recording. When it is rolling, z3ta+ 2 is able to find the tempo and sync with it. Otherwise, it can't and it just sits there. Anyone else seeing this behavior?

KVRAF
1909 posts since 26 Sep, 2004

Post Sat Aug 06, 2011 10:34 pm

Bug in Cubase 5.1.1: I hear always a high sine tone at 2000 Hz as noise.
Last edited by Gucky on Mon Aug 08, 2011 1:02 am, edited 1 time in total.

KVRAF
42530 posts since 21 Dec, 2005

Post Sat Aug 06, 2011 10:39 pm

Good lord :roll:

Well, an in just to keep track

User avatar
KVRAF

Topic Starter

2852 posts since 23 Feb, 2004 from Planet Earth...for now

Post Sat Aug 06, 2011 11:55 pm

Not exactly bug related but has anyone else noticed a general lackluster job on the new manual? I swear they just cribbed off the V1 manual. There's even stuff lifted that's no longer applicable.
Page 61 of the V2 manual wrote:Default Programs File
Every time you start Z3TA+ in stand-alone mode, or when you insert a new instance in a host when using it as VSTi, Z3TA+ checks the Contents\Z3TA+ 2\Programs folder under installation directory for a file called default.fxp, which is the default file used when initializing a program.

If it finds this file, it automatically loads it, and all its programs will be instantly available. This is the way the default patches are shipped.
If you want to customize your bank and have it ready for use in the next instance or session, you can use the Save Default File option in the Bank menu to save the default bank file.

Warning: If you delete the default bank file, Z3TA+ will load without programs. You will need to reinstall the product in order to restore the factory patches.
NOT! :lol: This was lifted in its entirety from the old manual and is no longer valid info. They even mish-mashed it a bit to make it less correct than the original.

KVRAF
4592 posts since 2 Nov, 2006

Post Sun Aug 07, 2011 7:22 am

Ok, how to ruin a masterpiece... :help:
Image

User avatar
KVRAF
2488 posts since 18 Jun, 2008 from "nunya"....

Post Sun Aug 07, 2011 10:38 am

Sounds like they better re-hire Rene.... :hihi:

(sorry for the OT..)
KVR >Gear Slutz! Change my mind! :clap:

User avatar
KVRist
312 posts since 23 Oct, 2007 from Somerset UK

Post Sun Aug 07, 2011 11:42 am

vaisnava wrote:There is no FX version... Please provide one. Many people expected this. Thank you.
I'm going out on a limb here, but are you saying you don't yet own, delay, chorus, phasor, reverb, and distortion inor on your DAW.?

There's not much point in the FX version, to be honest. The only synth/fx section I've ever found interesting is Absynth FX simply because it modulates well and grain type delays.

Apart from that, there's not much point, and I can see why I would leave it out should I be in the DSP business.

No offence. :?

User avatar
KVRAF
15395 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun Aug 07, 2011 2:13 pm

Proxima4 wrote:
vaisnava wrote:There is no FX version... Please provide one. Many people expected this. Thank you.
I'm going out on a limb here, but are you saying you don't yet own, delay, chorus, phasor, reverb, and distortion inor on your DAW.?

There's not much point in the FX version, to be honest. The only synth/fx section I've ever found interesting is Absynth FX simply because it modulates well and grain type delays.

Apart from that, there's not much point, and I can see why I would leave it out should I be in the DSP business.

No offence. :?
The point being I like the Chorus....and the Delays....and the Reverb....and the EQ.... and the fact that you can now rearrange their order in version 2 all in one convenient plugin rather than loading 3 or 4 separate plugins....

Do I own other FX? Of course I do but since there was an FX version of Z1 and the Z3TA FX in general are of pleasing quality it stands to reason that people will ask for an FX version of Z2.....in fact it was rather expected.

But anyway this is the BUG REPORT thread...... and we've both wandered off topic. Let's take the discussion to one of the other Z2 threads.........
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

Return to “Instruments”