MacOS High Sierra compatibility

Official support for: bluecataudio.com
RELATED
PRODUCTS

Post

Ready to migrate to MacOS High Sierra, Apple's new operating system released this week?

Image

Blue Cat Audio plug-ins should run fine on this new system, with just a few minor limitations and changes. Check out our plug-ins compatibility test results for more information.

Return to “Blue Cat Audio”