Tracktion 7 - No longer hear any audio for playback, but...

Discussion about: tracktion.com
GC65
KVRer
20 posts since 6 May, 2019

Post Wed May 15, 2019 4:28 am

Agreed, but what information -specifically- would assist you and others in determining the problem?

The exclamation point says there is no audio out chosen, yet there is, I can hear the drums. There is not exclamation error for the guitar, which I cannot hear.

chico.co.uk
KVRAF
2252 posts since 17 Jun, 2003

Re: Tracktion 7 - No longer hear any audio for playback, but...

Post Wed May 15, 2019 6:35 am

Can you post a screengrab of the right hand side of the screen, where the MT-PowerDrumkit is on the track, and the properties panel, when you have one of the tracks selected that's going to MT-PowerDrumkit?

With the best will in the world, that's the third time I've asked for the same thing
"my gosh it's a friggin hardware"

GC65
KVRer
20 posts since 6 May, 2019

Re: Tracktion 7 - No longer hear any audio for playback, but...

Post Wed May 15, 2019 7:05 am

I apologize Chico, I had explained the situation and thought I had a picture of that track but I did not. Here it is.

In this setting I can hear all the drum tracks with the ! just fine. Remove the VST in the lower right, track 1 guitar comes back on but drums off. Was this the screen shot you wanted?
You do not have the required permissions to view the files attached to this post.

GC65
KVRer
20 posts since 6 May, 2019

Re: Tracktion 7 - No longer hear any audio for playback, but...

Post Wed May 15, 2019 7:07 am

In addition: I CAN REPRODUCE THIS ISSUE ON A DIFFERENT MODEL LAPTOP

The one in all the pictures is a Lenovo T420S with Windows x64 Pro all the latest updates as well as the latest tracktion.

System 2 - Lenovo Yoga, same OS and latest updates, same tracktion. Installed fresh traction, ASIO4ALL, did not install the Behringer driver, ran a test microphone track 1 "Test 123, test 123" works fine, sounds fine.

Track 2, added VST MT Power Drums, chose a random groove, imported to track 2, plays fine, clear but unfortunately Track 1 vocal audio test is now silent, like system 1.

chico.co.uk
KVRAF
2252 posts since 17 Jun, 2003

Re: Tracktion 7 - No longer hear any audio for playback, but...

Post Wed May 15, 2019 7:39 am

Okay, so what you've done is put the MT power drumkit on the master out, not on an individual track. That's your problem

That plugin only takes midi input, so it'll now get all the midi input from all the tracks, and generate drum noises, that will work, but it blocks any audio sent to it, so you can't hear your guitar.

What you actually want to do, is create a new track, call it MT Power Drumkit, and put that VST just to the left of the volume/pan on that track, and then on each of your midi tracks, point those to that new track. Leave your guitar going to the default audio out

That's one way of doing it. Another way would be to use send and return filters, again to send the midi to a new track, with your Drum VST on it

A third way of doing it would be to wrap the MT Power Drumkit in a rack filter, and put that rack filter on each track that makes a drum sound, just to the left of the volume/pan filter.

When i get a bit more time, i'll mock something up in an edit to show you what i mean, if that doesn't make sense

But yeah, you can't have the Drumkit vst there, that's your master out, and that vst will block any tracks that aren't midi from making noise
Last edited by chico.co.uk on Wed May 15, 2019 1:37 pm, edited 1 time in total.
"my gosh it's a friggin hardware"

chico.co.uk
KVRAF
2252 posts since 17 Jun, 2003

Re: Tracktion 7 - No longer hear any audio for playback, but...

Post Wed May 15, 2019 7:52 am

Set it up like this ... Where I've got the "Battery 4" plugin, put your MT Power-Drumkit there, on it's own new track, with that plugin just to the left of the volume and pan control

Then select each drum track, like I've selected the one called "Main Open HH" and look down in the properties panel where it says "Track Destination". Click on that, and change it from "Default Output" to the track called "MT Power Drumkit"
Screenshot 2019-05-15 at 16.49.15.png
You do not have the required permissions to view the files attached to this post.
"my gosh it's a friggin hardware"

GC65
KVRer
20 posts since 6 May, 2019

Re: Tracktion 7 - No longer hear any audio for playback, but...

Post Wed May 15, 2019 7:55 am

Thanks Chico! I will give that a try a bit later today and if that works, which I believe/hope it will, I will post a screen shot and perhaps detail what I did wrong so that it may help others in the future. Appreciate your time and quick responses on this!

Thanks!

GC65
KVRer
20 posts since 6 May, 2019

Re: Tracktion 7 - No longer hear any audio for playback, but...

Post Wed May 15, 2019 7:36 pm

Hello everyone! Just wanted to say that Chicos suggestion was spot on 100% and solved all my problems! I am back in action once again and thanks so much Chico for the help, very much appreciated!

Case closed

:)

fde101
KVRist
104 posts since 16 Mar, 2017

Re: Tracktion 7 - No longer hear any audio for playback, but...

Post Thu May 16, 2019 1:53 am

One picture is worth a thousand words... glad you are up and running.

Return to “Tracktion”