11.5.7 unusable VST3s

Discussion about: tracktion.com
KVRist
133 posts since 4 Oct, 2019 from France

Post Mon Mar 29, 2021 6:06 am

Hello,
since 11.5.7 version, I get many, many graphic issues with my VST3s.

Somes examples with my Cakewalk VST3s and all Arturia which have become unusable...

Thanks in advance.
You do not have the required permissions to view the files attached to this post.
Waveform 11.5.17, Windows 10

KVRian
758 posts since 3 May, 2005 from Victoria, BC

Post Mon Mar 29, 2021 9:56 am

This was fixed in the JUCE Framework we used, unfortunately the fix came to late for the 11.5,9 that was just released. This fix will be in the next Waveform.

KVRist

Topic Starter

133 posts since 4 Oct, 2019 from France

Post Mon Mar 29, 2021 10:59 am

Ok, many thanks :tu:
Waveform 11.5.17, Windows 10

KVRer
5 posts since 11 Mar, 2019

Post Mon Mar 29, 2021 12:12 pm

Is there an ETA on when the fix for this will be available?

KVRist
40 posts since 6 Mar, 2010

Post Wed May 05, 2021 5:22 am

Yes, please, any ETA?

KVRian
758 posts since 3 May, 2005 from Victoria, BC

Post Wed May 05, 2021 5:26 am

Can you try https://www.dropbox.com/s/qgl2b73mc43jv ... 2.exe?dl=0 and let me know if it's fixed

KVRist

Topic Starter

133 posts since 4 Oct, 2019 from France

Post Wed May 05, 2021 7:12 am

It seems to be fixed, many thanks! :tu:
Waveform 11.5.17, Windows 10

KVRist

Topic Starter

133 posts since 4 Oct, 2019 from France

Post Thu May 06, 2021 7:45 am

Ok, GUI issues are fixed but many other new issues with VST3s:
- pitch wheel is not at 0 (low position instead) when inserting AAS plugins and others, and new position not saved with edit,
- no sound at all for Cakewalk Rapture Pro,
- no sound for Arturia plugins until we change the first preset, but still no sound when quit and relaunch Waveform.

And I think I've not seen everything...

Thanks in advance :tu:
Waveform 11.5.17, Windows 10

KVRian
758 posts since 3 May, 2005 from Victoria, BC

Post Thu May 06, 2021 11:47 am

Can you confirm if this build fixes it: https://www.dropbox.com/s/vaj8oz6awt32e ... 4.exe?dl=0

KVRist

Topic Starter

133 posts since 4 Oct, 2019 from France

Post Fri May 07, 2021 4:23 am

All VST3s issues are fixed with this last version, even old bugs with Amplesound VST3s (Pitchbend and Modwheel that didn't work)!

Many thanks for your quick response :tu:
Waveform 11.5.17, Windows 10

KVRer
3 posts since 8 May, 2021

Post Sat May 08, 2021 8:32 am

I've downloaded this version and I've no more problems with VST3 plugins.
Unfortunately I'm actually experiencing problems with all the automations, it doesn't let me write an automation curve for any parameter in any vst plugin (x64, VST2, VST3).

KVRian
758 posts since 3 May, 2005 from Victoria, BC

Post Sat May 08, 2021 9:39 am

xmasblue wrote:
Sat May 08, 2021 8:32 am
I've downloaded this version and I've no more problems with VST3 plugins.
Unfortunately I'm actually experiencing problems with all the automations, it doesn't let me write an automation curve for any parameter in any vst plugin (x64, VST2, VST3).
I can't reproduce this. Anybody else seeing it?

KVRist

Topic Starter

133 posts since 4 Oct, 2019 from France

Post Sat May 08, 2021 10:32 am

No problem here...
How do you write automation usually?
Waveform 11.5.17, Windows 10

KVRer
3 posts since 8 May, 2021

Post Sun May 09, 2021 3:02 am

"Add new automation track -> select the parameter I want to modulate and then write the modulation"
But now when I try to write the modulation it doesn't appear any flat curve to write the points on.
This happened to me with Khz Toolbox plugins, TAL software, NI Kontakt and Arturia Pigments, with Tracktion Daw Essentials it shows the curve but it doesn't let me modulate it or create modulation points.
Maybe it is a problem only in my version, can you help me solving that?

KVRist

Topic Starter

133 posts since 4 Oct, 2019 from France

Post Sun May 09, 2021 5:38 am

Personally, I drag the "+" (under the "A") on my vst and choose the parameter I want to automate.
So it creates a new automation track.
Sometimes, when the parameter is at the max value or the min value, you don't see the curve because it's red and the borders of the selected automation track is also red! You have to deselect your automation track to see the curve...
When you see the curve, can you create points on it?
Is automation write mode armed when you write with a controller?
Waveform 11.5.17, Windows 10

Return to “Tracktion”