usb keyboard does not work with zynaddsubfx,yoshimi or zyn-fusion demo - yet works w/ other synths!

Official support for: zynaddsubfx.sourceforge.net
KVRer
2 posts since 14 Apr, 2017

Post Fri Apr 14, 2017 4:31 pm

looking for some help with getting my usb keyboard working with zynaddsubfx or even yoshmi or zyn-fusion.

oddly, it works just fine with other synths like amsynth or qsynth so i think that rules out the hardware as the issue. im using it with an ubuntu 16.04 64bit laptop and the keyboard itself is an m-audio keystation mini32.
i get the same results with yoshimi, zyn-fusion, and zynaddsubfx standalone (ive tried the alsa version and jack version). because i am on a linux distro i am using qjackctrl

with yoshimi, i can never get yoshimi to show up in the "alsa" tab of qjackctrl so i can never connect it to the keyboard

with zynaddsubfx or zyn-fusion (jack version) I see zyn show up under the audio tab and midi tab but not the alsa tab.

with zynaddsubfx or zyn-fusion (alsa version) I see zyn show up as a writable client on the alsa tab but it does not show up in the audio tab (so cant connect it to system output) or midi tab.

on zyn-fusion, when I press keys on my usb keyboard I can see the same keys light up on the virtual keyboard of zyn-fusion but still I get no sound coming out and that is in both the alsa version (I guess that is obvious since zyn didnt show up in the audio tab) and the jack version (after I connect everything in the audio, midi and alsa tabs – but again, zyn doesnt show up in the alsa tab)

under the qjackctrl settings params Ive tried diff drivers like the “alsa” driver and also different midi drivers like “seq” but still I get no sound out from pressing the usb keyboard’s keys.

Any ideas are appreciated, and thanks in advance!

KVRian
536 posts since 21 Oct, 2008 from USA

Post Fri Apr 14, 2017 6:49 pm

First as a note, theses forums are not built for discussions on yoshimi.


As per your problem, you want to have ALSA MIDI and JACK audio. This is a pretty common setup and is the default when zyn isn't launched with a desktop shortcut. To see this behavior, just run 'zynaddsubfx' from a run-program dialog or from a terminal (both the zynaddsubfx or zyn-fusion version).

Additionally, the MIDI/audio drivers can be changed during runtime. These options haven't been exposed in zyn-fusion, but in the zynaddsubfx UI, look for File->Nio Settings. The subwindow that this menu option spawns will let you change the options at runtime.

Lastly, many users and applications seem to prefer using JACK audio & MIDI. To expose your physical keyboard to JACK MIDI you may want to use a tool such as a2jmidid.
One of the developers on the ZynAddSubFX open source synth
The author of the Zyn-Fusion UI for ZynAddSubFX

KVRer

Topic Starter

2 posts since 14 Apr, 2017

Post Sat Apr 15, 2017 11:12 pm

Thanks for the feedback. I am still at a loss, I tried messing with a2jmidid but didn't get anywhere with it, I could never get a2jmidid to show up in the alsa tab so I could never connect the usb keyboard to it.

Below are some aconnect outputs that might tell a different or better story than I can right now. I am kind wondering if there is some kind of root vs non-root funny business going on right now. I had a similar, if not the same, issue with Ubuntu 10.x where I think it was some kind of root vs non-root order of things I had to do. Please let me know if the aconnect outputs below shed any light: (in the middle is a example with amsynth which works fine)

####### aconnect -l output when zynaddsubfx (jack version) is connected to system in audio tab
####### I get sound output from the virtual keyboard in zynaddsubfx but cant connect zyn to the usb keyboard
client 0: 'System' [type=kernel]
0 'Timer '
1 'Announce '
Connecting To: 128:0, 129:0
client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'
Connecting To: 129:0[real:0]
Connected From: 129:0
client 20: 'Keystation Mini 32' [type=kernel]
0 'Keystation Mini 32 MIDI 1'
Connecting To: 129:0[real:0]
Connected From: 129:0

####### aconnect -l output when amsynth is connected to m-audio keystation mini32, this works fine #######
client 0: 'System' [type=kernel]
0 'Timer '
1 'Announce '
Connecting To: 128:0, 129:0
client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'
Connecting To: 129:0[real:0]
Connected From: 129:0
client 20: 'Keystation Mini 32' [type=kernel]
0 'Keystation Mini 32 MIDI 1'
Connecting To: 129:0[real:0], 130:0
Connected From: 129:0
client 130: 'amsynth' [type=user]
0 'MIDI IN '
Connected From: 129:0, 20:0
1 'MIDI OUT '
Connecting To: 129:0[real:0]

####### aconnect -l output when zynaddsubfx (alsa version) is connected to m-audio keystation mini32
client 0: 'System' [type=kernel]
0 'Timer '
1 'Announce '
Connecting To: 128:0, 130:0
client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'
Connecting To: 130:0[real:0]
Connected From: 130:0
client 20: 'Keystation Mini 32' [type=kernel]
0 'Keystation Mini 32 MIDI 1'
Connecting To: 130:0[real:0], 129:0
Connected From: 130:0
client 129: 'ZynAddSubFX' [type=user]
0 'ZynAddSubFX '
Connected From: 130:0, 20:0

KVRian
536 posts since 21 Oct, 2008 from USA

Post Sun Apr 16, 2017 6:52 am

a2jmidid creates copies of ALSA MIDI ports for JACK MIDI, not visa-versa. If this doesn't make sense to you I would recommend running 'zynaddsubfx -I alsa -O jack' instead.
One of the developers on the ZynAddSubFX open source synth
The author of the Zyn-Fusion UI for ZynAddSubFX

KVRist
93 posts since 25 Feb, 2013 from United States

Post Tue Apr 18, 2017 9:50 pm

Something to bear in mind is that "a2jmidid -e" presents your hardware (ALSA) MIDI devices as JACK MIDI connections. Even if you get Zyn to hook up on the ALSA side with Fundamental's advice, this trick will help with other instruments such as OBXD which presents only JACK MIDI.

KVRer
1 posts since 27 Dec, 2016

Post Mon Nov 01, 2021 8:04 am

I had the same problem and solved it by setting the MIDI receive channel in said plugins to the same value as the MIDI transmit channel of my keyboard. It happened to be other than 1, which is what Yoshimi et al expect by default.

Return to “ZynAddSubFX”