ConvertWithMoss (prev. MultisampleGenerator) - convert multisamples from WAV,multisample,SFZ,SoundFont2,Decent Sampler

User avatar
KVRAF

Topic Starter

2913 posts since 13 May, 2004

Post Thu Jul 08, 2021 3:06 am

zfigz wrote:
Thu Jul 08, 2021 1:56 am
okay, progress. now my error is as follows:

Code: Select all

Could not detect a name.
As I wrote: please upload me the files somewhere (PM me) then I can check what's the issue.

KVRist
126 posts since 26 Jan, 2006

Post Thu Jul 08, 2021 3:23 pm

oops, sorry about that. will do / cheers <3

User avatar
KVRist
90 posts since 21 Feb, 2010

Post Fri Jul 16, 2021 8:13 pm

Hi

There is a Folder lets say named [Ultrasound]
In that Folder is a
  • "sf2_smpl.wav" (5Mb). This sample contains all the different sounds of all *.sfz-files.
  • 2 Folders named [000] and in this Case one is named [128]
    in the [000] are all *.sfz in [128] is one named standard.sfz
So i have a constellation that will not work. This Files was created around 2015, if that helps.

WAV -> converts the sample just in a bws-mult, and dont split any sound
SF2 -> too much errors, does nothing
SFZ -> creates empty bws-mult from the Folder [000]

I try also put all files together but:

Code: Select all

Sample file does not exist: T:\xxxx\Production\Soundpool\soundfont-convert\Ultrasound_Classic_sf2\..\sf2_smpl.wav
\8.4.2 MIDI Note-On Velocity to Filter Cutoff
\8.4.8 MIDI Continuous Controller 91 to Reverb Effects Send
\8.4.9 MIDI Continuous Controller 93 to Chorus Effects Send
\8.4.10 MIDI Pitch Wheel to Initial Pitch Controlled by MIDI Pitch Wheel Sensitivity

Sample file does not exist: T:\xxxx\Production\Soundpool\soundfont-convert\Ultrasound_Classic_sf2\..\sf2_smpl.wav
\8.4.2 MIDI Note-On Velocity to Filter Cutoff
\8.4.8 MIDI Continuous Controller 91 to Reverb Effects Send
\8.4.9 MIDI Continuous Controller 93 to Chorus Effects Send
\8.4.10 MIDI Pitch Wheel to Initial Pitch Controlled by MIDI Pitch Wheel Sensitivity

Sample file does not exist: T:\xxxx\Production\Soundpool\soundfont-convert\Ultrasound_Classic_sf2\..\sf2_smpl.wav
\8.4.2 MIDI Note-On Velocity to Filter Cutoff
\8.4.8 MIDI Continuous Controller 91 to Reverb Effects Send
\8.4.9 MIDI Continuous Controller 93 to Chorus Effects Send
\8.4.10 MIDI Pitch Wheel to Initial Pitch Controlled by MIDI Pitch Wheel Sensitivity
what should i do now?

Thank you for that Tool...it works good...in some cases.

User avatar
KVRAF

Topic Starter

2913 posts since 13 May, 2004

Post Sat Jul 17, 2021 12:35 am

capracan wrote:
Fri Jul 16, 2021 8:13 pm
Hi

There is a Folder lets say named [Ultrasound]
In that Folder is a
  • "sf2_smpl.wav" (5Mb). This sample contains all the different sounds of all *.sfz-files.
  • 2 Folders named [000] and in this Case one is named [128]
    in the [000] are all *.sfz in [128] is one named standard.sfz
So i have a constellation that will not work. This Files was created around 2015, if that helps.

what should i do now?

Thank you for that Tool...it works good...in some cases.
If you send me the file I can have a look.

User avatar
KVRAF

Topic Starter

2913 posts since 13 May, 2004

Post Wed Jul 21, 2021 1:36 pm

ConvertWithMoss # 2.0 is out!

Get it from http://mossgrabers.de
  • New: Added reading and writing of DecentSampler preset and library files.
  • New: Improved note detection from file names.
  • Fixed: SFZ detector - global_label was not read.
  • Fixed: SFZ parser - Comments at line end were not removed which conflicted with attribute values.
  • Fixed: WAV detector - Crash if left and right mono sample had different lengths.
  • Fixed: Creating folders for SFZ could raise an exception.
  • Fixed: Source and destination tabs could be removed.
https://youtu.be/Jwmj6oqqLJ8

Enjoy!

User avatar
KVRAF

Topic Starter

2913 posts since 13 May, 2004

Post Sun Jul 25, 2021 4:08 am

ConvertWithMoss 2.1 is online!

Get it from http://mossgrabers.de
  • Fixed: WAV detector did also deliver results for empty folders.
  • Fixed: Setup for created DecentSampler Filter and Reverb is working now.
Enjoy!

User avatar
KVRAF

Topic Starter

2913 posts since 13 May, 2004

Post Sun Jul 25, 2021 10:28 am

Argh, just noticed that reading loops from WAV files was broken.

So, 2.1.1 is online!

KVRist
126 posts since 26 Jan, 2006

Post Fri Jul 30, 2021 9:16 pm

🙇.

KVRist
126 posts since 26 Jan, 2006

Post Sat Jul 31, 2021 9:25 am

okay, some progress here but i'm getting the following error:

Code: Select all

Could not create multisample: Attempt to combine Mono splits into Stereo files but there are more than two files per note.
my pattern is _layer001_ with files like:
G#6_layer001_sft_stac.wav
G#6_layer002_sft_stac.wav
G#6_layer003_sft_stac.wav

User avatar
KVRAF

Topic Starter

2913 posts since 13 May, 2004

Post Sat Jul 31, 2021 9:47 am

zfigz wrote:
Sat Jul 31, 2021 9:25 am
okay, some progress here but i'm getting the following error:

Code: Select all

Could not create multisample: Attempt to combine Mono splits into Stereo files but there are more than two files per note.
my pattern is _layer001_ with files like:
G#6_layer001_sft_stac.wav
G#6_layer002_sft_stac.wav
G#6_layer003_sft_stac.wav
You need to put a star where the layer numbering is like:
_layer*_

KVRist
126 posts since 26 Jan, 2006

Post Sat Jul 31, 2021 5:02 pm

ouf, totally missed that. thank you 🙇

edit: heh, now i'm getting the following when using _layer*_:

Code: Select all

Could not detect a name.
i'm sure it's a user error on my part, just not sure what.

User avatar
KVRAF

Topic Starter

2913 posts since 13 May, 2004

Post Sun Aug 01, 2021 5:18 am

zfigz wrote:
Sat Jul 31, 2021 5:02 pm
ouf, totally missed that. thank you 🙇

edit: heh, now i'm getting the following when using _layer*_:

Code: Select all

Could not detect a name.
i'm sure it's a user error on my part, just not sure what.
Can you please post your settings? And/or send me the files.

KVRist
126 posts since 26 Jan, 2006

Post Mon Aug 02, 2021 5:20 pm

they're the same files i sent earlier in the thread. i've attached a screenshot of my settings.
You do not have the required permissions to view the files attached to this post.

KVRist
126 posts since 26 Jan, 2006

Post Mon Aug 02, 2021 5:24 pm

ah, i i checked "Prefer folder name" and it worked !

noticed that the group meant for the highest velocity wasn't mapped up to 127 (max) but instead to like 126 (one or so less than max).

User avatar
KVRAF

Topic Starter

2913 posts since 13 May, 2004

Post Wed Aug 04, 2021 11:26 pm

zfigz wrote:
Mon Aug 02, 2021 5:24 pm
ah, i i checked "Prefer folder name" and it worked !

noticed that the group meant for the highest velocity wasn't mapped up to 127 (max) but instead to like 126 (one or so less than max).
Thanks for the info, will be fixed in the next update!

Return to “Controller Scripting”