Omnisphere 2 slow interface

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
Echoes in the Attic
KVRAF
9471 posts since 12 May, 2008

Post Mon Dec 06, 2021 9:24 am

I recently reinstalled Ominsphere on a new computer from the download installers and updated to latest versions. Put my third party libraries back as well. Everything is much faster than I remember on my last system. Preset switching is snappy. No more lagging when the wavetables are loaded. So I'll be curious to see if this changes over time.

legendCNCD
KVRian
1227 posts since 23 Sep, 2004 from Kocmoc

Post Mon Dec 06, 2021 9:47 am

For me it hasnt changed ever, always been fast and snappy.
Soft Knees - Demoscene - Live 10 - Diva - Omnisphere - Slate Digital VSX - TDR - Kush Audio - Fabfilter - PA - Valhalla - Fuse - Pulsar - NI - OekSound etc...

Echoes in the Attic
KVRAF
9471 posts since 12 May, 2008

Post Mon Dec 06, 2021 9:52 am

legendCNCD wrote:
Mon Dec 06, 2021 9:47 am
For me it hasnt changed ever, always been fast and snappy.
When did you first acquire Omnisphere? I've upgraded since V1, maybe that had something to do with it. I recently downloaded everything fresh.

iPlogger
KVRian
754 posts since 27 Oct, 2011 from Pacific Northwest

Post Mon Dec 06, 2021 10:21 am

I feel like the reports on the slow interface started right around the time they added the Hardware Integration. They pushed out a fix that fixed it for most people. It's been running fine for me. I think I ran into the initial problem and it was especially noticeable with multis, but got cleared up after an update. I have only had version 2 and updated it several times over the years on my laptop. I installed it on a new computer at the beginning of this year and it has been running fine. I run Omnisphere standalone, inside of Ableton Live and inside of PlugInGuru's Unify.

noiseboyuk
KVRAF
3591 posts since 25 Jan, 2007

Post Mon Dec 06, 2021 10:28 am

iPlogger wrote:
Mon Dec 06, 2021 10:21 am
I feel like the reports on the slow interface started right around the time they added the Hardware Integration.
90% sure it considerably predated HW integration in 2.6 - I think around 2.4 it was being much discussed.
http://www.guyrowland.co.uk
http://www.sound-on-screen.com
W10, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2019 Ultimate, Cubase Pro 10.5
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD

legendCNCD
KVRian
1227 posts since 23 Sep, 2004 from Kocmoc

Post Tue Dec 07, 2021 5:50 am

Echoes in the Attic wrote:
Mon Dec 06, 2021 9:52 am
legendCNCD wrote:
Mon Dec 06, 2021 9:47 am
For me it hasnt changed ever, always been fast and snappy.
When did you first acquire Omnisphere? I've upgraded since V1, maybe that had something to do with it. I recently downloaded everything fresh.
When 2.0 was released. I've just updated/upgraded it since.
Soft Knees - Demoscene - Live 10 - Diva - Omnisphere - Slate Digital VSX - TDR - Kush Audio - Fabfilter - PA - Valhalla - Fuse - Pulsar - NI - OekSound etc...

User avatar
zvenx
KVRAF
10544 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Tue Dec 07, 2021 6:17 am

I too have never had the anything but fast and snappy on either mac or windows, and I started from Atmosphere days.
rsp
sound sculptist

Ah_Dziz
KVRAF
3507 posts since 2 Jul, 2005

Post Tue Dec 07, 2021 8:02 am

pluton wrote:
Thu Jan 16, 2020 7:24 pm
Does omnisphere need extra fast video card or something?
I’m using onboard graphics,
Running latest updates.

But omnisphere is the only plugin that has laggy interface,
it takes about 3-4 seconds to switch between parts,
and even longer when selecting categories in the browser.
All the Spectrasonics gear I have is a bit sluggish from loading up into the host to swapping sound sources. The time it takes is still far less than "3-4" seconds. More like 1 second. Rmx is slower on my system but still under 2 seconds for pretty much anything.

I have a 5 year old 30 dollar Nvidia 2GB fanless card in my system. I use both plugins at their default size which is the only graphical variable I can think of unless you are running the library from an old mechanical drive or something else that would be a data bottleneck.
Don't F**K with Mr. Zero.

Return to “Instruments”