Omnisphere automation parameters not visible in BWS

Official support for: bitwig.com
RELATED
PRODUCTS

Post

Hi all,

I'm not sure if this is a Bitwig problem, Omnisphere problem, or user error. Would love any confirmation/instructions from the wisdom of the collective.

Automation parameters are not visible in the BWS plug-in device or through the automation lanes for Omnisphere vst3. The parameters for Omnisphere are visible in at least one other DAW: Logic Pro X. And other plugin parameters (like Synthmaster Player) are visible in the BWS device and automation lanes.

I could have sworn that the parameters were visible in the past, but maybe I'm mistaken.

Steps to Recreate
1) Add Omnisphere plugin as instrument device on instrument track.
2) Set a parameter in Omnisphere to automatable by selecting "Enable Host Automation"
3) No automation parameter is visible in the device or in the track automation lane.

2021 M1 Pro, 14" MacBook Pro
Bitwig 4.0.7 (and 4.1 Beta 5)
Omnisphere 2.8.1c arm

Thank you in advance for your help.

Post

I had the same problem and reported it to Spectrasonics. The same problem exists in Reaper. The solution for me was using the VST2 which Spectrasonics suggested. I have to 'show hidden plugins' to see the VST2 in Bitwig. Haven't found a way to 'prefer' that one.

Post

valankar wrote: Sat Nov 20, 2021 8:44 am I had the same problem and reported it to Spectrasonics. The same problem exists in Reaper. The solution for me was using the VST2 which Spectrasonics suggested. I have to 'show hidden plugins' to see the VST2 in Bitwig. Haven't found a way to 'prefer' that one.
I've had this same issue. Does using the VST2 version give you a list of actual parameters? Mine still gives a generic list of numbers with no names.

Post

By default they show up like this:
1.jpg
Then you need to enable host automation for a parameter:
2.jpg
Which then shows up in Bitwig:
3.jpg
You do not have the required permissions to view the files attached to this post.

Post

Yes thats right but when you reopen a project and open the Omni GUI the Value of a Modulators changes
viewtopic.php?t=573243

Post

valankar wrote: Sat Nov 20, 2021 11:56 am Then you need to enable host automation for a parameter:
That works, thanks!

Post

I'm having the same problem with the VST3. Much less usable if you can't automate anything.

Post

I'm new to Bitwig, and am testing it mostly to use the Modulating features and Omnisphere I use a LOT. Oddly, in the same project things worked fine with my first instance of Omnisphere (I could enable host automation and see the name of what I could modulate at the bottom) but for the 2nd instance I couldn't modulate anything (nothing shows up at all at the bottom). How can that be? As far as I know I did the same thing when I added each instance of Omnisphere.
I was going to test using Omnisphere as a VST 2 but can only find it as a VST3 -- any ideas how to get the VST2 version?

Post

Ultrabra wrote: Tue Dec 07, 2021 5:42 am I'm new to Bitwig, and am testing it mostly to use the Modulating features and Omnisphere I use a LOT. Oddly, in the same project things worked fine with my first instance of Omnisphere (I could enable host automation and see the name of what I could modulate at the bottom) but for the 2nd instance I couldn't modulate anything (nothing shows up at all at the bottom). How can that be? As far as I know I did the same thing when I added each instance of Omnisphere.
I was going to test using Omnisphere as a VST 2 but can only find it as a VST3 -- any ideas how to get the VST2 version?
You need to enable parameters for each instance. If you have the setting on to hide redundant VST2, you won't see it. You can click show redundant plugins in the browser though to bring it up or uncheck that in preferences.

Post

valankar wrote: Sat Nov 20, 2021 8:44 am I had the same problem and reported it to Spectrasonics. The same problem exists in Reaper. The solution for me was using the VST2 which Spectrasonics suggested. I have to 'show hidden plugins' to see the VST2 in Bitwig. Haven't found a way to 'prefer' that one.
Simplest way would be to physically delete the VST3 plugin. The VST2 should then display all the time.
Bitwig 5.1.6 + Akai MIDIMix + Launchpad X + MuLab 9.3.18
Roli Lumi Keyboard x 2 + Universal Audio Apollo Twin X
Mac Mini M1 16GB/4TB + macOS 14.4 Sonoma

Post

Is there any benefit from using the VST3 Omnisphere, over the VST2?

Post

No

Post

Echoes in the Attic wrote: Tue Dec 07, 2021 5:51 am
Ultrabra wrote: Tue Dec 07, 2021 5:42 am I'm new to Bitwig, and am testing it mostly to use the Modulating features and Omnisphere I use a LOT. Oddly, in the same project things worked fine with my first instance of Omnisphere (I could enable host automation and see the name of what I could modulate at the bottom) but for the 2nd instance I couldn't modulate anything (nothing shows up at all at the bottom). How can that be? As far as I know I did the same thing when I added each instance of Omnisphere.
I was going to test using Omnisphere as a VST 2 but can only find it as a VST3 -- any ideas how to get the VST2 version?
You need to enable parameters for each instance. If you have the setting on to hide redundant VST2, you won't see it. You can click show redundant plugins in the browser though to bring it up or uncheck that in preferences.
OK thanks. I found the VST2 as "redundant", and that seems to work ok for the modulating.

Post

Thank you Valankar for the screenshots!

Post

This has been fixed in the latest updates. They didn't show on the splash screen but they are in your account now. VST3 parameters now showing in bitwig, yeah!

Sweet resizable GUI update for Stylus RMX too...

Return to “Bitwig”