yikes vst2 vst3 different id's

Official support for: sugar-bytes.de
RELATED
PRODUCTS

Post

I found out today that the four SugarBytes plugins that I have now have vst3 versions.. YES!!!

But there is an issue.
on pc, the vst3 has the same plugin id as vst2 as they should, so in cubendo I only see the vst3 and although I haven't checked, i should be able to open old projects that used the vst2 versions fine with the vst3 versions.

on mac however.
I see both vst2 and vst3, which means they have different version ids and spells trouble.

So I made a test to confirm..

A Cubendo project created on mac, two tracks.. one track with all the vst2 versions four I have and the second track with the vst3 versions of the four sugarbytes I have..

I opened it on pc and yep.. indeed..

Houston there is a problem.

The PC vst3 see the mac vst2 fine, but since apparently for whatever reason the vst3 on mac have different plugin id's I get an error notification.

I have also included the project if anyone wants to look at it.

https://www.dropbox.com/s/xhub85mi1eh7j ... t.cpr?dl=0

rsp
You do not have the required permissions to view the files attached to this post.
sound sculptist

Post

Tal had a similar issue in the early days of the J-8. Fortunately it was spotted very quickly and this was what they decided to do which I think was the cleanest way to do it.

(though in sugarbytes case it is the other way around.. the issue is on the mac vst3 not the pc vst3, and it is the mac vst3 that would need to be replaced)

rsp
You do not have the required permissions to view the files attached to this post.
sound sculptist

Post

They have to fix that fast. This can destroy cross-platform workflows and not only that…

Post

Yep..
Rsp
sound sculptist

Post

Yes, we are aware of the described issue and now released updates to all our plug-ins for better migration from VST2 to VST3.

Unfortunately this update will break existing projects with VST3 plug-ins from Sugar Bytes on macOS.
If you are affected please read the following instructions carefully before installing the update:

- Open your project(s)
- Save the state as preset within the Sugar Bytes plug-in
- Download and update your products: https://sugar-bytes.de/account
- Load your project and reassign missing plug-ins
- Load the preset you previously saved

If you need additional assistance feel free to contact us: support@sugar-bytes.de

We are sorry for any inconvenience,
Your Sugar Bytes Team

Post

Got it, installed it and so far so good.
Much appreciated.
rsp
sound sculptist

Post

A couple of the new VST3 versions don't seem to work on Mac (Cyclop, Egoist, and Factory) - within Bitwig I just receive an "Could not create plugin instance: Could not create VST3 instance for class id ... A null component was returned." error message.

Post

Hi spu7nic,

thanks for your report! I've tried it here and it works for me but sometimes it only works after a rescan.
So have you already tried to right-click Cyclop, Egoist, and Factory in the Browser - Devices window of Bitwig and used the Rescan Plug-in option? What you could also try is to load the VST2 version instead and close it again. Does the VST3 versions work for you then? If not, do at least the standalone versions work for you?

Best,
Nadine

Post

The rescanning did indeed resolve my issues :) - thanks!

Return to “Sugar Bytes”