1. Plugins
  2. »
  3. AIR Music Technology
  4. »
  5. AIR Instrument Expansion Pack 3 Complete
  6. »
  7. Reviews

AIR Instrument Expansion Pack 3 Complete

 My KVR
Air Instrument Expansion Plugin by AIR Music Technology
$339.00Buy BUYING!X
Upgrades

Upgrade Licenses

Upgrade from ANY AIR Music software $74.99Buy Now BUYING!X

AIR Instrument Expansion Pack 3 Complete has an average user rating of 1.00 from 1 review

Rate & Review AIR Instrument Expansion Pack 3 Complete

User Reviews by KVR Members for AIR Instrument Expansion Pack 3 Complete

Reviewed By psycho45039 [read all by] on 17th September 2019
Version reviewed: Latest on Mac
2 of 2 people found this review helpful.
Was it helpful to you? Yes No

Great sounding plugins, horrible customer support as in non-existent. I had 2 HD's die during a recent move. One had copies of installers and the other contained sample data for my various software instruments. The only company that hasn't went above and beyond in helping get everything reinstalled is this company. as amateur of fact they have never replied to asking for help. So from my experience my best recommendation is to stay away from them.

Latest 1 review from a total of 1

Comments & Discussion for AIR Music Technology AIR Instrument Expansion Pack 3 Complete

Discussion
Discussion: Active
waynekhin
waynekhin
12 August 2016 at 3:59am

AIR Instrument Expansion Pack 3 Complete and Pro Tools 12

After installation, I have the problems inserting the following synth plugins: Velvet, Vacuum Pro, Hybrid, theRiser, Loom, Strike, Structure. When inserting them in a instrument track, the error message (below) will pop out and Pro Tools crashes.

Here is the error message: "Fatal Error - Structure, Structure could not be loaded. Please contact the software publisher for support using this software. Error details: Relation query was attempted when disallowed."
------
I have the same error messages for all the troubled plugins, except the name of the plugin is different in the error. Please help.

Link to another post with photo of the error message: http://gsfn.us/t/4ypa1

Fleer
Fleer
14 August 2016 at 7:11pm

Same here today. Happens with Loom, but also with Eventide Blackhole, Soundtoys and AutoTheory.

I think it's iLok related. Anyone has ideas?

THIS POST HAS BEEN REMOVED

Please log in to join the discussion