DrivenByMoss - Bitwig extension for lots of controller devices (and more)

KVRer
6 posts since 12 Jul, 2005

Post Tue Jun 22, 2021 8:28 am

moss wrote:
Tue Jun 22, 2021 7:13 am
trigger303 wrote:
Tue Jun 22, 2021 5:11 am
Hello,
I started using DrivenByMoss for Reaper with Push2 recently, I've been surprised to see how smart and useful it is!
Thank you for developing this, Moss!

BTW I have a question about playing MIDI.
I want to choose MIDI channels at will when I play the notes on Note Mode.
I think this can be achieved by selecting "Midi Insert/Edit channel" setting in Preferences, but
it seems that the Reaper track always receives the notes on MIDI channel 1 regardless of the Preferences setting value.
Am I wrong ?

I'm using DrivenByMoss v12.2.2
That setting is only for entering sequencer notes. As a workaround you can change the MIDI channel either on the track settings in Bitwig or add a MIDI channel device on the track(s).
Thank you Moss! I understand. I'll try workaround.

KVRist
70 posts since 11 Jun, 2014

Post Tue Jun 22, 2021 12:45 pm

Hi, I'm using the generic flexi with an Akai MPK mini. Mainly I wanted to use the modes and map the rotaries to control track volumes, being able to switch to sets of 8 tracks. This somewhat works, but I'm having some issues. I've set a control to 'Modes: Item 1: Set Value'. When I use Relative (1-64 increments), the rotary only moves the volume in tiny amounts. If I then set 'Knob Sensitivity Default: +100' it is a bit better, but still requires a lot of knob turning. I tried the other knob modes and none work too well. One even makes both clockwise and counter-clockwise decrease the fader.

If I don't use modes and instead have Track: Track 1 Set Volume, it works better, but I have to set Relative (1-63 increments). The only problem is clockwise lowers the fader, and counter-clockwise raises it, and I'd like it opposite.

Ideally I'd like to use modes if I can get it working, to be able to switch to device modes, etc. But not sure how to fix the knob resolution issue.

Thanks.

KVRer
2 posts since 8 Jul, 2006

Post Tue Jun 22, 2021 5:01 pm

Hi - I'm using KK Mk2S - When automating from the device parameter screen - All automation is type 'write' no read. My other controllers (including the Push 2 and Machine Jam do not have this issue - Would be nice to resolve. Thanks!

User avatar
KVRAF

Topic Starter

2868 posts since 13 May, 2004

Post Wed Jun 23, 2021 1:39 am

valankar wrote:
Tue Jun 22, 2021 12:45 pm
Hi, I'm using the generic flexi with an Akai MPK mini. Mainly I wanted to use the modes and map the rotaries to control track volumes, being able to switch to sets of 8 tracks. This somewhat works, but I'm having some issues. I've set a control to 'Modes: Item 1: Set Value'. When I use Relative (1-64 increments), the rotary only moves the volume in tiny amounts. If I then set 'Knob Sensitivity Default: +100' it is a bit better, but still requires a lot of knob turning. I tried the other knob modes and none work too well. One even makes both clockwise and counter-clockwise decrease the fader.

If I don't use modes and instead have Track: Track 1 Set Volume, it works better, but I have to set Relative (1-63 increments). The only problem is clockwise lowers the fader, and counter-clockwise raises it, and I'd like it opposite.

Ideally I'd like to use modes if I can get it working, to be able to switch to device modes, etc. But not sure how to fix the knob resolution issue.

Thanks.
I do not have that model but from looking at a picture of the device, aren't these absolute knobs?

User avatar
KVRAF

Topic Starter

2868 posts since 13 May, 2004

Post Wed Jun 23, 2021 1:41 am

Zola40 wrote:
Tue Jun 22, 2021 5:01 pm
Hi - I'm using KK Mk2S - When automating from the device parameter screen - All automation is type 'write' no read. My other controllers (including the Push 2 and Machine Jam do not have this issue - Would be nice to resolve. Thanks!
Could you please elaborate a bit more? I do not understand your issue.

KVRist
70 posts since 11 Jun, 2014

Post Wed Jun 23, 2021 4:22 am

moss wrote:
Wed Jun 23, 2021 1:39 am
valankar wrote:
Tue Jun 22, 2021 12:45 pm
Hi, I'm using the generic flexi with an Akai MPK mini. Mainly I wanted to use the modes and map the rotaries to control track volumes, being able to switch to sets of 8 tracks. This somewhat works, but I'm having some issues. I've set a control to 'Modes: Item 1: Set Value'. When I use Relative (1-64 increments), the rotary only moves the volume in tiny amounts. If I then set 'Knob Sensitivity Default: +100' it is a bit better, but still requires a lot of knob turning. I tried the other knob modes and none work too well. One even makes both clockwise and counter-clockwise decrease the fader.

If I don't use modes and instead have Track: Track 1 Set Volume, it works better, but I have to set Relative (1-63 increments). The only problem is clockwise lowers the fader, and counter-clockwise raises it, and I'd like it opposite.

Ideally I'd like to use modes if I can get it working, to be able to switch to device modes, etc. But not sure how to fix the knob resolution issue.

Thanks.
I do not have that model but from looking at a picture of the device, aren't these absolute knobs?
It can be set to absolute or relative with the Akai configuration program. I tried both.

KVRer
25 posts since 8 Sep, 2019

Post Wed Jun 23, 2021 10:15 am

Hello Moss,
Little problem with your last driver and generic flexi : I have an Arturia minilab mkii, but when I want to use the knobs to control the devices in Bitwig, they run very very very slowly, even if I put the knob sensivity to the maximum.

Everything was fine with your previous drivers. I've rechecked now with the 11 and it works fine but not with the 12.2 and 12.3. Any idea ?

User avatar
KVRer
17 posts since 14 Oct, 2020

Post Wed Jun 23, 2021 11:32 am

2021-06-23_22-28-10.png
OSC is broken in Bitwig 4.0 beta 5
At least in my configuration @ DrivenByMoss-12.3.0-Bitwig
You do not have the required permissions to view the files attached to this post.

User avatar
KVRAF

Topic Starter

2868 posts since 13 May, 2004

Post Thu Jun 24, 2021 12:15 am

artsense wrote:
Wed Jun 23, 2021 11:32 am
OSC is broken in Bitwig 4.0 beta 5
At least in my configuration @ DrivenByMoss-12.3.0-Bitwig
Thanks for the info. I can reproduce that, too. I reported it to Bitwig.

KVRer
15 posts since 22 May, 2019

Post Thu Jun 24, 2021 1:19 am

I have a problem with my launchpad pro (original), Bitwig 3.3.10 an latest DrivenByMoss extension.
Most of the time it doesn't react when in fader or device mode. Some "faders" on the launchpad work, but some not. So if I push a pad it doesn't react...
I installed the latest firmware on the launchpad. Note mode work ok.

KVRer
19 posts since 16 Jan, 2021

Post Thu Jun 24, 2021 1:26 pm

Hello. I've started using the Akai Fire and have run into an issue that I'm stuck on. In the Clip Launcher, after adding 4 clips to a track, trying to add a 5th using Alt+Rec throws an error "No empty slot in the current page. Please scroll down". As you can see in the attached image, I did scroll to the next "scene page" as indicated by the white outlines around the slots.

I'm still able to add clips with the mouse and record with over dub that way.

Thanks for any help on this! (and thanks for programming the Fire extension. Its a funky game changer)
You do not have the required permissions to view the files attached to this post.

KVRist
282 posts since 12 Jul, 2015

Post Fri Jun 25, 2021 5:45 am

Hello Moss !
One question .
Is it possible to configure knobs of the push 2 to go faster or slower regarding the parameter it controls ? I need to go really slow to control one and it's already to fast . That would be cool to have the ability to control the speed of rotation of the push knobs . Like a sensitivity parameter for each parameters you want to control with a knob.
Thanks !

KVRist
96 posts since 30 Jun, 2005 from Scotland

Post Fri Jun 25, 2021 8:55 am

carlca wrote:
Fri Jun 25, 2021 8:20 am
Has anyone used the Open Stage Control server together with a suitable web page that would provide an easy to use 4 x 4 drum pad to directly control Bitwig's Drum Machine device? Kind of an NI Maschine "on the cheap" kinda thing?
This might have what you're after :

https://github.com/kdejaeger/open-stage-control-bitwig

KVRist
96 posts since 30 Jun, 2005 from Scotland

Post Fri Jun 25, 2021 10:35 am

Doesn't the template on that Github page give you a drums section?

It looks like it should from the screentshots.

KVRist
96 posts since 30 Jun, 2005 from Scotland

Post Fri Jun 25, 2021 12:02 pm

Moss has YT vids on OSC here :

https://youtu.be/GEH7k1kp5U8

Return to “Controller Scripting”