1. Plugins
  2. »
  3. Best Service
  4. »
  5. ERA II Medieval Legends
  6. »
  7. Reviews

ERA II Medieval Legends

 My KVR
Medieval Instruments Plugin by Best Service

Comments & Discussion for Best Service ERA II Medieval Legends

Discussion
Discussion: Active
fizzicist
fizzicist
26 May 2015 at 5:56pm

I saw the pre-release info on ERA II last month. I was all ready to pre-order it when I noticed...AACCKK!! --- the Mac system requirements exclude OS X 10.8. FAIL!.

This keeps happening. By the time Apple fixes the bugs in their own software, and the developers fix their own compatibility issues, you can have maybe a year or two wherein the literally hundreds of audio and video apps and plug-ins that it takes to run a fully-functional workstation in an A/V project studio all work perfectly together.

Then it starts. One by one, apps start dropping support for a stable OS X version even before Apple does. It happened with 10.4. It happened with 10.6. And now it's happening again with 10.8. My question to both Apple and all of these developers is, "Do you people actually ever use your software in a production environment?"

Never mind. It's a rhetorical question. (sigh)

Please log in to join the discussion